Focal Point
[CLOSED] Issues with subordinate Paramaters

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/7971057331/m/3317067096

September 11, 2018, 04:24 PM
Max Nevill
[CLOSED] Issues with subordinate Paramaters
Hi All.

I'm trying to troubleshoot a dashboard with 2 parameters, each selected from a list box. The selection list of Parameter 2 is supposed to depend on Parameter 1.

What happens, is that any selection of Parameter 1 filters out ALL options from Parameter 2 instead of some of them. Hitting the run button results in empty reports with no data.

However, if I leave Parameter 1 alone, and select from Parameter 2, the dashboard reports work just fine.

How do I fix Parameter 1?

This message has been edited. Last edited by: FP Mod Chuck,


WebFocus 8.104
Windows 7 Entreprise, SP1
September 11, 2018, 05:36 PM
Doug
This sounds like a Chaining issue.
What's the sources of these two list boxes?
How many items are in each list box source?
Can you change them to Drop Down Lists (ComboBox)?
September 11, 2018, 07:31 PM
Max Nevill
Doug, the two list boxes refer back to the same table.

Parameter1 has 8 options, Parameter2 has about 150.

I tried changing them to drop down lists, but I still got the same error.


WebFocus 8.104
Windows 7 Entreprise, SP1
September 13, 2018, 11:51 AM
FP Mod Chuck
Max

You may want to consider using a fex that has BY parm1 BY parm2 and referencing that and chaining them that way.


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
September 14, 2018, 10:13 AM
Les J
Keep poking the bear and keep this post alive. Maybe one day they'll fix it.


WebFOCUS 8

Windows, All Outputs
September 20, 2018, 04:36 PM
Max Nevill
Hi Chuck,

The parameters are being used for filtering only and not displaying in the reports. I'm giving up and submitting this to tech support.


WebFocus 8.104
Windows 7 Entreprise, SP1