Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Issues with subordinate Paramaters
Go
New
Search
Notify
Tools
Reply
  
[CLOSED] Issues with subordinate Paramaters
 Login/Join
 
Gold member
posted
Hi All.

I'm trying to troubleshoot a dashboard with 2 parameters, each selected from a list box. The selection list of Parameter 2 is supposed to depend on Parameter 1.

What happens, is that any selection of Parameter 1 filters out ALL options from Parameter 2 instead of some of them. Hitting the run button results in empty reports with no data.

However, if I leave Parameter 1 alone, and select from Parameter 2, the dashboard reports work just fine.

How do I fix Parameter 1?

This message has been edited. Last edited by: FP Mod Chuck,


WebFocus 8.104
Windows 7 Entreprise, SP1
 
Posts: 82 | Location: Abbotsford BC | Registered: March 15, 2010Reply With QuoteReport This Post
Expert
posted Hide Post
This sounds like a Chaining issue.
What's the sources of these two list boxes?
How many items are in each list box source?
Can you change them to Drop Down Lists (ComboBox)?
 
Posts: 3045 | Location: Middle Tennessee [8204M Gen48 in Test&Prod] | Registered: February 23, 2005Reply With QuoteReport This Post
Gold member
posted Hide Post
Doug, the two list boxes refer back to the same table.

Parameter1 has 8 options, Parameter2 has about 150.

I tried changing them to drop down lists, but I still got the same error.


WebFocus 8.104
Windows 7 Entreprise, SP1
 
Posts: 82 | Location: Abbotsford BC | Registered: March 15, 2010Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Max

You may want to consider using a fex that has BY parm1 BY parm2 and referencing that and chaining them that way.


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
 
Posts: 1694 | Location: Customer Support | Registered: April 12, 2005Reply With QuoteReport This Post
Silver Member
posted Hide Post
Keep poking the bear and keep this post alive. Maybe one day they'll fix it.


WebFOCUS 8

Windows, All Outputs
 
Posts: 45 | Location: Phoenix | Registered: March 01, 2018Reply With QuoteReport This Post
Gold member
posted Hide Post
Hi Chuck,

The parameters are being used for filtering only and not displaying in the reports. I'm giving up and submitting this to tech support.


WebFocus 8.104
Windows 7 Entreprise, SP1
 
Posts: 82 | Location: Abbotsford BC | Registered: March 15, 2010Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Issues with subordinate Paramaters

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.