Focal Point
[SOLVED] WF 769, 1-page PDF report giving error 18

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/7971057331/m/334106353

January 27, 2010, 03:54 PM
tmboyd
[SOLVED] WF 769, 1-page PDF report giving error 18
In testing some reports on our 7.6.9 instance (that currently work just fine in our Production and Test 7.6.1 instances), some of those with PDF output are producing an error in Adobe Reader. More specifically, Reader is telling us that, "There was an error processing a page. There was a problem reading this document (18)."

I read on these forums a warning about compound reports and using the EMPTYREPORT=ON option to weed out blank pages, but this is not a compound report. We tried fiddling with SET EMPTYREPORT=ON anyhow, but to no avail.

Has anyone else come across this problem with 7.6.9 (or earlier versions)? We are using Reader 8 and Reader 9.3, I believe, and both of them have produced the error.

This message has been edited. Last edited by: Kerry,


Test & Prod: WF 7.6.9 | Server OS: Windows Server 2003 | Web Server: Apache Tomcat/6.0.20 | Components: Managed Reporting, Report Caster
January 27, 2010, 03:57 PM
mrguru
Chances are there is a problem with the report itself and has nothing to do with pdf. Try outputing as html and see if it displays the actual error.


WF 8.2.01M
8.2.01M Reporting Server
Windows 2012 Srvr R2
PDF,Excel, HTML
Graphs - a lot of graphs
February 01, 2010, 03:36 PM
tmboyd
The analyst said that turning off Gridding did the trick, but we're going to dig a bit further and find out what difference between 761 and 769 is causing that to be an issue.


Test & Prod: WF 7.6.9 | Server OS: Windows Server 2003 | Web Server: Apache Tomcat/6.0.20 | Components: Managed Reporting, Report Caster
February 04, 2010, 09:25 AM
tmboyd
Okay.. so apparently grid lines in the header of a PDF report are causing this issue. I have not been able to find anything in changelogs or documentation that would explain why. Any suggestions for troubleshooting or possibly-related issues would be appreciated.

Thanks!


Test & Prod: WF 7.6.9 | Server OS: Windows Server 2003 | Web Server: Apache Tomcat/6.0.20 | Components: Managed Reporting, Report Caster