Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SHARING] Dev Studio 7.7.02 using ibirls2 instead of ibirls3?
Go
New
Search
Notify
Tools
Reply
  
[SHARING] Dev Studio 7.7.02 using ibirls2 instead of ibirls3?
 Login/Join
 
Expert
posted
So, there's no way to develop HTML screens in Dev Studio 7.7.02 using ibirls2 instead of ibirls3? The moment you open an HTML Composer designed page in v7.7.02, ibirls2 changes to ibirls3.

Here's a scenario: I have a BI Dashboard view with three tabs. When I open the view in IE, the first tab is displayed. It contains an HTML page designed by HTML Composer 7.6.8.

I open the file in HTML Composer 7.7.02 and do not make any changes - simply saving the file replaces ibirls2 with ibirls3.

I return to the dashboard view in IE and hit refresh - I get a non-ending "Loading, please wait" message.

It looks like it Dev Studio HTML Composer 7.7.02 changes ibirls2 to ibirls3 and drastically changes most of the code in the file, and yet it will not work.

Disappointed with my first real attempt at using the GUI.

This message has been edited. Last edited by: Kerry,


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
Guru
posted Hide Post
When you open an existing HTML file in a new release, it will be migrated in memory. If you save, the migrated version is saved to disk. Have you modified the original page after it was generated by the HTML Composer? That would increase the chances that the migration will fail and result in a loop.


David Glick
Director WebFOCUS App Studio
and WebFOCUS Developer Studio
WebFOCUS Division
Information Builders, Inc.
Direct (917) 339-5560
Voice Mail (212) 736-6250 x3560
Fax (212) 947-5168
Email david_glick@ibi.com
 
Posts: 312 | Registered: April 13, 2004Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Francis,
Have you opened up a case with Techsupport? This sounds like something that should be drilled into in more detail.

As always, if you can create a simple reproduction of the problem that can be run at IBI, it greatly speeds up the process. This can either be based off CAR, or if your data is non sensitive and you can create FOCUS Hold files that can be uploaded with the masters that also reproduce the issue it works.

I usually try to delete as much as I can out of the HTML file that still reproduces the issue in the process of troubleshooting. This makes it more clear what within the HTML page is causing the issue. Just be sure you also upload the original when doing this.


WF 71.x, 76.x, 7701, 8.0 Beta OS: Linux, Win2k3, Win2k, Win2k8, WinXP


 
Posts: 203 | Registered: November 19, 2007Reply With QuoteReport This Post
Expert
posted Hide Post
The html page in question is a simple mock-up that was created in v7.6.8. The drop-down boxes don't get populated by data, nothing much is on the screen. It seems unusual that simply opening the html page in HTML Composer v7.7.02 and saving it would cause the simplest screen to not work.

Doesn't bode well for more complex screens.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Is the server 7.6.8. or 7.7?

If it's 7.6.8 it probably won't work and you'll need to recover an old version of that file from somewhere and stop using a newer version of DS with it.
We had similar issues with DS 7.6.11 until we upgraded our server from 7.6.8 to 7.6.11 as well. But almost every launch-page we edited after that needed some tweaking to make it work again...

I definitely agree that Dev Studio should at least emit a warning if it's upgrading a file to a newer version without being asked to do so. It's a nasty surprise. Of course, after the first time this hits you, you know not to use a newer version of DS with an older server (or just older launch-pages really), but it'd be nice to prevent that altogether.

Another issue is that the new version of the launch-page is much harder to create without using the graphical tools, as a bunch of XML code gets embedded in them now.


WebFOCUS 8.1.03, Windows 7-64/2008-64, IBM DB2/400, Oracle 11g & RDB, MS SQL-Server 2005, SAP, PostgreSQL 11, Output: HTML, PDF, Excel 2010
: Member of User Group Benelux :
 
Posts: 1646 | Location: Enschede, Netherlands | Registered: August 12, 2010Reply With QuoteReport This Post
Expert
posted Hide Post
I realize that lots of people are happily pointing and clicking away at the GUI tools, but I've had an unpleasant time with them since v4.3.6, though the taste is much less bitter these days.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SHARING] Dev Studio 7.7.02 using ibirls2 instead of ibirls3?

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.