Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Go
New
Search
Notify
Tools
Reply
  
HTML Editor
 Login/Join
 
Gold member
posted
Some how I have Front Page Express editing my DevStudio HTML files. Can someone please help change this to some other editor? I can't remember how it set this up in the first place.
Thx.
 
Posts: 81 | Location: Calgary, Alberta | Registered: August 07, 2003Reply With QuoteReport This Post
<Viswa>
posted
Hai

Please look at the following fiile,Focshell, under C:\IBI\desktop436\home\bin folder. It would be having an entry as
HTMLEditor=frontpg.exe.

So we need to Change the value of HTMLEditor appropriately, to open the required, HTML Builder, be it Frontpage or interdev.

I hope the above information will help you.

Thanks
Viswakanth
 
Reply With QuoteReport This Post
Gold member
posted Hide Post
Thanks for your reply. However I don't know wha file you are refering to. FOCSHELL.? Please supply an extension to the file you are referencing. I could not find any files with the entry you specified.
 
Posts: 81 | Location: Calgary, Alberta | Registered: August 07, 2003Reply With QuoteReport This Post
Guru
posted Hide Post
That would be focshell.ini, located in \ibi\desktop436\home\bin (if that's your path to Dev Studio).

/H�kan
 
Posts: 319 | Location: Stockholm, Sweden | Registered: February 04, 2004Reply With QuoteReport This Post
<Viswa>
posted
Hai

Focshell.ini is the file name.

Thanks
Viswakanth
 
Reply With QuoteReport This Post
Gold member
posted Hide Post
Well that's interesting as I have no focshell.ini at all! My path is c:\ibi\DevStudio52\bin and there is no focshell.ini anywhere. Any other ideas?
 
Posts: 81 | Location: Calgary, Alberta | Registered: August 07, 2003Reply With QuoteReport This Post
<Grzegorz>
posted
Since 5.x release of Developer Studio, the focshell.ini file is replaced by the Windows registry entries.
You can try to experiment with the following registry key:
HKEY_CURRENT_USER\Software\Information Builders\DeveloperStudio\52\FOCSHELL\DesktopSettings\Shell
and the entry:
"HTMLEditor"="frontpg.exe"

Hope this helps
Grzegorz
 
Reply With QuoteReport This Post
Gold member
posted Hide Post
Still didn't do the trick.
I found the following works however:
Edit
HKLM\SOFTWARE\Classes\Applications\explore.exe\shell\edit\command and set the (Default) to your HTML Editor of choice. Example:frontpg.exe
 
Posts: 81 | Location: Calgary, Alberta | Registered: August 07, 2003Reply With QuoteReport This Post
Master
posted Hide Post
The HTML editor is configured at the Windows level, not in DevStudio; DevStudio actually uses the Windows setting to determine what editor to load for a particular file when you do an Open action.

Fastest way to configure it: Go to Internet Explorer. Select Tools > Internet Options. Click the Programs tab. There it is - the first entry. Change the program to whatever other one you want from the list.
 
Posts: 919 | Registered: March 26, 2003Reply With QuoteReport This Post
Gold member
posted Hide Post
Best answer yet! Thanks Smiler
 
Posts: 81 | Location: Calgary, Alberta | Registered: August 07, 2003Reply With QuoteReport This Post
  Powered by Social Strata  
 


Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.