Focal Point
[CLOSED] Prompt don't work on Deferred

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/7971057331/m/3657086096

August 14, 2018, 09:04 AM
JACQUETL
[CLOSED] Prompt don't work on Deferred
Hi,,

This fex run directly but not in defferred, do you know why ?

-DEFAULT &TYPE_DOSS = '_FOC_NULL';
-PROMPT &TYPE_DOSS.(<'Recouvrement',FVRECOUVRE>,<'Proc├ędure collective',FVPROCOLL>,).Type dossier.
-RUN

-MRNOEDIT EX baseapp/nom_rapport TYPE_DOSS=&TYPE_DOSS.QUOTEDSTRING


Where i use deffered :
(FOC295) VALEUR ABSENTE POUR: &TYPE_DOSS


But it's ok run directly ! Why ?

conf parameter is : &WFDESCRIBE = XMLPROMPT

Thanks

This message has been edited. Last edited by: JACQUETL,


Webfocus 8.201M.
Windows
InfoAssist +
Chrome, IE, Excel, HTML; PDF, AHTML,GRAPH
August 14, 2018, 09:23 AM
MartinY
As far as I know when you run as differed you need to have all parameters selected and passed to the request first.

When it's launch as differed, it doesn't go to the "normal" default service but to the DFM_DEFAULT service and waits for resources to be free prior to execute and/or with a lower priority.
So it cannot prompt you for input parameters. The parameters need to be filled prior to send to differed mode.

I have never used the auto-prompt for differed reports. Don't even know if possible and I will be surprised if available.


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
August 14, 2018, 09:33 AM
JACQUETL
If I run fex as differed, it asks me the contents of prompt before (WebFocus Autoprompt)

That's what I want.
End User must choise parameter before run differed


Webfocus 8.201M.
Windows
InfoAssist +
Chrome, IE, Excel, HTML; PDF, AHTML,GRAPH
August 14, 2018, 10:32 AM
FP Mod Chuck
Hi Jacquetl

You might consider creating a html document with the parameter displayed for selection and then use the run deferred button to run the report.


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
August 14, 2018, 10:37 AM
JACQUETL
ok Thanks FP Mod Chuck


Webfocus 8.201M.
Windows
InfoAssist +
Chrome, IE, Excel, HTML; PDF, AHTML,GRAPH
August 15, 2018, 04:15 AM
Tony A
quote:
-MRNOEDIT EX baseapp/nom_rapport TYPE_DOSS=&TYPE_DOSS.QUOTEDSTRING


Your issue is that your procedure is in an application folder. Also that you are using EX which is not parsed for missing variable values.

To check what I mean, select properties for a procedure in an application folder and also one within a domain folder. The one in the applications folder does not have a "run deferred" option whereas the one in the domains folder does. This should make you realise that the procedure should be in a domains folder structure and not an applications folder structure.

Also, look at the properties for a procedure in a domain folder and you can see that you can set it to only run deferred.

T

This message has been edited. Last edited by: Tony A,



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.07 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
August 16, 2018, 07:47 AM
JACQUETL
Thanks Tony i understand, i will changed it

but it remains disturbing when it works : "run directly"

Music


Webfocus 8.201M.
Windows
InfoAssist +
Chrome, IE, Excel, HTML; PDF, AHTML,GRAPH