Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

New TIBCO Community Coming Soon
In early summer, TIBCO plans to launch a new community—with a new user experience, enhanced search, and expanded capabilities for member engagement with answers and discussions! In advance of that, the current myibi community will be retired on April 30. We will continue to provide updates here on both the retirement of myibi and the new community launch.

What You Need to Know about Our New Community
We value the wealth of knowledge and engagement shared by community members and hope the new community will continue cultivating networking, knowledge sharing, and discussion.

During the transition period, from April 20th until the new community is launched this summer, myibi users should access the TIBCO WebFOCUS page to engage.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Prompt don't work on Deferred

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[CLOSED] Prompt don't work on Deferred
 Login/Join
 
Gold member
posted
Hi,,

This fex run directly but not in defferred, do you know why ?

-DEFAULT &TYPE_DOSS = '_FOC_NULL';
-PROMPT &TYPE_DOSS.(<'Recouvrement',FVRECOUVRE>,<'Procédure collective',FVPROCOLL>,).Type dossier.
-RUN

-MRNOEDIT EX baseapp/nom_rapport TYPE_DOSS=&TYPE_DOSS.QUOTEDSTRING


Where i use deffered :
(FOC295) VALEUR ABSENTE POUR: &TYPE_DOSS


But it's ok run directly ! Why ?

conf parameter is : &WFDESCRIBE = XMLPROMPT

Thanks

This message has been edited. Last edited by: JACQUETL,


Webfocus 8.201M.
Windows
InfoAssist +
Chrome, IE, Excel, HTML; PDF, AHTML,GRAPH
 
Posts: 92 | Location: France | Registered: July 08, 2009Report This Post
Virtuoso
posted Hide Post
As far as I know when you run as differed you need to have all parameters selected and passed to the request first.

When it's launch as differed, it doesn't go to the "normal" default service but to the DFM_DEFAULT service and waits for resources to be free prior to execute and/or with a lower priority.
So it cannot prompt you for input parameters. The parameters need to be filled prior to send to differed mode.

I have never used the auto-prompt for differed reports. Don't even know if possible and I will be surprised if available.


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
 
Posts: 2410 | Location: Montreal Area, Qc, CA | Registered: September 25, 2013Report This Post
Gold member
posted Hide Post
If I run fex as differed, it asks me the contents of prompt before (WebFocus Autoprompt)

That's what I want.
End User must choise parameter before run differed


Webfocus 8.201M.
Windows
InfoAssist +
Chrome, IE, Excel, HTML; PDF, AHTML,GRAPH
 
Posts: 92 | Location: France | Registered: July 08, 2009Report This Post
Virtuoso
posted Hide Post
Hi Jacquetl

You might consider creating a html document with the parameter displayed for selection and then use the run deferred button to run the report.


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
 
Posts: 2128 | Location: Customer Support | Registered: April 12, 2005Report This Post
Gold member
posted Hide Post
ok Thanks FP Mod Chuck


Webfocus 8.201M.
Windows
InfoAssist +
Chrome, IE, Excel, HTML; PDF, AHTML,GRAPH
 
Posts: 92 | Location: France | Registered: July 08, 2009Report This Post
Expert
posted Hide Post
quote:
-MRNOEDIT EX baseapp/nom_rapport TYPE_DOSS=&TYPE_DOSS.QUOTEDSTRING


Your issue is that your procedure is in an application folder. Also that you are using EX which is not parsed for missing variable values.

To check what I mean, select properties for a procedure in an application folder and also one within a domain folder. The one in the applications folder does not have a "run deferred" option whereas the one in the domains folder does. This should make you realise that the procedure should be in a domains folder structure and not an applications folder structure.

Also, look at the properties for a procedure in a domain folder and you can see that you can set it to only run deferred.

T

This message has been edited. Last edited by: Tony A,



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.07 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
 
Posts: 5694 | Location: United Kingdom | Registered: April 08, 2004Report This Post
Gold member
posted Hide Post
Thanks Tony i understand, i will changed it

but it remains disturbing when it works : "run directly"

Music


Webfocus 8.201M.
Windows
InfoAssist +
Chrome, IE, Excel, HTML; PDF, AHTML,GRAPH
 
Posts: 92 | Location: France | Registered: July 08, 2009Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Prompt don't work on Deferred

Copyright © 1996-2020 Information Builders