Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Override IBIF_max_messages in report ? [SOLVED]
Go
New
Search
Notify
Tools
Reply
  
Override IBIF_max_messages in report ? [SOLVED]
 Login/Join
 
Member
posted
The Controlling WebFOCUS Reporting Server Messages new features topic says:
quote:
IBIF_max_messages can be passed with the request, in which case it overrides the value set in the console


However, I have been unable to override that setting from within a report procedure. Neither treating it it as an option or as a variable works...
 SET IBIF_max_messages=0 

 -SET &IBIF_max_messages=0; 


So, can it be done from within a report, or is there some system setting preventing the override ?

Gene

This message has been edited. Last edited by: Gene F.,


WF 8.009 on Windows Server 2012/IIS/WebSphere; client: Windows 7
 
Posts: 7 | Location: St Louis, MO | Registered: July 17, 2008Reply With QuoteReport This Post
Master
posted Hide Post
Try this,

1. Go to your Tomcat folder and click the following exe file.

C:\Program Files\Apache Foundation\Tomcat\bin\Tomcat5w.exe

2. select the java tab, and increase the memory from the default (blank)
to 64 / 256 (min.max), and recyle Tomcat.


WFConsultant

WF 8105M on Win7/Tomcat
 
Posts: 780 | Location: Florida | Registered: January 09, 2005Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Although, the setting was created to prevent out of memory problems, changing settings in Tomcat won't change anything with the IBIF_max_messages. It's a WF server setting so increasing the memory for the JVM won't affect how the server handles the setting. My understanding is that it can be passed in a procedure, but I'm not sure how that's done either. It can be changed in the server console, however. Will do some more digging.


Regards,

Darin



In FOCUS since 1991
WF Server: 7.7.04 on Linux and Z/OS, ReportCaster, Self-Service, MRE, Java, Flex
Data: DB2/UDB, Adabas, SQL Server Output: HTML,PDF,EXL2K/07, PS, AHTML, Flex
WF Client: 77 on Linux w/Tomcat
 
Posts: 2298 | Location: Salt Lake City, Utah | Registered: February 02, 2007Reply With QuoteReport This Post
Master
posted Hide Post
I got this error earlier, after I changed the JVM setting it got resolved.

Trying things wont hurt. Neway we should dig in to the details as you mentioned and if we find a way, that will be helpful.


WFConsultant

WF 8105M on Win7/Tomcat
 
Posts: 780 | Location: Florida | Registered: January 09, 2005Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Kamesh - he didn't say anything about getting an error - he just wanted to know how to override the server setting. As well, he may or may not be using Tomcat as his server as he has not listed any additional information in his profile. (Note to Gene - please update your profile with server and version information to get a more helpful response to your issues. Thanks)

I am assuming you are talking about the "Max Messages Exceeded" error, which may possibly be handled in part by doing as you suggest.


Regards,

Darin



In FOCUS since 1991
WF Server: 7.7.04 on Linux and Z/OS, ReportCaster, Self-Service, MRE, Java, Flex
Data: DB2/UDB, Adabas, SQL Server Output: HTML,PDF,EXL2K/07, PS, AHTML, Flex
WF Client: 77 on Linux w/Tomcat
 
Posts: 2298 | Location: Salt Lake City, Utah | Registered: February 02, 2007Reply With QuoteReport This Post
Guru
posted Hide Post
I changed this setting once. It's in the WebFOCUS Administration Console, and there somewhere under general settings.


Test: WF 8.2
Prod: WF 8.2
DB: Progress, REST, IBM UniVerse/UniData, SQLServer, MySQL, PostgreSQL, Oracle, Greenplum, Athena.
 
Posts: 423 | Location: Europe | Registered: February 05, 2007Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Look into:
WF administration (client) console
Configuration
Client settings
General

The initial value is 20000.


Daniel
In Focus since 1982
wf 8.202M/Win10/IIS/SSA - WrapApp Front End for WF

 
Posts: 1949 | Location: Tel Aviv, Israel | Registered: March 23, 2006Reply With QuoteReport This Post
Expert
posted Hide Post
And if you are getting that many messages, it means that there is something seriously wrong with your program. I'm not sure if Gene wanted to make it unlimited or not, but we find the default works just fine and in fact could be lower. A number that high makes the problem hard to diagnose because you don't get a page to look at. I always recommend to my users that they change the output format to html and reduce the number of rows so that they can see the error messages. Only then can they fix the problem that is causing the error.


Ginny
---------------------------------
Prod: WF 7.7.01 Dev: WF 7.6.9-11
Admin, MRE,self-service; adapters: Teradata, DB2, Oracle, SQL Server, Essbase, ESRI, FlexEnable, Google
 
Posts: 2723 | Location: Ann Arbor, MI | Registered: April 05, 2006Reply With QuoteReport This Post
<Marilyn Kay>
posted
For what it's worth, this message sometimes indicates that a dialogue manager label may be duplicated so that a -GOTO may be resulting in a loop. I would carefully check the -LABELs in the focexec.
 
Reply With QuoteReport This Post
Member
posted Hide Post
A little bit of background for my question about overriding the message limit...

Yes, I am getting the following error response when the customer selects a large number of foreign exchange deal templates to print out:
 <HTML>
<HEAD><Title>WebFOCUS Message [32100]: Messages limit reached, report retrieval aborted.</Title></Head>
<Body>
<H2>
<p>Reporting Server messages exceeded IBIF_max_messages, report retrieval aborted.
</H2>
<p>Please, contact your WebFOCUS administrator.
</Body>
</HTML> 
The procedure is not in a "runaway" mode or in an infinite loop. The large number of messages is just a byproduct of the way the report is currently structured and asking for a fairly large number of templates to be processed. Each template produces 1 or 2 pages that are combined into a compound output. For each of the pages another procedure is called to perform the database access and generation of the report page. Each call to the second procedure is generating 19 or 20 message lines, which consists solely of the table access information (number of rows, etc.). The customer for which the error was discovered has over 640 templates. So, if the user selects 'ALL' templates for reporting we are looking at the possibilty of this many messages: ((640 * 2) * 19) = 24,320.

The original report only needed to process a single template per request. However, the capability to process multiple templates was later made a requirement and there was no time available to properly restructure the procedure; so, the original procedure was turned into an inner procedure and is now called by an outer procedure to process each of the selected templates in a serial fashion. Also, at the time the second (outer) procedure was created we were running WebFOCUS version 5.33, which does not have the IBIF_max_message limit.

That's the background. The options would seem to be:
1) Override the message limit.
2) Restructure the procedures.
3) Limit the number of templates that can be processed with a single request.
Doing #1 would be ideal, but only if it does not involve changing the limit for all reports at the server level.
Doing #2 is currently out of the question, there is no time available to redo this complex report.
Doing #3 is my fall back method if #1 cannot be done at the report level, and it is not the best solution from the affected customer(s) point of view.

So, back to my original question. Can the IBIF_max_messages limit be overridden on a per report basis as the documentation seems to suggest or not ? And if so, how ?


Gene


WF 8.009 on Windows Server 2012/IIS/WebSphere; client: Windows 7
 
Posts: 7 | Location: St Louis, MO | Registered: July 17, 2008Reply With QuoteReport This Post
Expert
posted Hide Post
I don't know the answer to your question but have you considered turning messages off.

SET MSG=OFF


Ginny
---------------------------------
Prod: WF 7.7.01 Dev: WF 7.6.9-11
Admin, MRE,self-service; adapters: Teradata, DB2, Oracle, SQL Server, Essbase, ESRI, FlexEnable, Google
 
Posts: 2723 | Location: Ann Arbor, MI | Registered: April 05, 2006Reply With QuoteReport This Post
Member
posted Hide Post
Ginny, that put a stop to those pesky messages. I never had to make use of that particular option before. It would be nice to have a definitive answer to my question about overriding the system limit, but for now I'll accept the suppression solution.


Thanks,
Gene


WF 8.009 on Windows Server 2012/IIS/WebSphere; client: Windows 7
 
Posts: 7 | Location: St Louis, MO | Registered: July 17, 2008Reply With QuoteReport This Post
Virtuoso
posted Hide Post
quote:
Originally posted by Gene F.:

quote:
IBIF_max_messages can be passed with the request, in which case it overrides the value set in the console




The request - in this case - is the URL or your html form.


"There is no limit to what you can achieve ... if you don’t care who gets the credit." Roger Abbott
 
Posts: 1102 | Location: Toronto, Ontario | Registered: May 26, 2004Reply With QuoteReport This Post
Member
posted Hide Post
I ran across another report that would also get the message limit exceeded error. Tried turning off the messages with 'SET MESSAGE=OFF' just as I did with earlier report. But, that did not work when the report was processing a very large number of foreign exchange deals; it would still get the error even with messages turned off. Never could figure out what "messages" were still causing the error. The real fix was to override the IBIF_max_messages limit with an additional input field on the requesting html form.
 <INPUT NAME="IBIF_max_messages" VALUE="0" TYPE="hidden"> 
... just as dhagen pointed out in the last reply. It's a shame you cannot just set the limit with code within the report procedure itself.

Gene


WF 8.009 on Windows Server 2012/IIS/WebSphere; client: Windows 7
 
Posts: 7 | Location: St Louis, MO | Registered: July 17, 2008Reply With QuoteReport This Post
<JG>
posted
Actually the correct way to manage this is as Daniel suggested back in July.

Turn off the limit via the Adiministration console

Checkout:-
http://techsupport.informationbuilders.com/sps/30262027.html
 
Reply With QuoteReport This Post
Member
posted Hide Post
While changing the limit at the server level might seem to be the easy solution, it was not an option for me. Our site's application developers do not have access to the admin console for security purposes. Also, our site runs multiple applications on a single server. Changing the limit at the server would affect all applications and indeed all reports instead of just targeting the very few reports that need special handling.

Gene


WF 8.009 on Windows Server 2012/IIS/WebSphere; client: Windows 7
 
Posts: 7 | Location: St Louis, MO | Registered: July 17, 2008Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Override IBIF_max_messages in report ? [SOLVED]

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.