Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at myibi@ibi.com and provide your corporate email address, company, and name.


Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] How to change NLS configuration file

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[SOLVED] How to change NLS configuration file
 Login/Join
 
Silver Member
posted
We have WF server installed on Mainframe and we recently upgraded from 7704 to 7708. After the upgrade we are having an issue printing Times New Roman font with bold or italic. We found one change between versions, NLSCTRL parameter in codepage, in 7704 default setting is OFF and 7708 default is ON. Does anyone know how to change NLSCTRL from ON to OFF? This parameter can't be changed on screen(no option in Webconsole nlscfg.err), manuals say run a TSGU command but not sure about the right command. Thank you!

This message has been edited. Last edited by: FP Mod Chuck,


WebFOCUS 8.2.05
Windows 2003
Excel, HTML, PDF
 
Posts: 47 | Registered: April 22, 2009Report This Post
Virtuoso
posted Hide Post
JJ

You should be able to right mouse click on nlscfg.err and choose edit. Then add NLSCTRL=OFF Click the Save button and say OK to restart the reporting server.

I don't have access to a mainframe server so I can't verify what I am telling you. I found these instructions in a mainframe case on techsupport.


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
 
Posts: 2128 | Location: Customer Support | Registered: April 12, 2005Report This Post
Silver Member
posted Hide Post
Thank you for your reply. NLSCTRL is not there to edit. We only see parameters below
CODE_PAGE(65002 Unicode(UTF-EBCDIC))
LANG(AMENGLISH)
DATEOUTPUT(DEFAULT)
COLLATION(CODEPAGE)
and then under optional customization
TSGU command(there is a text box to type the command and Run button)
I think need to run a command but not sure.


WebFOCUS 8.2.05
Windows 2003
Excel, HTML, PDF
 
Posts: 47 | Registered: April 22, 2009Report This Post
Virtuoso
posted Hide Post
JJ

If you can't type in the area where the other stuff is. Then I would try to put the NLSCTRL=OFF in the text box and the run button. If you aren't comfortable with that contact techsupport and I'm sure they can help you with this.


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
 
Posts: 2128 | Location: Customer Support | Registered: April 12, 2005Report This Post
Silver Member
posted Hide Post
Thank you Chuck. We were able to change the NLSCTRL setting to OFF but that did not resolve the issue we are having with PDF outputs, it is still printing squares when the font is "Times New Roman" and bold or italic. If anyone experienced this issue before and have a solution please help. Thanks!


WebFOCUS 8.2.05
Windows 2003
Excel, HTML, PDF
 
Posts: 47 | Registered: April 22, 2009Report This Post
Gold member
posted Hide Post
Hello JJ,

I haven't had this exact problem, but I took a
quick scour of the server manual to see if I could find an answer for you.

Check out the commands for

PDFX {font-name}
and
KTBL {pdfy-name}

I have a feeling it might be just what you need.

Font topics can always be a little confusing. Since pdf fonts are embedded, they come from the server. It's the font's themself (are I and B missing?) Or, it's in that command to configure the font.


WebFocus 7x, 8x, Win / Linux, any output format
 
Posts: 70 | Location: reading, pa | Registered: April 07, 2007Report This Post
Silver Member
posted Hide Post
jnc,
Thank you for taking time to look into this issue. I also found this in the manual and we tried this in server console but returned an error(NLS configuration error). I have a case open with ibi for this issue, it's been several weeks now but haven't got a response back. Thanks again.


WebFOCUS 8.2.05
Windows 2003
Excel, HTML, PDF
 
Posts: 47 | Registered: April 22, 2009Report This Post
Virtuoso
posted Hide Post
JJ

Up the severity on your case and let them know you need an answer. This should not be that hard.


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
 
Posts: 2128 | Location: Customer Support | Registered: April 12, 2005Report This Post
Silver Member
posted Hide Post
Chuck,
Thanks for the reply. I did ask them to escalate the case but no answer at all. I started using IBI products about almost 20 years ago, it was the best customer service by then but not anymore. Frowner


WebFOCUS 8.2.05
Windows 2003
Excel, HTML, PDF
 
Posts: 47 | Registered: April 22, 2009Report This Post
Silver Member
posted Hide Post
[SOLVED]
We used TSGU KTBL GEN PD* command to resolve this issue. Thank you all.


WebFOCUS 8.2.05
Windows 2003
Excel, HTML, PDF
 
Posts: 47 | Registered: April 22, 2009Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] How to change NLS configuration file

Copyright © 1996-2020 Information Builders