Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at myibi@ibi.com and provide your corporate email address, company, and name.


Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Alert and -INCLUDE w/Parameters

Read-Only Read-Only Topic
Go
Search
Notify
Tools
Alert and -INCLUDE w/Parameters
 Login/Join
 
Silver Member
posted
I have an Alert that has a -INCLUDE in the top of the program. Here's a sample:

-* Created by Alert Wizard
-* version 1.0
-* start of the test report
-INCLUDE app/parmrpts.fex
-SET &CLLNDR = IF &LEVEL EQ 'HO' THEN 'SERVHOMEOFF' ELSE 'SERLNDID';
-SET &LNDTYPE = IF &LEVEL EQ 'HO' THEN 'HOMEOFF' ELSE 'ORIGINSURED';

The -INCLUDE has this information in the .fex
-SET &&LNDRID = 3485571001;
-SET &LEVEL = HO;

Will an Alert not work with this -INCLUDE on the top of the program and then another
-INCLUDE at the bottom of the program ?
I can get the Alert to work with hard coding the information into the program, but I need to use this information for several sets of programs to run if my Alert is true. Does this not work because of ReportCaster, or am I missing some simple code? Do I have a work around (other Dialog Manager code or JavaScript I need to use)?


WF 7.7
Unix/Tomcat
ZLinux on System Z
DB2 Relational DB
 
Posts: 33 | Registered: April 23, 2007Report This Post
Silver Member
posted Hide Post
I was searching in the Technical Support area and found this old Case number #13502067 that refers to my Alert problem. The case says "Closed", does this mean that I have NO workaround, OR this is fixed ?? I have WebFOCUS 764. Any help, thanks.


WF 7.7
Unix/Tomcat
ZLinux on System Z
DB2 Relational DB
 
Posts: 33 | Registered: April 23, 2007Report This Post
Expert
posted Hide Post
CherylB,

Try putting quotes around the values in your -INCLUDE.

BTW, welcome to the forum. Please update your signature using the following steps:

** Update signature
1) Logon to Focal Point and go into your complete profile.
2) Scroll down the page until you see the “Signature” field.
3) Fill in the signature you want to use. Here is a sample to model:

Prod: WebFOCUS 5.2.3 on Win 2K/IIS 6/ISAPI Mode
Test: WebFOCUS 7.1 on Win 2K/IIS 6/Weblogic 8.1/Servlet Mode

4) Once all changes are made/added, scroll down to the bottom of the page and click on the Submit button.

Tom


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1972 | Location: Centennial, CO | Registered: January 31, 2006Report This Post
Expert
posted Hide Post
CherylB,

I would open a case with IBI.

The case you found states:

                  Product                         OpSys  Major Rel Put Level
                  -------                         -----  --------- ---------
  Reported in:    WebFOCUS ReportCaster           WIN/2K 711
  Fixed in:       WebFOCUS ReportCaster           ALL    713       95/86


It is very possible that the problem returned in version 7.6 and is/will be fixed in a release subsequent to your version 7.6.4.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Report This Post
Silver Member
posted Hide Post
I want to add to this problem. I get this message when the Alert runs:
Completed with errors/warnings
Error running alert app/chrisalert from MRE:EdaExcp Eda code 227 subcode: 0 xopen: S1000 THE FOCEXEC PROCEDURE CANNOT BE FOUND: parmrpts
Task error:EdaExcp Eda code 227 subcode: 0 xopen: S1000 THE FOCEXEC PROCEDURE CANNOT BE FOUND: parmrpts
No report to distribute.

I tried to search for the Eda Code 227 in the Technical Support area, but have been unsuccessful. Can anyone give me a clue. I might have to open a Case.


WF 7.7
Unix/Tomcat
ZLinux on System Z
DB2 Relational DB
 
Posts: 33 | Registered: April 23, 2007Report This Post
Expert
posted Hide Post
quote:
THE FOCEXEC PROCEDURE CANNOT BE FOUND


This is your problem. I don't know where your program is but neither does WebFOCUS. Razzer

So if the program is in the reporting server application path, then the directory it is in is not in the global path (or the user path if running with a user profile). Or the program is in MRE. I dont' do alerts so I'm not sure where the program is supposed to be but I would first check the location vs. where APP PATH is pointing.

And don't forget to do what Tom recommended above regarding your signature.


Ginny
---------------------------------
Prod: WF 7.7.01 Dev: WF 7.6.9-11
Admin, MRE,self-service; adapters: Teradata, DB2, Oracle, SQL Server, Essbase, ESRI, FlexEnable, Google
 
Posts: 2723 | Location: Ann Arbor, MI | Registered: April 05, 2006Report This Post
Silver Member
posted Hide Post
Ginny,
I have tried every path possible to make the -INCLUDE work. I believe it has something to do with ReportCaster and the -INCLUDE in the top of my Alert program. If I hard code the parameters into this program, it works great. But, I want to set the parms in one .fex, which will then RUN many other programs if my Alert has a True condition.
I have:
- added quotes, taken quotes off.
- made the && a -DEFAULT to set the default parms.
- check the paths, added a full path to the -INCLUDE
- hard coded the parameters
- checked in the Focal Point for other Alert issues
- checked in the Technical Support area for Alert issues
- I've RUN my program/s without the Alert and they work.

So, it seems to be something with the Alert AND the -INCLUDE using ReportCaster. Am I doing something wrong that I need be aware of in ReportCaster?? I thought I was doing something fairly simple, but it might have a limitation ??
I'm willing to try any other suggestions. OR do I open a CASE with IBI ??
I am on WebFOCUS 7.6.4 / ZLINUX on the Mainframe


WF 7.7
Unix/Tomcat
ZLinux on System Z
DB2 Relational DB
 
Posts: 33 | Registered: April 23, 2007Report This Post
Expert
posted Hide Post
is your host fex on the back end or is it in MRE? You don't say.
if it is not in MRE, then
-MRNOEDIT -INCLUDE appname/includename

also
as Tom has said
-SET &LEVEL = HO;
needs to be -SET &LEVEL='HO';

This message has been edited. Last edited by: susannah,




In Focus since 1979///7706m/5 ;wintel 2008/64;OAM security; Oracle db, ///MRE/BID
 
Posts: 3811 | Location: Manhattan | Registered: October 28, 2003Report This Post
Silver Member
posted Hide Post
Susannah,

To answer your questions.
The -INCLUDE sits in the MRE, on the same path in the same domain.
And yes, I did make the -SET &LEVEL = 'HO';

I will try the -MRNOEDIT. Thanks, let you know if works.


WF 7.7
Unix/Tomcat
ZLinux on System Z
DB2 Relational DB
 
Posts: 33 | Registered: April 23, 2007Report This Post
Silver Member
posted Hide Post
Susannah,

Putting in the -MRNOEDIT did not work.
I will submit a IBI case.
But, if anyone has further suggestions, please let me know.
Thanks.


WF 7.7
Unix/Tomcat
ZLinux on System Z
DB2 Relational DB
 
Posts: 33 | Registered: April 23, 2007Report This Post
Expert
posted Hide Post
putting in -MRNOEDIT should work just fine
whats your exact syntax?
post the line here.
-MRNOEDIT -INCLUDE myfex
there's no app/myfex
if the myfex is in the apppath

This message has been edited. Last edited by: susannah,




In Focus since 1979///7706m/5 ;wintel 2008/64;OAM security; Oracle db, ///MRE/BID
 
Posts: 3811 | Location: Manhattan | Registered: October 28, 2003Report This Post
Member
posted Hide Post
susannah, -MRNOEDIT is used to tell MR to ignore (not process) the line of code. CherylB confirmed all the files are in MR so -MRNOEDIT should not be used unless she wants to have the INCLUDEd file reside on the WF Reporting Server in an APP directory that will be on the WF Server's path when the scheduled job runs.

CherylB, what is your case #? I've reproduced the problem in Rel 766. The WF Client is sending the information for the -INCLUDEd parmrpts FEX referenced in the Alert test but RC Distribution Server is not integrating it into the FEX it creates to send to the WF Reporting Server.
I confirmed this by reviewing the ReportCaster 'Schedule' trace files located in the /trc directory. When you manually run a schedule from the RC Applet interface you can select the level of tracing you want for just that run. The .trc file shows the WF Client sends the -INCLUDE parmrpts.fex file contents which are:
EX -LINES 2 EDAPUT FOCEXEC,parmrpts,C,MEM,-SET &&LNDRID = 3485571001;
-SET &LEVEL = 'HO';
but...
The .fex file created by the Distribution Server does not integrate this information so that the parmrpts.fex is created in the /edatemp directory on the WF Reporting Server. The .fex file the Distribution Server created in my test is:
EX -LINES 20 EDAPUT FOCEXEC,aalert_include_test,C,MEM,-* Created by Alert Wizard
-*
-* version 1.0
-* start of the test report
-INCLUDE parmrpts
-SET &CLLNDR = IF &LEVEL EQ 'HO' THEN 'SERVHOMEOFF' ELSE 'SERLNDID';
-SET &LNDTYPE = IF &LEVEL EQ 'HO' THEN 'HOMEOFF' ELSE 'ORIGINSURED';
TABLE FILE CAR
SUM SALES
BY COUNTRY
WHERE SALES GT 10000;
ON TABLE HOLD
END
-* end of the test report
-* start of the test
-RUN
-IF &LINES EQ 0 GOTO ALERTEXIT;
-* end of the test
-TYPE %%$$TRIGGERED$$%%
-ALERTEXIT
SET FOCHTMLURL=/ibi_html
EX * RCASTER WFDESCRIBE=OFF
SET CGI-RELEASE=5230
-INCLUDE aalert_include_test
END*

To workaround the problem put a copy of the parmrpts.fex on the WF Reporting Server in an APP directory that will be on the path of the WF Reporting Server when the schedule runs. You don't have to change the code in the Alert FEX as when the WF Client sends it to ReportCaster it is already changed to -INCLUDE parmrpts. You also then don't have to change the MR Alert FEX when this problem is fixed.

In case you are wondering...the reason the -INCLUDE code is changed by the WF Client is due to how MR reports are run whether immediate or scheduled. If you would like to read up on this processing see the WF Newsletter Article I wrote in Fall 2004 edition "Release 5.3 Internal Change Execution of Managed Reporting Procedures (FEXs)"


Susan Trommer
Information Builders
 
Posts: 28 | Registered: May 22, 2003Report This Post
Expert
posted Hide Post
imho, saying that -MRNOEDIT = 'ignore' is misleading;
here's a summary;
FROM THE BACKEND TO THE BACKEND
-INCLUDE myappdir/guestfex.fex
however drilldowns wont work unless
-SET &FOCEXURL='/ibi_apps/WFServlet?' | '&';
-SET &FOCEXURL=&FOCEXURL | 'IBIAPP_app=myappdir' | '&'
SET FOCEXURL=&FOCEXURL
-INCLUDE myappdir/guestfex.fex


FROM MRE if the guestfex is on the backend
-MRNOEDIT -INCLUDE myappdir/guestfex.fex
..or..
-REMOTE BEGIN
EX myappdir/guestfex.fex
-REMOTE END
..runs but won't pass any &values out

FROM MRE if the guestfex is on the backend and on the edapath/apppath
-MRNOEDIT -INCLUDE myfex.fex


FROM MRE TO SAME DOMAIN
-INCLUDE guestfex
-INCLUDE app/guestfex ... also works but don't seem to need the word app;

FROM MRE TO ANOTHER MRE DOMAIN
-INCLUDE mydomain/app/guestfex
...here you do need the word /app/




In Focus since 1979///7706m/5 ;wintel 2008/64;OAM security; Oracle db, ///MRE/BID
 
Posts: 3811 | Location: Manhattan | Registered: October 28, 2003Report This Post
Silver Member
posted Hide Post
Susan and Susannah,
I have not been checking Focal Point, so I apologize for not getting back to you. My case number is #42102547. They have been able to also get the same error message I get "Eda code 227", so it is a problem. The work around suggestion was to put the -INCLUDE into App directory where the Reporting Server runs. I am testing out the workaround. All of our .fexes and Alerts are in Managed Reporting. Any other suggestions?
I am using WebFOCUS 764.


WF 7.7
Unix/Tomcat
ZLinux on System Z
DB2 Relational DB
 
Posts: 33 | Registered: April 23, 2007Report This Post
Member
posted Hide Post
CherylB, I did find your case and had support process it to send to programming since I reproduced the problem, provided the traces and explained the problem to programming. ReportCaster programming is evaluating how to fix this issue and needs to work with a WF Client programmer who is on vacation this week. So please utilize the workaround I outlined earlier until this problem is fixed. Support will update when the problem is fixed.


Susan Trommer
Information Builders
 
Posts: 28 | Registered: May 22, 2003Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Alert and -INCLUDE w/Parameters

Copyright © 1996-2020 Information Builders