Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Filtering issue
Go
New
Search
Notify
Tools
Reply
  
[CLOSED] Filtering issue
 Login/Join
 
Member
posted
I've been having an issue with a dashboard I'm implementing. There's an ibiList of departments on the side. When a department is selected, the corresponding XML's location is given to an ibiDataGrid through seturl. There are then 3 ibiComboBoxes that are used to filter the data. The content of each combobox is pulled from a different column in the datagrid and the list of selections is different for each department selected. I've got ibiParent set to the datagrid and ibiFilterParent set to the department list. I'm also using mainCanvas.reloadData() on the datagrid when a new XML is selected.

The problem I'm having is that when I switch between departments, sometimes the comboboxes do not load the selections for the newly selected department. They only display the selections available from the previously selected department. The weird thing is that the dropdown does have the right number of rows, but they'll be empty. I know the data is actually there, but it's not displaying!

For example -
Dept 1 has a dropdown with selections A, B, C.
Dept 2 has D for the same dropdown.

If I click on Dept 2, then the dropdown properly shows just D. But, if I then if I click on Dept 1 the dropdown shows: D, blank, blank (should be A, B, C). If I then select D (which should be A), the dropdown will actually then show A, B, C, and filter for A.

Has anyone seen anything like this before, or have any suggestions? I can't find anything on the issue I'm having. Frowner

This message has been edited. Last edited by: Kerry,
 
Posts: 5 | Location: 229 | Registered: December 17, 2010Reply With QuoteReport This Post
Member
posted Hide Post
Agh, I just read the posts about the signatures/versions. I'm pretty new to Adobe Flex, and know practically nothing about WebFocus. All I know is that I'm using an XML file generated from some WebFocus thing, and I need to use these special components to use the XML file.

The user guide I've been using as a reference says this is WebFOCUS Enable for Adobe Flex. I'm coding in Flash Builder 4 but using Flex 3.5 and my OS is Windows XP.


WebFOCUS Enable for Adobe Flex
Windows XP
 
Posts: 5 | Location: 229 | Registered: December 17, 2010Reply With QuoteReport This Post
Expert
posted Hide Post
So you do not have WebFOCUS Enable ?


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.06OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Know The Code

 
Posts: 6131 | Location: 33.8688° S, 151.2093° E | Registered: October 31, 2006Reply With QuoteReport This Post
Member
posted Hide Post
I'm not sure what that means exactly...all I know is that another group uses WebFOCUS to create an XML that has the data I need to use in my dashboard, and that I need to use the special WebFocus Flex components to use that data.


WebFOCUS Enable for Adobe Flex
Windows XP
 
Posts: 5 | Location: 229 | Registered: December 17, 2010Reply With QuoteReport This Post
Expert
posted Hide Post
WebFOCUS Emable is IBI's Flex add on that will handle the XML files from WebFOCUS, and also display the reports.

Are you developing the Flex component ?


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.06OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Know The Code

 
Posts: 6131 | Location: 33.8688° S, 151.2093° E | Registered: October 31, 2006Reply With QuoteReport This Post
Member
posted Hide Post
Yes, I'm developing with the Flex components.


WebFOCUS Enable for Adobe Flex
Windows XP
 
Posts: 5 | Location: 229 | Registered: December 17, 2010Reply With QuoteReport This Post
Expert
posted Hide Post
Unfortunately, I have not worked with WebFOCUS Enable, so cannot help on that front, perhaps someone else in the forum has some experience.

I would suggest checking out the documentaiton of WbeFOCUS Enable, perhaps there is something in there.

Or put a case in with IBI if you can't solve the problem.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.06OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Know The Code

 
Posts: 6131 | Location: 33.8688° S, 151.2093° E | Registered: October 31, 2006Reply With QuoteReport This Post
Member
posted Hide Post
I was afraid it would come down to this as there doesn't seem to be much on these forums about the flex components. Thanks anyway! Smiler


WebFOCUS Enable for Adobe Flex
Windows XP
 
Posts: 5 | Location: 229 | Registered: December 17, 2010Reply With QuoteReport This Post
Expert
posted Hide Post
Apart from the IBI flex components, you may be able to check out some Flex forums.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.06OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Know The Code

 
Posts: 6131 | Location: 33.8688° S, 151.2093° E | Registered: October 31, 2006Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Filtering issue

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.