Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

Join the TIBCO Community
TIBCO Community is a collaborative space for users to share knowledge and support one another in making the best use of TIBCO products and services. There are several TIBCO WebFOCUS resources in the community.

  • From the Home page, select Predict: WebFOCUS to view articles, questions, and trending articles.
  • Select Products from the top navigation bar, scroll, and then select the TIBCO WebFOCUS product page to view product overview, articles, and discussions.
  • Request access to the private WebFOCUS User Group (login required) to network with fellow members.

Former myibi community members should have received an email on 8/3/22 to activate their user accounts to join the community. Check your Spam folder for the email. Please get in touch with us at community@tibco.com for further assistance. Reference the community FAQ to learn more about the community.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Connect to named instance

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[CLOSED] Connect to named instance
 Login/Join
 
Gold member
posted
I am trying to install client and in one of the installation steps, we need to enter database connection information.
We use sql server and our database is on a named instance.
When I give the named instance name in the connection, it does not connect. Installation does go through and it completes. But, when I try to bring up the ibi_apps page, it does not bring the page and also the repository is not created.
If I connect to the database that is not on a named instance, it connects fine.
Anyone encountered this issue. I did go through the forum and noticed that one of the users had the same issue. It was mentioned that if we assign dedicated port, it would work. We tried that option and it still did not work.
Please advice.

This message has been edited. Last edited by: <Kathryn Henning>,


7.7.01,windows2008 R2
 
Posts: 65 | Registered: July 28, 2011Report This Post
Virtuoso
posted Hide Post
Hi R,
Not sure that it will fix your issue but try this.
In edasprof.prf where your connection is defined, have the "np:" added before your server's name:

ENGINE SQLMSS SET CONNECTION_ATTRIBUTES YourConnectionName 'np:YourServerName'/,;YourDbName

And you'll maybe need help from your DBA to have proper access right.


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
 
Posts: 2410 | Location: Montreal Area, Qc, CA | Registered: September 25, 2013Report This Post
Guru
posted Hide Post
In the server entry I have

machine_name\instance_name[,port]

for example

localhost\sql_dev,1439

for the named instance "sql_dev" on port 1439. If you are using the default port of 1433 then you don't need the port.

On one system I needed to use \\ rather than \ for the seperator between server and instance but that was a long time ago.

Cheers

Stu


WebFOCUS 8.2.03 (8.2.06 in testing)
 
Posts: 253 | Location: Melbourne, Australia | Registered: February 07, 2007Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Connect to named instance

Copyright © 1996-2020 Information Builders