Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Link to webpage from Excel
Go
New
Search
Notify
Tools
Reply
  
[CLOSED] Link to webpage from Excel
 Login/Join
 
Platinum Member
posted
WF 8.1.0.5m

Can anyone tell me why this does not work in excel. It works fine when I use PDF or HTML. It will go to the page but it will not pass the variables.

  
TYPE=DATA,
     COLUMN=N4,
     TARGET='_blank',
     WHEN=N4 NE ' ',
-*     URL=https://lpolicy-sso.txfb-ins.com/IAF/InetXferServlet?,
     URL=https://lpolicy-sso.txfb-ins.com/IAF/InetXferServlet? (mode=N17 forwardTo=N18 agreement=N4 polSymbol=N5),
$

This message has been edited. Last edited by: FP Mod Chuck,


WebFOCUS 8105m
Windows, All Outputs
 
Posts: 150 | Registered: August 23, 2010Reply With QuoteReport This Post
Platinum Member
posted Hide Post
I am using EXL07 as the output


WebFOCUS 8105m
Windows, All Outputs
 
Posts: 150 | Registered: August 23, 2010Reply With QuoteReport This Post
Expert
posted Hide Post
Should the ? be there, would have thought that WebFOCUS would add it


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6280 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Reply With QuoteReport This Post
Platinum Member
posted Hide Post
I tried to remove the ? but that did not help.

The links are the same when i open with HTML or EXCEL but EXCEL will not pass the parameters to the page.

https://lpolicy-sso.txfb-ins.c...m=0.3227990084545218


WebFOCUS 8105m
Windows, All Outputs
 
Posts: 150 | Registered: August 23, 2010Reply With QuoteReport This Post
Platinum Member
posted Hide Post
here is the link again


 

https://lpolicysso.txfbins.com...m=0.3227990084545218     
 


WebFOCUS 8105m
Windows, All Outputs
 
Posts: 150 | Registered: August 23, 2010Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Not sure, why it will not post the link but they are the same


WebFOCUS 8105m
Windows, All Outputs
 
Posts: 150 | Registered: August 23, 2010Reply With QuoteReport This Post
Expert
posted Hide Post
What should the link be ?, remove the https.

Also I assume this link goes to a secure site, and you would need to be logged in or on an internal network ?

I also do not see the '?' in the URL

https ://lpolicysso.txfbins.com/IAF/account_search.doTAB_ID=0.4511945440030274&searchLob=HOL&searchAgreement=1727307&dynaKeys=%7Cactionflag%7CsearchOption%7C&dynaValues=%7Csearch%7Cbycontrol%7C&delimiter=%7C&actionflag=search&searchOption=bycontrol&srchMatchInd=B&srchType=B&page=ACCOUNT_SEARCH&jsrandom=0.3227990084545218

I assume it should be after 'account_search.do'


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6280 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Reply With QuoteReport This Post
Master
posted Hide Post

Originally posted by Jveselka:

I tried to remove the ? but that did not help.

The links are the same when i open with HTML or EXCEL but EXCEL will not pass the parameters to the page.

url=https://lpolicy-sso.txfb-ins.com/IAF/account_search.do?TAB_ID=0.4511945440030274&searchLob=HOL&searchAgreement=1727307&dynaKeys=%7Cactionflag%7CsearchOption%7C&dynaValues=%7Csearch%7Cbycontrol%7C&delimiter=%7C&actionflag=search&searchOption=bycontrol&srchMatchInd=B&srchType=B&page=ACCOUNT_SEARCH&jsrandom=0.3227990084545218


The url that you posted does not match the one in the code snippet you posted:

The URL that you posted in the link is like this:

        base URL=https://lpolicy-sso.txfb-ins.com/IAF/account_search.do
     parameter1: ?TAB_ID=0.4511945440030274
     parameter2: &searchLob=HOL
     parameter3: &searchAgreement=1727307
     parameter4: &dynaKeys=%7Cactionflag%7CsearchOption%7C
     parameter5: &dynaValues=%7Csearch%7Cbycontrol%7C
     parameter6: &delimiter=%7C
     parameter7: &actionflag=search
     parameter8: &searchOption=bycontrol
     parameter9: &srchMatchInd=B
    parameter10: &srchType=B
    parameter11: &page=ACCOUNT_SEARCH
    parameter11: &jsrandom=0.3227990084545218

Below is an example of a link that works in Excel

    TABLE FILE car
    SUM SALES/D12M
    BY CAR
    ACROSS COUNTRY AS ' '
    ON TABLE PCHOLD FORMAT XLSX
    ON TABLE SET STYLE *
    INCLUDE=IBFS:/FILE/IBI_HTML_DIR/ibi_themes/Flat.sty,$
    TYPE=DATA, COLUMN=N1, TARGET='_blank', URL=https://www.google.com/search?(q=CAR), $
    ENDSTYLE
    END
    -RUN

If the URL in the code snippet is the correct one, maybe try taking out the space after the question mark

    TYPE=DATA,
        COLUMN=N4,
        TARGET='_blank',
        WHEN=N4 NE ' ',
        URL=https://lpolicy-sso.txfb-ins.com/IAF/InetXferServlet?(mode=N17 forwardTo=N18 agreement=N4 polSymbol=N5),
    $


Hallway

 
Prod: 8202M1
Test: 8202M4
Repository:
 
OS:
 
Outputs:
 
 
 
 
 
Posts: 608 | Location: Salt Lake City, UT, USA | Registered: November 18, 2015Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Link to webpage from Excel

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.