Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at myibi@ibi.com and provide your corporate email address, company, and name.


Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] HTML Code to Clear Browser Caching Issue

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[CLOSED] HTML Code to Clear Browser Caching Issue
 Login/Join
 
Platinum Member
posted
Back to it.....

I opened this last year and got busy with an upgrade and never got back with you guys.

We are now running on WF8 and we still have the same issue with caching when we move between our BETA and PRODUCTION servers.

I have tried putting this code in my HTML but it does not help or maybe I have it in the wrong place.

  <HEAD>

<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
<META HTTP-EQUIV="Expires" CONTENT="-1">



We use junctions in the URL to point the link to the correct server but the HTML is not clearing the cookie when the page is loaded.

Beta Link - https://pd.txfb-ins.com/webfoc...menu_user_signon.htm
Prod Link - https://pd.txfb-ins.com/webfoc...menu_user_signon.htm

The below script runs before each screen is loaded and I think this is what needs to be cleared but I am not sure where the code is being generated.

  
<SCRIPT language="JavaScript">
<!-- 
document.cookie = "IV_JCT=%2Fwebfocusbeta8; path=/";
//--> 



Here is an example of the code that is caching...

 <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd">
<HTML><HEAD>
<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
<META HTTP-EQUIV="Expires" CONTENT="-1">
<META id=RLT_STANDARDS_MODE_META http-equiv=X-UA-Compatible content=IE=9>
<META id=RLT_STANDARDS_MODE_META http-equiv=X-UA-Compatible content=IE=10>
<META id=RLT_STANDARDS_MODE_META http-equiv=X-UA-Compatible content=IE=11>
<META name=mycharsetmeta http-equiv=Content-Type content="text/html; charset=ISO-8859-1">
<META name=Generation content="Created in release 8009, Generation 3">
<SCRIPT type=text/javascript>//confidential_id=IBI_OptionsScript
var szHtmlAlias="/ibi_apps/ibi_html";var szRunTimeHtmlAlias="runTimeHtmlAlias";var cgipath="cgipath";var ibirls="ibirls3";var rltdyncalendar="rltdyncalendar";var map="ibimap";var olap="olap";var olappanebase="olappanebase";var olapdrill="olapdrill";var ibiOptions = new Array(cgipath,ibirls);var nlsScript="/javaassist/nls.js";var glbScript="/javaassist/ibi/html/js/ibigbl.js";var replacePart="<replace>";
var scriptTemplate='<SCRIPT src="'+replacePart+'" type="text/javascript"><\/SCRIPT>';if(typeof(szRunTimeHtmlAlias) === 'string' && szRunTimeHtmlAlias.indexOf('/') == 0)szHtmlAlias=szRunTimeHtmlAlias;document.write(scriptTemplate.replace(replacePart, szHtmlAlias + nlsScript));document.write(scriptTemplate.replace(replacePart, szHtmlAlias + glbScript));</SCRIPT>
 
<SCRIPT type=text/javascript>//confidential_id=IBI_ibigblloadCss
if(typeof ibigblloadCss === 'function'){ibigblloadCss(null);addIntlTranslatedJS("composertrans.js");}else {alert("JavaScript alias '/ibi_apps/ibi_html'  is not valid");window.location("about:blank");}</SCRIPT>
<TITLE>HtmlPage</TITLE><LINK id=ITEM2 rel=stylesheet type=text/css UserSuppliedFullPath="1" rtFileName="cgipathsub/ibi_html/javaassist/ibi/html/composer/themes/nonBindows/IBI-Themes/default_theme.css"><LINK id=IBI_THEME_CSS rel=stylesheet type=text/css UserSuppliedFullPath="1" desc="Information Builders" rtFileName="cgipathsub/ibi_html/javaassist/ibi/html/composer/themes/nonBindows/IBI-Themes/ibi.css">
<SCRIPT for=window type=text/javascript eventname="onload">window.onload = function() { window_onload(); }</SCRIPT> 

This message has been edited. Last edited by: <Kathryn Henning>,


WebFOCUS 8105m
Windows, All Outputs
 
Posts: 156 | Registered: August 23, 2010Report This Post
Guru
posted Hide Post
In the WebFOCUS Admin Console you can set the Cache-Control value.

By default it is public, max-age=2592000.

Open the Admin Console and Under "Application Settings" select "Filters".

Your browser and it's version will also play a part in this. I find that IE is very greedy on keeping hold of data and cookies. Even when all pages to WebFOCUS are closed, if another IE page is open then the session cookie may not be released.

Also different browsers use different META tags to control cache.

Here are a bunch that I've used in the past :
<meta http-equiv="cache-control" content="max-age=0" />
<meta http-equiv="cache-control" content="no-cache" />
<meta http-equiv="expires" content="0" />
<meta http-equiv="expires" content="Tue, 01 Jan 1980 1:00:00 GMT" />
<meta http-equiv="pragma" content="no-cache" />


But give the setting in the Webconsole a try first as that will simplify things for you.

Cheers

Stu

This message has been edited. Last edited by: <Kathryn Henning>,


WebFOCUS 8.2.03 (8.2.06 in testing)
 
Posts: 253 | Location: Melbourne, Australia | Registered: February 07, 2007Report This Post
Expert
posted Hide Post
quote:
<META id=RLT_STANDARDS_MODE_META http-equiv=X-UA-Compatible content=IE=9>
<META id=RLT_STANDARDS_MODE_META http-equiv=X-UA-Compatible content=IE=10>
<META id=RLT_STANDARDS_MODE_META http-equiv=X-UA-Compatible content=IE=11>


interesting, jv... what does that quoted code do, actually?




In Focus since 1979///7706m/5 ;wintel 2008/64;OAM security; Oracle db, ///MRE/BID
 
Posts: 3811 | Location: Manhattan | Registered: October 28, 2003Report This Post
Platinum Member
posted Hide Post
StuBouyer

So what would we set the control to, 0?

Susannah
I am not sure I found this online and I assume it is supposed to hold the compatibility settings when moving from one WF page to another.

A lot of our users are complaining that they have to keep resetting the compatibility settings each time they load our WF pages. We also have problems with the RUN button not working. You have to click tools and then compatibility mode to get it to start working again. As far as I know this seems to have helped.

The big issue is the caching......

Thanks
JV


WebFOCUS 8105m
Windows, All Outputs
 
Posts: 156 | Registered: August 23, 2010Report This Post
Expert
posted Hide Post
HMMM. thanks. i'll put that code in every launch page....




In Focus since 1979///7706m/5 ;wintel 2008/64;OAM security; Oracle db, ///MRE/BID
 
Posts: 3811 | Location: Manhattan | Registered: October 28, 2003Report This Post
Platinum Member
posted Hide Post
I tried changing the setting and that did not help, FYI this is a IE problem for sure as I tried to load both BETA and PROD links with Firefox and all worked as it should.

I also tried using the other meta code with no luck.

Do you know where the following java script is run from? the IV_JCT=%2Fwebfocusbeta8 is what I think needs to be cleared each time. As you can see the meta code comes after it and by that time it is too late.

 <SCRIPT language="JavaScript">
<!-- 
document.cookie = "IV_JCT=%2Fwebfocusbeta8; path=/";
//--> 


</SCRIPT>
<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
<META HTTP-EQUIV="Expires" CONTENT="-1">
<!-- Generated by Report Layout Painter -->
<HTML>
<HEAD>
<meta http-equiv="cache-control" content="max-age=0" />
<meta http-equiv="cache-control" content="no-cache" />
<meta http-equiv="expires" content="0" />
<meta http-equiv="expires" content="Tue, 01 Jan 1980 1:00:00 GMT" />
<meta http-equiv="pragma" content="no-cache" />
<META id=RLT_STANDARDS_MODE_META http-equiv=X-UA-Compatible content=IE=9>
<META id=RLT_STANDARDS_MODE_META http-equiv=X-UA-Compatible content=IE=10>
<META id=RLT_STANDARDS_MODE_META http-equiv=X-UA-Compatible content=IE=11>
<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
<META HTTP-EQUIV="Expires" CONTENT="-1">
<SCRIPT id=IBI_RelCallBack type=text/javascript>function AdjustChildrenPosition(){
}
 


WebFOCUS 8105m
Windows, All Outputs
 
Posts: 156 | Registered: August 23, 2010Report This Post
Guru
posted Hide Post
What did you set the IBI_HTTP_Response_Header.Cache-Control value too?

I woulds try "no-cache, max-age=0"

Also try setting IBI_HTTP_Response_Header.expires to a small value 0 or 60 (one minute)

Stu


WebFOCUS 8.2.03 (8.2.06 in testing)
 
Posts: 253 | Location: Melbourne, Australia | Registered: February 07, 2007Report This Post
Platinum Member
posted Hide Post
I had it set to

IBI_HTTP_Response_Header.Cache-Control = public, max-age=1

and

IBI_HTTP_Response_Header.expires = 1

I will try setting them both to 0 and replace public with no-cache,

THanks


WebFOCUS 8105m
Windows, All Outputs
 
Posts: 156 | Registered: August 23, 2010Report This Post
Platinum Member
posted Hide Post
Also is a reboot required for this change?


WebFOCUS 8105m
Windows, All Outputs
 
Posts: 156 | Registered: August 23, 2010Report This Post
Platinum Member
posted Hide Post
Still not working with change and reboot. Any other suggestions?

Thanks
JV


WebFOCUS 8105m
Windows, All Outputs
 
Posts: 156 | Registered: August 23, 2010Report This Post
Guru
posted Hide Post
Have a look at what is being passed through in the HTML headers now.

you should be able to use Chrome or Firefox's developer tools to see the HTML headers.

Also depending on the browser you may need to clear your browser cache - especially if the content is already cached


WebFOCUS 8.2.03 (8.2.06 in testing)
 
Posts: 253 | Location: Melbourne, Australia | Registered: February 07, 2007Report This Post
Virtuoso
posted Hide Post
quote:
<META id=RLT_STANDARDS_MODE_META http-equiv=X-UA-Compatible content=IE=9>
<META id=RLT_STANDARDS_MODE_META http-equiv=X-UA-Compatible content=IE=10>
<META id=RLT_STANDARDS_MODE_META http-equiv=X-UA-Compatible content=IE=11>


This should tell various Internet Explorer versions that they should not use "compatibility mode" for this HTML. The id-tags were probably initially added by WebFOCUS and then incorrectly (id attributes are supposed to be unique on a page) copied. I suspect WF is also responsible for turning this into dubious HTML by removing the attribute quotes, exposing the equals sign in the attribute value to the HTML interpreter.

Cleaned up, the HTML would read as below:
<META http-equiv="X-UA-Compatible" content="IE=9">
<META http-equiv="X-UA-Compatible" content="IE=10">
<META http-equiv="X-UA-Compatible" content="IE=11">


WebFOCUS 8.1.03, Windows 7-64/2008-64, IBM DB2/400, Oracle 11g & RDB, MS SQL-Server 2005, SAP, PostgreSQL 11, Output: HTML, PDF, Excel 2010
: Member of User Group Benelux :
 
Posts: 1669 | Location: Enschede, Netherlands | Registered: August 12, 2010Report This Post
Platinum Member
posted Hide Post
This seems to be an IE (We use IE10 & IE11) issue because this process works fine in Firefox / Chrome.

I made the change Wep5622 but it didn't help.

Can anyone tell me what is generating this code. It is not in any of my HTML code but when I look at the source code it is there. To me this is what needs to be cleared but it runs before any of my code so all the META code I am putting in seems to be running to late.

<script language="JavaScript">
< !--
document.cookie = "IV_JCT=%2Fwebfocusbeta8; path=/";
//-->


WebFOCUS 8105m
Windows, All Outputs
 
Posts: 156 | Registered: August 23, 2010Report This Post
Platinum Member
posted Hide Post
This looks like something (PD) Policy Director is running. Anyone know how to clear this on the fly?

THanks
JV


WebFOCUS 8105m
Windows, All Outputs
 
Posts: 156 | Registered: August 23, 2010Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] HTML Code to Clear Browser Caching Issue

Copyright © 1996-2020 Information Builders