Focal Point
[OPEN CASE] Excel output opening Issue.

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/7971057331/m/4097027486

November 28, 2016, 09:14 AM
Neelima
[OPEN CASE] Excel output opening Issue.
Hi All,

when I am opening the Excel output file Its giving me warning like

 "The file format and extension of "Xyz.xlsx" don't match.The file could be corrupted or unsafe. Unless you trust its source, dont open it do you want to open it anyway " 


I don't want to show this error to the user. So how can I resolve this issue.

Thanks
Neelima

This message has been edited. Last edited by: Tamra,


WebFocus 8104,8204
Excel/PDF/HTML/HTMLTABLE/XML/ALPHA/GIF file/GRAPH/Active technologies
November 28, 2016, 09:21 AM
Avinash
Hi Neelima,

Can you please try below code-
ON TABLE PCHOLD FORMAT XLSX


Thanks!
@vi

WebFOCUS 8105, Dev Studio 8105, Windows 7, ALL Outputs
November 28, 2016, 09:26 AM
Neelima
Hi dear,

yes, i did it and i have modified the Microsoft trust-in option also.

but no luck.. Frowner


WebFocus 8104,8204
Excel/PDF/HTML/HTMLTABLE/XML/ALPHA/GIF file/GRAPH/Active technologies
November 28, 2016, 02:13 PM
Tamra
Neelima,

Can you also take a look at the IBI Techsupport site and the following Advisory...

IBI Technical Support

- Under Announcements and Advisories

- Microsoft Update to Resolve WebFOCUS EXL2K and EXL2K FORMULA (HTML-based) XLS Files Not Opening After Applying Microsoft Security Patch MS16-088

The link contains information related to ....
- As described in Microsoft's Fixes or workarounds for recent issues in Excel for Windows dated July 2016, when you previously tried to open an HTML file with an .XLS file extension from an untrusted location, Excel would warn about the mismatch between the file extension and content.


Let us know if the information provided within the Microsoft advisory helped with your Excel issue.

Thank your for participating in the Focal Point Forum,

Tamra Colangelo
Focal Point Moderator
Information Builders


WebFOCUS 8x - BI Portal, Developer Studio, App Studio, Excel, PDF, Active Formats and HTML5
November 28, 2016, 02:25 PM
Francis Mariani
From IBI's announcement: "Information Builders strongly recommends converting WebFOCUS EXL2K and EXL2K FORMULA procedures to WebFOCUS XLSX (EXL07) and XLSX FORMULA format"

It's really too bad that in WF 8.0.08 (and some newer versions), XLSX has a lower feature set than EXL2K. It's also really too bad that EXL2K is not a real Excel format but an HTML one.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
November 30, 2016, 08:36 AM
Neelima
Hi Tamra,

I am not able to open your link.

Neelima


WebFocus 8104,8204
Excel/PDF/HTML/HTMLTABLE/XML/ALPHA/GIF file/GRAPH/Active technologies
November 30, 2016, 09:19 AM
Neelima
Hi Francis,

Is XLSX Format work with Compound report.I don't know about it.please help me to resolve this issue.

Thank you.


WebFocus 8104,8204
Excel/PDF/HTML/HTMLTABLE/XML/ALPHA/GIF file/GRAPH/Active technologies
November 30, 2016, 09:48 AM
Francis Mariani
Please take a look at WebFOCUS XLSX/EXL07 Format Supported Features Release Roadmap. You need to login to Information Builders Tech Support.

(It's possible you may have to login to see that link Tamra provided.)


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
November 30, 2016, 01:44 PM
Neelima
Hi Francis,

I am not able registered with my personal id in IBI techsupport site.

please suggest me for same.

Thanks
Neelima


WebFocus 8104,8204
Excel/PDF/HTML/HTMLTABLE/XML/ALPHA/GIF file/GRAPH/Active technologies
November 30, 2016, 01:48 PM
Francis Mariani
You should be able to register with Information Builders Tech Support. All you need is the Information Builders Site ID for the products your company has purchased.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
November 30, 2016, 02:33 PM
Tony A
Francis, It could be that the company for whom Neelima works, does not have a maintenance contract? or her company precludes her from registering?

T



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.07 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
November 30, 2016, 02:43 PM
Neelima
Hi,

Is there any trial site code for registration?


WebFocus 8104,8204
Excel/PDF/HTML/HTMLTABLE/XML/ALPHA/GIF file/GRAPH/Active technologies
November 30, 2016, 02:45 PM
susannah
i have had that error whenever I have forgotten to exclude an image when exporting to excel.
In pdf or html, I have a lot of images.
in excel, I have to remember to make my output image free and very very simple. I forget sometimes. and I get that error.




In Focus since 1979///7706m/5 ;wintel 2008/64;OAM security; Oracle db, ///MRE/BID
November 30, 2016, 02:57 PM
jcannavo
I may be off my rocker, but I'm pretty sure quite some time ago I had this same sort of issue. For me I was dynamically creating tabs in Excel with my compound report and one of them I was putting a worksheet name that included an ampersand "&" and Excel didn't like that. Once I eliminated the ampersand from the worksheet name I was fine. Just double check that you aren't putting any special characters in for worksheet names or anything like that.


JC
WebFOCUS Dev Studio / App Studio
8.2.01
Windows 7
December 01, 2016, 09:31 AM
Neelima
hi,

I am not giving any name to given excel output.but still getting error.

Thanks,
Neelima


WebFocus 8104,8204
Excel/PDF/HTML/HTMLTABLE/XML/ALPHA/GIF file/GRAPH/Active technologies
December 02, 2016, 09:35 AM
Neelima
Hi All,

Please help me on this. I am waiting for the solution..


WebFocus 8104,8204
Excel/PDF/HTML/HTMLTABLE/XML/ALPHA/GIF file/GRAPH/Active technologies
December 02, 2016, 10:55 AM
Tamra
Neelima,

Here is a bit more information that might help out:

The .xslx is a binary compilation of xml files. Generating this new file format using WebFOCUS is a two-step process that consists of generating the xml files containing the report output and zipping the xml documents into the binary .xlsx format. The reporting server performs the xml generation process. The zipping can be completed by either the WebFOCUS Client or the WebFOCUS Reporting Server.
It is recommended that the JSCOM3 agent on the Reporting Server is set to also do the zipping process.
(For more information on this topic please see Technical Memo 4690: http://documentation.informati...f_wf_8105/TM4690.pdf )

Please check the setting of IBIF_excelservurl within the Administration Console to determine if it is the Client or Reporting Server that is currently set to do the zipping.
1. From the WebFOCUS Client select Administration from the menu bar
2. Select Administration Console from the drop down list
3. Click on Configuration -> Client Settings -> General
4. Look for the IBIF_excelservurl setting
Is there a value listed here? If so (copy and paste a copy elsewhere for your reference) then set this value to a single blank space
5. Save your changes and re-run the Excel file. Are you still receiving this warning?

Thank your for participating in the Focal Point Forum,

Tamra Colangelo
Focal Point Moderator
Information Builders


WebFOCUS 8x - BI Portal, Developer Studio, App Studio, Excel, PDF, Active Formats and HTML5
December 03, 2016, 05:00 AM
Neelima
quote:
IBIF_excelservurl


After doing your given steps, still I am getting same issue.

This message has been edited. Last edited by: Neelima,


WebFocus 8104,8204
Excel/PDF/HTML/HTMLTABLE/XML/ALPHA/GIF file/GRAPH/Active technologies
February 15, 2017, 04:37 PM
mmoody
Hello Neelima,

Is this happening for all reports you are attempting to generate with
ON TABLE PCHOLD FORMAT XLSX
or is this only happening with a specific report(s)?

Can you attempt to run the following simple procedure:

SET EXCELSERVURL = ' '
TABLE FILE CAR
SUM SALES
BY COUNTRY
BY CAR
BY MODEL
ON TABLE PCHOLD FORMAT XLSX
END

Are you getting the same warning?
If you do not receive the warning then as the other participants mentioned, there may be an unreadable character or chunk of code within that report. We would need to see the code that you are using to generate the Excel output.

Thanks,
Michelle


WebFOCUS 8.1.05, InfoAssist, In Document Analytics, Report Styling
February 15, 2017, 06:13 PM
WF1326
adding to mmoody comment

In addition to SET EXCELSERVURL = '' ,You may need the following set if your report consists of any graphs

SET GRAPHSERVURL =''


WebFOCUS
7703/7705/8105m/8201m/8202m

February 16, 2017, 08:18 AM
Neelima
Thanks Michelle. we have done all the steps.. we have opened the case on IBI techsupport and found the solution from there.


WebFocus 8104,8204
Excel/PDF/HTML/HTMLTABLE/XML/ALPHA/GIF file/GRAPH/Active technologies
February 16, 2017, 08:50 AM
Francis Mariani
quote:
we have opened the case on IBI techsupport and found the solution from there

Which means you now have access to Tech Support?


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
February 16, 2017, 12:32 PM
Neelima
quote:
Copyright © 1996-2017 Information Builders, leaders in enterprise business intelligence.


Yes.. I got the site code from my organization..


WebFocus 8104,8204
Excel/PDF/HTML/HTMLTABLE/XML/ALPHA/GIF file/GRAPH/Active technologies
March 28, 2017, 12:55 AM
Prabhakar
Hi All,
we are able to open the excel report with out any warning messages popping out, after following the steps suggested by Tamra (dated Dec-02-2016). However, we found that the format got distorted between EXL2K and EXL07/XLSX. Any suggestion or work arounds here ? The objective is to just supress the warning messages with out any impact to the format. Thank you.

with Regards;
Rao


WebFOCUS 7.7.05 and 8.x
Windows, All Outputs
March 28, 2017, 10:30 AM
Francis Mariani
quote:
Please take a look at WebFOCUS XLSX/EXL07 Format Supported Features Release Roadmap.


Please see the link I posted above in an earlier post. Unfortunately, EXL07 does not support all the features of EXL2K...


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
March 28, 2017, 02:02 PM
S.J. Kadish
Plug in this line at the top of the fex and test:
SET EXCELSERVURL=''


Sandy Kadish
Dev: 8.2.04- PostgreSQL
Test: 8.2.04 - PostgreSQL
Prod: 8.2.04 - PostgreSQL
March 29, 2017, 07:14 AM
Neelima
Hi Kadish,

I have applied this setting and did not work for me. techsupport is working with us for this EXCEL issue.

Thank you..

Regards,
Neelima


WebFocus 8104,8204
Excel/PDF/HTML/HTMLTABLE/XML/ALPHA/GIF file/GRAPH/Active technologies
March 29, 2017, 12:38 PM
Prabhakar
Hi All,

We are able to address the formatting issue with EXL07 by declaring SET WRAP = OFF. But declaring this for all the components like Header, subhead, report titles, footer and sub footer is difficult. We have altogether 200 odd reports with no common style sheets. Can some one help me understand if at all there is a way to set the wrap off at a server level or similar optimum changes. Awaitng response. Thank you.


WebFOCUS 7.7.05 and 8.x
Windows, All Outputs
January 22, 2018, 04:47 PM
MichaelSamuels
quote:
Originally posted by jcannavo:
I may be off my rocker, but I'm pretty sure quite some time ago I had this same sort of issue. For me I was dynamically creating tabs in Excel with my compound report and one of them I was putting a worksheet name that included an ampersand "&" and Excel didn't like that. Once I eliminated the ampersand from the worksheet name I was fine. Just double check that you aren't putting any special characters in for worksheet names or anything like that.


jcannavo: You're not off your rocker! That fixed things for me. Thanks!


7706 gen 902; Windows 10