Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Active Report Problem
Go
New
Search
Notify
Tools
Reply
  
[CLOSED] Active Report Problem
 Login/Join
 
Silver Member
posted
Hi have an Active Report that just does not seem to want to run. The issues seems to be when I format the dates in the table to HDMtYYB, if I leave the date format as the default the report runs with no problem

SET NODATA = ''
TABLE FILE COUNTRIES_TABLE
PRINT 
	COUNTRY_NM AS 'Country'
	STATUS_NM AS 'Status'
	PLAN_FSI/HDMtYYB AS 'Planned ,First ,Site ,Initiated'
	ACT_FSI/HDMtYYB AS 'Actual ,First ,Site ,Initiated'
	PLAN_FSD/HDMtYYB AS 'Planned ,First ,Site ,Shipment'
	ACT_FSD/HDMtYYB AS 'Actual ,First ,Site ,Shipment'
	ACT_COUNT AS 'Active ,Number ,of ,Sites'
	PLAN_COUNT AS 'Planned ,Number ,of ,Sites'
	CLOSED_DM/HDMtYYB AS 'Country ,Closed'
	NUM_SCR AS 'Subjects ,Screened'
	NUM_SF AS 'Subjects ,Screen ,Failed'
	NUM_RAND AS 'Subjects ,Randomized'
	NUM_DISCON AS 'Subjects ,Discontinued'
	NUM_COMP AS 'Subjects ,Completed'
	COMPUTE BAND1/I1=IF LAST BAND1 EQ 1 THEN 2 ELSE 1; NOPRINT
BY COUNTRY_NM NOPRINT
HEADING
""
FOOTING
""
ON TABLE SET PAGE-NUM OFF 
ON TABLE NOTOTAL
ON TABLE PCHOLD FORMAT AHTML
ON TABLE SET HTMLCSS ON
ON TABLE SET STYLE *
     UNITS=IN,
     SQUEEZE=ON,
     ORIENTATION=LANDSCAPE,
$
TYPE=REPORT,
     GRID=OFF,
     FONT='VERDANA',
     SIZE=8,
     LINES-PER-PAGE=20,
$
TYPE=TITLE,
     STYLE=BOLD,
$
TYPE=DATA,
	BACKCOLOR=RGB(217 231 250),
	WHEN=BAND1 EQ 1,
$
ENDSTYLE
END
 

Sometimes I get no error, just a blank screen and I can see by viewing source that an array was not finished. ex [32,-989,0],[60,6

Sometimes I get an error message:
Error: Expected ']'
Code: 0
URL: http://192.168.1.100/ibi_apps/WFServlet

On rare occasions it works, maybe 1 out of 50 tries

Thanks for the help

This message has been edited. Last edited by: Kerry,


WebFOCUS 7.6.8
Linux
HTML,AHTML,PDF
 
Posts: 37 | Registered: June 12, 2009Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Have you tried running the report where you put the reformatted columns in a define?
It may be that because of the reformatting the active html code acts funny.
So, try:
DEFINE FILE COUNTRIES_TABLE
CPLAN_FSI/HDMtYYB  = PLAN_FSI;
CACT_FSI/HDMtYYB   = ACT_FSI;
CPLAN_FSD/HDMtYYB  = PLAN_FSD;
CACT_FSD/HDMtYYB   = ACT_FSD;
CCLOSED_DM/HDMtYYB = CLOSED_DM;
END
TABLE FILE COUNTRIES_TABLE
PRINT 
COUNTRY_NM AS 'Country'
STATUS_NM AS 'Status'
CPLAN_FSI AS 'Planned ,First ,Site ,Initiated'
CACT_FSI AS 'Actual ,First ,Site ,Initiated'
CPLAN_FSD AS 'Planned ,First ,Site ,Shipment'
CACT_FSD AS 'Actual ,First ,Site ,Shipment'
ACT_COUNT AS 'Active ,Number ,of ,Sites'
PLAN_COUNT AS 'Planned ,Number ,of ,Sites'
CCLOSED_DM AS 'Country ,Closed'
NUM_SCR AS 'Subjects ,Screened'
NUM_SF AS 'Subjects ,Screen ,Failed'
NUM_RAND AS 'Subjects ,Randomized'
NUM_DISCON AS 'Subjects ,Discontinued'
NUM_COMP AS 'Subjects ,Completed'
COMPUTE BAND1/I1=IF LAST BAND1 EQ 1 THEN 2 ELSE 1; NOPRINT
BY COUNTRY_NM NOPRINT
HEADING
""
FOOTING
""
ON TABLE SET PAGE-NUM OFF 
ON TABLE NOTOTAL
ON TABLE PCHOLD FORMAT AHTML
ON TABLE SET HTMLCSS ON
ON TABLE SET STYLE *
     UNITS=IN,
     SQUEEZE=ON,
     ORIENTATION=LANDSCAPE,
$
TYPE=REPORT,
     GRID=OFF,
     FONT='VERDANA',
     SIZE=8,
     LINES-PER-PAGE=20,
$
TYPE=TITLE,
     STYLE=BOLD,
$
TYPE=DATA,
	BACKCOLOR=RGB(217 231 250),
	WHEN=BAND1 EQ 1,
$
ENDSTYLE
END
and see what happens. Hope it works out, at least you tried ...


GamP

- Using AS 8.2.01 on Windows 7 - IE11.
in Focus since 1988
 
Posts: 1960 | Location: Netherlands | Registered: September 25, 2007Reply With QuoteReport This Post
Silver Member
posted Hide Post
No luck, I tried this and creating a hold file both still get the same error.


WebFOCUS 7.6.8
Linux
HTML,AHTML,PDF
 
Posts: 37 | Registered: June 12, 2009Reply With QuoteReport This Post
Expert
posted Hide Post
Hi Cody,

Suggestion from our technicals: this looks like some type of javascript problem that could be caused for any number of reasons. Please open a case with Customer Support Services, and upload the procedure, master file, and access file (if there is one) to the case management site. You may either call at 1-800-736-6130, or access online at InfoResponse.

Cheers,

Kerry


Kerry Zhan
Focal Point Moderator
Information Builders, Inc.
 
Posts: 1950 | Location: New York | Registered: November 16, 2004Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Active Report Problem

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.