Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Excel gone after a while?
Go
New
Search
Notify
Tools
Reply
  
[CLOSED] Excel gone after a while?
 Login/Join
 
Master
posted
Hi all,

I have a question. I tried to search it in the forum but couldn't find anything.

I have a .fex with output format EXL2K.

When done the browser show a message what to do with it:
Open, Save or Cancel

But I'm not always behind my computer when this happens. And when I come back I choose 'open'... ...and then nothing happens. I seems that the excel is removed from the server? Does it clean-up after a time-out?

Setting the windows xls-setting to open automatically is not what I want. I need it to ask me what to do with it.

Does anyone ever noticed this?
Is it a time-out setting?

It does seems to happen only with bigger files.. ( 40000+ rows )

any clues?

Greets,Dave

This message has been edited. Last edited by: Kerry,


_____________________
WF: 8.0.0.9 > going 8.2.0.5
 
Posts: 669 | Location: Veghel, The Netherlands | Registered: February 16, 2010Reply With QuoteReport This Post
Gold member
posted Hide Post
Hi,

I've often had this problem. No idea why it happen though and never thought to ask!
Interested to see if anyone does know why it happens.

Jinx.


7.6.11
Windows
HTML, PDF, Excel etc
DevStudio/Webfocus/Focus IBM
SQL Server 2000 / 2008
DB2
 
Posts: 78 | Location: UK | Registered: February 07, 2008Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Someone explained it to me once...Because when the report is run...depending on your Release of WebFocus..the report is actually going to a .MHT format and not native Excel. I'm sure there is a better explanation.

It is quite annoying.
 
Posts: 1903 | Location: San Antonio | Registered: February 28, 2005Reply With QuoteReport This Post
Virtuoso
posted Hide Post
May also have something to do with redirection. With redirection enabled for a file type, the file is actually saved to a temp location on the webserver ( as opposed to being sent directly to the browser) and then the user receives a redirection to that location. As it is temporary, it IS cleaned up after a while. There is a setting that determines how long those are held, but I can't remeber off the top of my head what it is. You might also turning off redirection for xls/mht file types in the W Client console and see if that makes any difference.


Regards,

Darin



In FOCUS since 1991
WF Server: 7.7.04 on Linux and Z/OS, ReportCaster, Self-Service, MRE, Java, Flex
Data: DB2/UDB, Adabas, SQL Server Output: HTML,PDF,EXL2K/07, PS, AHTML, Flex
WF Client: 77 on Linux w/Tomcat
 
Posts: 2298 | Location: Salt Lake City, Utah | Registered: February 02, 2007Reply With QuoteReport This Post
Expert
posted Hide Post
We have this problem too, but only since we changed the environment from two-tier to three-tier. I've never had the problem with the web server and WebFOCUS servers on the same machine. We now have the web server on a windows machine and the WebFOCUS server on a AIX machine and we very often have the problem. We use IBM WebSphere and IBM HTTP Server, I dug around the IBM support site and may have found a hot fix to correct the problem, but it has not been applied yet.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
Virtuoso
posted Hide Post
we also have this, and running on the same machine
what i do is running it deferred.

might be a solution for you too




Frank

prod: WF 7.6.10 platform Windows,
databases: msSQL2000, msSQL2005, RMS, Oracle, Sybase,IE7
test: WF 7.6.10 on the same platform and databases,IE7

 
Posts: 2387 | Location: Amsterdam, the Netherlands | Registered: December 03, 2006Reply With QuoteReport This Post
Expert
posted Hide Post
I would suggest that you don't rely on the report still being there, instead, save it somewhere, and return a link to it or email it.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6319 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Reply With QuoteReport This Post
Master
posted Hide Post
Thanks so far,

I trying to find a solid solution.
"Run deferred" is indeed good way to prevent your reports from dissapearing.
But for the end-user this somtimes seems unneccesary elaborate.

I'm interested in Francis' remark about the possible time-out.

Waz:
I that case I must create an unique filename I guess?
And a e-mail containing a link.
Can this be done in a self-service report on a dashboard?
( could you give me some pointers where I might find a sample of that? )

( and I have to check with IT how and where to save... )

Thanks all, Dave


_____________________
WF: 8.0.0.9 > going 8.2.0.5
 
Posts: 669 | Location: Veghel, The Netherlands | Registered: February 16, 2010Reply With QuoteReport This Post
Expert
posted Hide Post
I've worked with WebFOCUS for over 10 years, why is this problem rearing its ugly head now?


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Excel gone after a while?

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.