Focal Point
[CLOSED]Portal URL getting redirected to tree

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/7971057331/m/4267064386

August 17, 2016, 11:31 AM
Rajna Nannat
[CLOSED]Portal URL getting redirected to tree
Hi,

I need to publish a portal URL to the users as below

http://domainname/ibi_apps/bip/yourportalname

But when I click on it, it takes me to the tree client portal page by default where my last session was. Is there a way to control this portal call URL take me only to the portal page itself and not to the client page where we have the tree.

I tried remove customization for myself on the portal , but didn't seem to work if I close the browser and open again.

Thanks,
Rajna

This message has been edited. Last edited by: <Emily McAllister>,


WebFOCUS 8.1.05
Windows
Excel, PDF, HTML
August 17, 2016, 12:59 PM
MartinY
In your Portal, remove the "Close" menu option and replace it by the "Sign out" one.

The "Close" redirect to the default IBI portal (with the three) when the "Sign out" redirect to the portal and keep it as the default for next login.

The url used should be something like this
http://domain/ibi_apps/bip/portal/portalname



WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
August 17, 2016, 04:49 PM
Rajna Nannat
Even if I sign out from the portal page and close all explorer windows. Logging in back from URL takes me to the http:\\domain\ibi_apps page. Is there any client setting or customization privilege to prevent this behavior?


WebFOCUS 8.1.05
Windows
Excel, PDF, HTML
August 18, 2016, 08:00 AM
MartinY
Just to confirm that you are using
quote:


the
/portal/
is very important

This message has been edited. Last edited by: MartinY,


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
August 19, 2016, 11:51 AM
Rajna Nannat
Yes Martin, the link is exactly used the way given by you.


WebFOCUS 8.1.05
Windows
Excel, PDF, HTML
August 19, 2016, 01:26 PM
MartinY
I do not understand why it doesn't work for you.

If I always use the sample url, I always get back to that Portal and my portals only have the "Sign out" and not the "Close".
If I close the browser you need to use again the provided url with .../bip/portal/portalname otherwise it is going to be the default IBI portal that will be loaded.

If no one else have an answer, I suggest to open a case with TechSupport.


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
August 19, 2016, 05:50 PM
Ram Prasad E
Rajna,

What type of security is WF Client configured? Pre-Authentication or WF Security?

Are you using IIS or Tomcat as Web Server?

Thanks,
Ram


WebFOCUS 8.1.05
Windows
http://ibiwebfocus.wordpress.com
https://www.facebook.com/groups/ibi.webfocus/
August 19, 2016, 06:18 PM
Ram Prasad E
Also check value for this variable - "WF_SIGNON_MESSAGE". You can find this in Admin Console -> Configuration -> Client Settings -> General.


WebFOCUS 8.1.05
Windows
http://ibiwebfocus.wordpress.com
https://www.facebook.com/groups/ibi.webfocus/
August 22, 2016, 12:09 AM
Rajna Nannat
Hi Ram

Using Tom Cat Server here and security is set to default and prompts user id /pswd on the client link, The WF_SIGNON_MESSAGE is having the value &FOCHTMLURL/default.htm and WF_SIGNON is set to yes.
On the URL click its calling the page wfsignon.htm under ibi_html folder.


WebFOCUS 8.1.05
Windows
Excel, PDF, HTML