Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

Join the TIBCO Community
TIBCO Community is a collaborative space for users to share knowledge and support one another in making the best use of TIBCO products and services. There are several TIBCO WebFOCUS resources in the community.

  • From the Home page, select Predict: WebFOCUS to view articles, questions, and trending articles.
  • Select Products from the top navigation bar, scroll, and then select the TIBCO WebFOCUS product page to view product overview, articles, and discussions.
  • Request access to the private WebFOCUS User Group (login required) to network with fellow members.

Former myibi community members should have received an email on 8/3/22 to activate their user accounts to join the community. Check your Spam folder for the email. Please get in touch with us at community@tibco.com for further assistance. Reference the community FAQ to learn more about the community.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Maintain and images ?

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[SOLVED] Maintain and images ?
 Login/Join
 
Platinum Member
posted
I tried to change a reference to an image in a Maintain, to a similar file in another Project directory (apps/images/). But Maintain insisted on keeping the link to the file in the Maintain project (apps/car/).

I would like to consolidate and share all our image files in the one /image/ folder, but Maintain is fighting me.

I also tried changing the 'resourcepath's in the form xml, and the image didn't show up when I ran the maintain, but the image properties path looked OK. Later I realized that I don't have the new /image/ directory in the Servers APPPATH, but then I'm not sure if that is necessary for a non-executable file...

Also, why is the Image selection/edit popup in the Maintain Form Editor so complicated ?

It takes a long time to click through all the meaningless actions, and has never made any sense to me, through I have used it many times. It seems like a simple file selection dialog should do the trick.

Really poor UI, IMHO

Perhaps these issues are related, perhaps not...

TIA,

This message has been edited. Last edited by: Kerry,


Regards,
Dave

http://www.daveayers.com

WebFocus/Maintain 7.6.4-8
on Win2000 and 2003 Server
 
Posts: 165 | Location: Detroit Metro | Registered: September 17, 2003Report This Post
Expert
posted Hide Post
I agree with you, it seems very complex.

perhaps you could create an HTML object and put the image in there, it will be normal HTML code.

This message has been edited. Last edited by: Waz,


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Master
posted Hide Post
As with most things Maintain, there is always more than one way do accomplish this task. If you would prefer not to use the image Resource Wizard you could always just create a variable with the path and image name:

compute imgpath/a50 = '/approot/appname/image.gif';

This way the image will be dynamically pulled from the application path on the server at runtime. While I have hardcoded the name here, you can use dynamic values passed in or from the database as well.

As for the panels in the Resource Wizard, the last couple of panels just make sure that the same image is not overwritting another image of the same name and that the resource has a unique name. Yes, it is a little cumbersome, but you can bypass it completely by using dynamic or hardcoded image paths and selecting "From the resource selected here"

Mark
 
Posts: 663 | Location: New York | Registered: May 08, 2003Report This Post
Platinum Member
posted Hide Post
Mark,

quote:
the last couple of panels just make sure that the same image is not overwriting another image of the same name and that the resource has a unique name.


I hear what you are saying, but it has never made sense to me. Why does it care so much about the very rare situation of over writing a file, to spend two windows on it ? And why do I need to care about the unique name of a resource, when so many others are handled under the covers anyway ?

I would like that stuff to be replaced with a simple file dialog to paste the path and file name into the image object properties !
</ non-Feature request  :)  


Also, can you tell me if my /apps/images/ needs to be in APPPATH for Maritain to find image files there ?
(assuming I can get the right paths in place)


Regards,
Dave

http://www.daveayers.com

WebFocus/Maintain 7.6.4-8
on Win2000 and 2003 Server
 
Posts: 165 | Location: Detroit Metro | Registered: September 17, 2003Report This Post
Master
posted Hide Post
Dave
I will put your suggestion in to the team about the image dialogue.

The directory containing the images does not have to be in the APP PATH. When you deploy, you drag the resource files (Images, JavaScript, etc...) to the application server. When deployment takes place, the paths are automatically set, so when you run the images appear in the correct location.

Mark

PS Again, you can override this process AND the image wizards just by using a computed variable path.
 
Posts: 663 | Location: New York | Registered: May 08, 2003Report This Post
Platinum Member
posted Hide Post
Mark, I tested your suggestion and it worked,

compute imgpath/a50 = '/approot/images/HeaderTemplate.jpg';


Here is the results of a maintain app where I edited the xml to provide the path to the shared image folder, it didn't display the image, but I got the URL (from properties) of the missing maintain image:

http://localhost/approot/images/HeaderTemplate.jpg

And the URL (from properties) of a working image from a fex's -HTMLFORM:

http://localhost:8080/approot/...s/HeaderTemplate.jpg

Isn't Maintain part of the WebFocus family ? Shouldn't it respect approot and form proper URL's to web resources ?

I felt kind of stupid Computing the image paths into variables. Yes it works, but I have a thing against workarounds, and this is one for sure. Do you think the maintain team might be interested in these results ? Maybe they can fix the URL paths while they are fixing the Image dialog ?

Thanks,


Regards,
Dave

http://www.daveayers.com

WebFocus/Maintain 7.6.4-8
on Win2000 and 2003 Server
 
Posts: 165 | Location: Detroit Metro | Registered: September 17, 2003Report This Post
Master
posted Hide Post
David
When you deploy your Maintain application are you using the Deployment tool? From Developers Studio, for your project, create a deployment scenario. Once created you are brought into a deployment screen that allows you to drag and drop ALL of your application files to both the Maintain Servers AND Web Servers.

At that point you can create or point to another directory, under the Web Server for your images and other resource files. The deployment process takes care of all of the paths. I have done this for many applications and the images do display properly from the folder I have deployed them to.

If you are not using this process, please look into it. If you are and you are not getting the correct results, please open a case with the help desk... Or use the computed paths.

Mark
 
Posts: 663 | Location: New York | Registered: May 08, 2003Report This Post
Platinum Member
posted Hide Post
Mark,

Yes. I deployed the maintain application, and the 'images' with deployment scenarios in my Dev. Studio to the remote WF server.

I tested on localhost and that displayed the images, but testing on the remote server did not, and the examples above are from the remote test session.

Both the WF Client and Reporting server are on the same machine right now , but that will change shortly...


Regards,
Dave

http://www.daveayers.com

WebFocus/Maintain 7.6.4-8
on Win2000 and 2003 Server
 
Posts: 165 | Location: Detroit Metro | Registered: September 17, 2003Report This Post
Expert
posted Hide Post
Mark, It would be nice to have the Image wizard to support static images in other places or on other web servers, instead of it having to make a copy locally.

At least this way all the image functionality is in one place.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Master
posted Hide Post
Gentlemen
The best way to get new features in the product is to open a case in customer support. Customer concerns get the highest priority. Please open a case with as much detail as possible and we can go from there.

Thank you!
Mark Derwin
 
Posts: 663 | Location: New York | Registered: May 08, 2003Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Maintain and images ?

Copyright © 1996-2020 Information Builders