Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED, but worried] Code pages and accents revisited, again.
Go
New
Search
Notify
Tools
Reply
  
[CLOSED, but worried] Code pages and accents revisited, again.
 Login/Join
 
Expert
posted
I thought I resolved this, but the accents in my code disappear when I save and re-open in DevStudio.

Result of ? LANG:

NATIONAL LANGUAGE INFORMATION
Language                001/AMENGLISH   (   ,en)
Code Page               137
Client Code Page        437
Dollar                  24($)
Lowcase alphabet        YES
Decimal notation        OFF(.)
Currency symbol         $
Date/Time format        EDA
NLS sort                YES
NLS upcase/lowcase      YES
NLS Control Characters  OFF
DBCS Flag               OFF(SBCS)

None of these accent characters are retained: À, Á, Â, Ç, È, É, Ê, Î, Ï, Ô, à, á, â, ç, è, é, ê, î, ï, ô.

This message has been edited. Last edited by: Francis Mariani,


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
Expert
posted Hide Post
It seems the code page on the client somehow changed from the required 137 to the default 437. I wonder if this happens every time WebFOCUS is updated, not very nice if this is the case.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
Expert
posted Hide Post
Argh!!!

Code page 137 seems to do only half the job!

Works:         á, à, â, ç, Ç, é, É, è, ê, î, ï, ô,
Does not work: Á, À, Â, È, Ê, Î, Ï, Ô


What the heck is going on?


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
Expert
posted Hide Post
Edited the fex and saved and re-opened. Now all accents show up. Strange.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
Expert
posted Hide Post
Did you edit the fex in DS ?

Just wondering.

Confused


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6278 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Reply With QuoteReport This Post
Expert
posted Hide Post
Yes, editing was done in Dev Studio text editor. I haven't found any Language options in Dev Studio, so I just can't explain why the situation occurred.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
Expert
posted Hide Post
Another one for Techsupport ?


Roll Eyes


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6278 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Reply With QuoteReport This Post
Expert
posted Hide Post
Francis,

There used to be an option to "Store data as ANSI" under "Other Settings" in DS - Windows/Options but that has disappeared in 7.6.11. That used to keep symbols such as the Birtish Pound symbol £ for us each time we saved - until we upgraded of course. I got so fed up with having to edit the code each time in DS that I started using HEXBYT(156, 'A1') in DM, Defines and Computes - a bit long winded I know but at least I then didn't have to edit every time!!

Not sure what release it was removed from but it was still there in 7.1.6.

T



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.07 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
 
Posts: 5686 | Location: United Kingdom | Registered: April 08, 2004Reply With QuoteReport This Post
Expert
posted Hide Post
Thanks Tony. "Store data as ANSI" is still there in v7.6.8. Perhaps the setting is removed because the files are now always stored as ANSI?


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED, but worried] Code pages and accents revisited, again.

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.