Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

New TIBCO Community Coming Soon
In early summer, TIBCO plans to launch a new community—with a new user experience, enhanced search, and expanded capabilities for member engagement with answers and discussions! In advance of that, the current myibi community will be retired on April 30. We will continue to provide updates here on both the retirement of myibi and the new community launch.

What You Need to Know about Our New Community
We value the wealth of knowledge and engagement shared by community members and hope the new community will continue cultivating networking, knowledge sharing, and discussion.

During the transition period, from April 20th until the new community is launched this summer, myibi users should access the TIBCO WebFOCUS page to engage.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED]IMAGE URL IN WebFOCUS 8x

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[SOLVED]IMAGE URL IN WebFOCUS 8x
 Login/Join
 
Gold member
posted
Hi,

Have a requirement to load the graph image in the excel starts before the Tabular report (i.e., First 6 Columns are Image and then Tabular report)

I tired to Hold the Graph in GIF file - > ON GRAPH HOLD AS LEAD FORMAT GIF

and then How to use this HOLD file in the Define field, What is the URL to get this image in WF8

In 7x I used as
IMAGE1/A200= '';

But this is not help me in WF8, anyone know how to use IMG SRC in WF8 version ('')

Thanks,
Dev

This message has been edited. Last edited by: <Emily McAllister>,


8202, 8105M, 7.7.03
 
Posts: 79 | Registered: June 12, 2012Report This Post
Master
posted Hide Post
you might want to create a CAR demo of what was working and what your trying to do. I'm little confused on your goal.



- FOCUS Man, just FOCUS!
-----------------------------
Product: WebFOCUS
Version: 8.1.04
Server: Windows 2008 Server
 
Posts: 578 | Registered: October 01, 2014Report This Post
Gold member
posted Hide Post
below is the sample what am trying

-SET &ECHO = ALL;
DEFINE FILE CAR
SUM_VAL1/D12 = DEALER_COST/10;
SUM_VAL2/D12 = DEALER_COST/1.5 * 25;
SUM_VAL3/D12 = DEALER_COST;
END
ENGINE INT CACHE SET ON
-DEFAULTH &WF_STYLE_UNITS='PIXELS';
-DEFAULTH &WF_STYLE_HEIGHT='405.0';
-DEFAULTH &WF_STYLE_WIDTH='770.0';
-DEFAULTH &WF_TITLE='WebFOCUS Report';
GRAPH FILE CAR
-* Created by Info Assist for Graph
SUM SUM_VAL1 AS '' SUM_VAL2 AS '' SUM_VAL3 AS ''
BY COUNTRY AS ''
BY CAR NOPRINT
ON GRAPH HOLD AS LEAD FORMAT GIF
-*ON GRAPH PCHOLD FORMAT PNG
ON GRAPH SET VZERO OFF
ON GRAPH SET HTMLENCODE ON
ON GRAPH SET GRAPHDEFAULT OFF
ON GRAPH SET GRWIDTH 1
ON GRAPH SET UNITS &WF_STYLE_UNITS
ON GRAPH SET HAXIS &WF_STYLE_WIDTH
ON GRAPH SET VAXIS &WF_STYLE_HEIGHT
ON GRAPH SET GRMERGE ADVANCED
ON GRAPH SET GRMULTIGRAPH 0
ON GRAPH SET GRLEGEND 0
ON GRAPH SET GRXAXIS 2
ON GRAPH SET LOOKGRAPH VLINE
ON GRAPH SET STYLE *
*GRAPH_SCRIPT
setPieDepth(0);
setPieTilt(0);
setDepthRadius(0);
setCurveFitEquationDisplay(false);
setPlace(true);
setUseSeriesShapes(true);
setMarkerSizeDefault(50);
*END
INCLUDE=IBFS:/FILE/IBI_HTML_DIR/javaassist/intl/EN/ENIADefault_combine.sty,$
TYPE=REPORT, TITLETEXT=&WF_TITLE.QUOTEDSTRING, $
*GRAPH_SCRIPT
setReportParsingErrors(false);
setSelectionEnableMove(false);
setDisplay(getO1MajorGrid(),false);
setFillColor(getFrame(),new Color(192,192,192));
setTransparentBorderColor(getChartBackground(),false);
setSmoothLines(true);
setLegendPosition(2);
setLegendOrient(0);
setBorderColor(getLegendArea(),new Color(0,0,0));
setTextString(getO1Title(),"");
setFontName(getO1Label(),"ARIAL");
setFontSizeAbsolute(getO1Label(),true);
setAutofit(getO1Label(),false);
setFontSizeInPoints(getO1Label(),10);
setPlaceResize(getO1Label(),0);
setFontName(getY1Label(),"ARIAL");
setTextFormatPreset(getY1Label(),-2);
setGridStyle(getY1MajorGrid(),2);
setAltFmtFrameNumColors(getY1AltFmtFrame(),5);
setTransparentBorderColor(getLegendArea(),false);
*END
ENDSTYLE
END
-RUN
-*IA_GRAPH_FINISH
DEFINE FILE CAR
SPACE/A5='';
IMAGE1/A200= '';
END
TABLE FILE CAR
BY CAR NOPRINT
HEADING
“IMAGE1”
END
-EXIT

This message has been edited. Last edited by: Dev,


8202, 8105M, 7.7.03
 
Posts: 79 | Registered: June 12, 2012Report This Post
Expert
posted Hide Post
Please use the code tags for posting code.

When editing click on the
</>


APPROOT is now hidden with WF8.

You should put your images in the repository, and then reference them with something like this:

<img src="/ibi_apps/run.bip?BIP_REQUEST_TYPE=BIP_RUN&|BIP_folder=IBFS:/WFC/Repository/{location}&|BIP_item=' || {image name} || '">


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Master
posted Hide Post
Or you can put a folder called images in your \WebFOCUS\ibi\WebFOCUS81\ibi_html folder. Then access it directly using yourDom:8080/ibi_html/yourFolder/Yourfiles.jpg



- FOCUS Man, just FOCUS!
-----------------------------
Product: WebFOCUS
Version: 8.1.04
Server: Windows 2008 Server
 
Posts: 578 | Registered: October 01, 2014Report This Post
Gold member
posted Hide Post
Thanks Waz

I changed few thing and tried below URL its working in HTML but not in Excel format, Is there we need to change any server settings or in the Code level

img src=http://wwwdev.webfocus8.TEST.com/ibi_apps/run.bip?BIP_REQUEST_TYPE=BIP_RUN&|BIP_folder=IBFS:/WFC/Repository/EMPLOy1/Image&|BIP_item=graph_test.png

How to HOLD the image file in the Content folder and how to use the same!


8202, 8105M, 7.7.03
 
Posts: 79 | Registered: June 12, 2012Report This Post
Expert
posted Hide Post
What format Excel are you using ?

for PDF and Excel it should be different


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Gold member
posted Hide Post
Am using Excel Waz


8202, 8105M, 7.7.03
 
Posts: 79 | Registered: June 12, 2012Report This Post
Expert
posted Hide Post
quote:
What format Excel are you using ?


What output format are you using ?

This should be detailed in the documentation


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Gold member
posted Hide Post
XLSX


8202, 8105M, 7.7.03
 
Posts: 79 | Registered: June 12, 2012Report This Post
Expert
posted Hide Post
You should just be able to specify the location in the stylesheet with XLSX format.

IMAGE={location}, $

location is IBFS.... or if the image is on the WebFOCUS server, and its in the path, then the name.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Gold member
posted Hide Post
Thanks to all Smiler

Its working. below is the code. But this image is storing in the Data server.
Am trying to HOLD this image in the content and have to retrieve. Please share if anyone know!

SET GRAPHSERVURL=''
FILEDEF CHART DISK chart.gif
END

GRAPH FILE CAR
SUM SALES
ACROSS COUNTRY
ON TABLE HOLD AS CHART FORMAT GIF
ON TABLE SET STYLE *
ENDSTYLE
END

DEFINE FILE GGSALES
SHOWCAT/A100='chart.gif';
END
TABLE FILE GGSALES
SUM DOLLARS UNITS BUDDOLLARS BUDUNITS SHOWCAT NOPRINT BY REGION BY ST BY CATEGORY BY PRODUCT
ON TABLE SET BYDISPLAY ON
ON TABLE PCHOLD FORMAT EXL07
ON TABLE SET STYLE *
FONT=ARIAL,SIZE=12,XLSXPAGESETS=ON,TOPMARGIN=1,BOTTOMMARGIN=1,ORIENTATION=LANDSCAPE,PAGESIZE=LETTER,$
TYPE=TITLE, COLOR=WHITE, BACKCOLOR=GREY,$
TYPE=DATA,COLUMN=DOLLARS,IMAGE=(SHOWCAT),POSITION=(+0.000000 +0.000000),SIZE=(.5 .5),$
END

This message has been edited. Last edited by: Dev,


8202, 8105M, 7.7.03
 
Posts: 79 | Registered: June 12, 2012Report This Post
Platinum Member
posted Hide Post
Can't you just replace IMAGE=(SHOWCAT) with IMAGE=file.gif and as along as file.gif is in the path it should pick it up.
 
Posts: 196 | Location: London, UK | Registered: December 06, 2005Report This Post
Gold member
posted Hide Post
Yes it will work, Why we need to assign the image file name in separate separate place, am just kept as in one place and am reusing.


8202, 8105M, 7.7.03
 
Posts: 79 | Registered: June 12, 2012Report This Post
Expert
posted Hide Post
The TYPE=DATA,COLUMN=SHOWCAT,IMAGE=(SHOWCAT),SIZE(n n),$ syntax is how you would present the image into the output when the contents of the SHOWCAT field is a BLOB.

T



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.07 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
 
Posts: 5694 | Location: United Kingdom | Registered: April 08, 2004Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED]IMAGE URL IN WebFOCUS 8x

Copyright © 1996-2020 Information Builders