Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Move IBI Repository from SQL 2000 to SQL 2008 - What am I doing wrong?
Go
New
Search
Notify
Tools
Reply
  
[SOLVED] Move IBI Repository from SQL 2000 to SQL 2008 - What am I doing wrong?
 Login/Join
 
Gold member
posted
Hi,

I've tried following all of the notes in the WebFOCUS & ReportCaster Installation and Configuration Book, but cannot get it right. Below are the steps I'm following, can anyone possibly see anything I'm doing wrong or missing?

1. Install SQL 2005 JDBC driver (this should work for 2008 right?).
2. Setup a new repository on the target database server, with correct permissions etc.
3. Change the CLASSPATH variables classpath.bat to use the 2005 JDBC driver.
4. Change the registry CLASSPATH to use the 2005 driver.
5. In Tomcat, change the Java Classpath field to use the 2005 driver.
6. Edit the connection information to point to the new server and database. This includes changing the CLASS and url.

I've tried these changes several times but either get an error about the driver or that it cannot connect to the database.

Could it be that I'm trying to connect to a SQL Server non default instance and it cannot do this?

Any suggestions would be great!

Thanks,

Jinx.

This message has been edited. Last edited by: Jinx,


7.6.11
Windows
HTML, PDF, Excel etc
DevStudio/Webfocus/Focus IBM
SQL Server 2000 / 2008
DB2
 
Posts: 78 | Location: UK | Registered: February 07, 2008Reply With QuoteReport This Post
<JG>
posted
for SQL Server 2008 you should use the version 3 driver sqljdbc4.jar
 
Reply With QuoteReport This Post
Gold member
posted Hide Post
Hi,

Is there a difference in the way that one uses this in the URL, as I tried all of the changes listed in my first post with this driver as well, with no success?

Jinx.


7.6.11
Windows
HTML, PDF, Excel etc
DevStudio/Webfocus/Focus IBM
SQL Server 2000 / 2008
DB2
 
Posts: 78 | Location: UK | Registered: February 07, 2008Reply With QuoteReport This Post
Gold member
posted Hide Post
The solution to this problem was that I was using a SQL Server named instance rather than the default instance. The named instance has a dynamic TCP/IP port setting and I needed to manually set a static port. That solved the problem!

Jinx.


7.6.11
Windows
HTML, PDF, Excel etc
DevStudio/Webfocus/Focus IBM
SQL Server 2000 / 2008
DB2
 
Posts: 78 | Location: UK | Registered: February 07, 2008Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Move IBI Repository from SQL 2000 to SQL 2008 - What am I doing wrong?

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.