Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Problem with JavaScript alias './ibi_html/' after upgrade
Go
New
Search
Notify
Tools
Reply
  
[SOLVED] Problem with JavaScript alias './ibi_html/' after upgrade
 Login/Join
 
Platinum Member
posted
We recently upgraded from 8.0.0.9 to 8.1.0.5. It wasn't an easy upgrade and at one point we had to go back and do it again. I've installed the upgraded App and Dev Studios on my desktop; have un-installed them and re-installed them, and I'm having a problem opening an HTML page. I have three HTML pages in one folder that are causing a problem. They were all created in App Studio. All three of the pages I can open in App Studio, however, when I run them I get the "JavaScript alias './ibi_html/' is not valid." error. However, two of the pages I can run if I right click on the file in the folder and select "Run". Unfortunately when I try to run the third report it results in the same error message. I can run the individual fexes that make up the third report, however, I can't run the html page.

Is there some some setting that may have been overlooked in the upgrade process? We've poured through the mountains/plethora/reams of documentation regarding upgrades and have come up empty. Has anyone else had this type of experience after an upgrade? I've scoured the forum and have seen several instances regarding this type of error but they don't quite fit this type of scenario.

Any advice would be welcome.

Thanks!

This message has been edited. Last edited by: Pondog,


WebFOCUS 8.1.05
Windows, All Outputs
 
Posts: 118 | Location: Birmingham, Al | Registered: July 23, 2015Reply With QuoteReport This Post
Expert
posted Hide Post
In V8, the alias to ibi_html is now /ibi_apps/ibi_html


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.06OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Know The Code

 
Posts: 6136 | Location: 33.8688° S, 151.2093° E | Registered: October 31, 2006Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Hey Waz,

Thanks for the info. Forgive my newbie-ness, but, how do I go about implementing /ibi_apps/ibi_html ?


WebFOCUS 8.1.05
Windows, All Outputs
 
Posts: 118 | Location: Birmingham, Al | Registered: July 23, 2015Reply With QuoteReport This Post
Guru
posted Hide Post
It is supposed to be an alias configured on your webserver.

Which webserver are you using?

For Tomcat Catalina its located on \ibi\tomcat\conf\Catalina\localhost

Files looks like this:
ibi_html.xml
 <?xml version='1.0' encoding='utf-8'?>
<Context docBase="C:\ibi\AppStudio81\webapps\ibi_html" path="/ibi_html">
</Context>


ibi_apps.xml
<?xml version='1.0' encoding='utf-8'?>
<Context docBase="C:\ibi\AppStudio81\webapps\webfocus" path="/ibi_apps" useHttpOnly="true">
</Context>


approot.xml
 
<?xml version='1.0' encoding='utf-8'?>
<Context docBase="C:\ibi\apps" path="/approot">
</Context>
 




I hope it helps.


WebFOCUS 8.1.05 / APP Studio
 
Posts: 272 | Location: Brazil | Registered: October 31, 2006Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Ricardo,

We went through and checked the files and everything was in place as you described. I ended up opening a case with IB. Here is their solution:



quote:
We can easily correct this issue by doing the following:

1. From the WebFOCUS Client open the Administration Console
2. Navigate to Configuration > Application Settings > Filters
3. Change the value of IBI_GZIP.enabled to TRUE
4. Save changes

You should no longer encounter the ./ibi_html/ is not valid error.


It worked; this case is closed.


WebFOCUS 8.1.05
Windows, All Outputs
 
Posts: 118 | Location: Birmingham, Al | Registered: July 23, 2015Reply With QuoteReport This Post
Expert
posted Hide Post
You know, I missed that you said its was './ibi_html/'

the setting must turn on absolute addressing or something.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.06OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Know The Code

 
Posts: 6136 | Location: 33.8688° S, 151.2093° E | Registered: October 31, 2006Reply With QuoteReport This Post
Member
posted Hide Post
Hi,

I am using 8201M. I don't find IBI_GZIP in the filter settings. Can you help me where to find athat.

Thanks.

quote:
Originally posted by Pondog:
Ricardo,

We went through and checked the files and everything was in place as you described. I ended up opening a case with IB. Here is their solution:



quote:
We can easily correct this issue by doing the following:

1. From the WebFOCUS Client open the Administration Console
2. Navigate to Configuration > Application Settings > Filters
3. Change the value of IBI_GZIP.enabled to TRUE
4. Save changes

You should no longer encounter the ./ibi_html/ is not valid error.


It worked; this case is closed.


WebFOCUS 8201M
Windows 10
Excel, HTML, PDF, AHTML
 
Posts: 6 | Location: Birmingham | Registered: October 09, 2017Reply With QuoteReport This Post
Virtuoso
posted Hide Post
ThinkWF

That setting does not exist in 8.2 anymore. If you are experiencing the same issue I suggest you open a case with techsupport.


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
 
Posts: 1694 | Location: Customer Support | Registered: April 12, 2005Reply With QuoteReport This Post
Member
posted Hide Post
Thank you Chuck


WebFOCUS 8201M
Windows 10
Excel, HTML, PDF, AHTML
 
Posts: 6 | Location: Birmingham | Registered: October 09, 2017Reply With QuoteReport This Post
Member
posted Hide Post
I am also facing the same issue on 8.2.03
Was there a ticket raised for this issue ?


WEBFOCUS 82
Windows X64
HTML,PDF,EXCEL
 
Posts: 9 | Registered: December 08, 2017Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Problem with JavaScript alias './ibi_html/' after upgrade

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.