Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Is the number of hold files in one fex limited?
Go
New
Search
Notify
Tools
Reply
  
[CLOSED] Is the number of hold files in one fex limited?
 Login/Join
 
Member
posted
Hello all,

I am using InfoAssist and have four hold files and the final "report" created. I now need to join in another table on the summarized data, but when I try to create what would be the fifth hold file, I get a pop-up dialog that says "Please add at least one field to the report." Since I already have fields there, I am wondering if I have hit a limitation to the number of hold files one can have in a fex. Does anyone know if this might be what is happening? I can't find anything in the manual or searching tech support that says there is a limitation.

Thanks,
Chris

Update 1/8/2016 - I no longer think the error message that I'm getting is related to the number of hold files in a fex, because now I'm getting it when I try to add a third hold file in my reconfigured design. I am now suspecting it has something to do with having multiple data sources (i.e. DB2 and SQL Server). I would still like to know if anyone has run into this error message and what the problem really might be.

Thanks,
Chris

This message has been edited. Last edited by: Tamra,


WebFOCUS 8.1.03
Excel, PDF, HTML, Active Reports
 
Posts: 13 | Registered: February 23, 2014Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Is there a FOCxxxxx error number associated with this message? Could you provide a screen shot or step by step of how to cause the error?


WebFOCUS 8206, Unix, Windows
 
Posts: 1707 | Location: New York City | Registered: December 30, 2015Reply With QuoteReport This Post
Master
posted Hide Post
I don't use InfoAssist but we have fexes that have dozens of hold files. I know of no limit and I been using FOCUS and WebFOCUS for 30 years.

Since you obviously have multiple steps in your procedure, make sure that JOINs and DEFINEs are cleared when you no longer need them. I try to have the code look like this:
JOINs .....

DEFINEs

TABLE, TABLEF, GRAPH ...
...
END

DEFINE FILE XXXXX CLEAR
END

JOIN CLEAR *


I know FOCUS and WebFOCUS is supposed to clear DEFINES when a JOIN CLEAR * is done, but I still code it anyway, call it my distrust of defaults.

To me that pop-up dialog that says "Please add at least one field to the report." is saying you have a TABLE request with no fields.


In FOCUS since 1985. Prod WF 8.0.08 (z90/Suse Linux) DB (Oracle 11g), Self Serv, Report Caster, WebServer Intel/Linux.
 
Posts: 938 | Location: Oklahoma City | Registered: October 27, 2006Reply With QuoteReport This Post
Member
posted Hide Post
BabakNYC - there is no FOCxxxxx error message. The error message comes up immediately when I click the "File" button in IA. The screen shot

jgelona - this is the InfoAssist forum, so I was hoping to get an IA answer. I myself have the luxury of using App Studio (which I've switched to for this project and it is working fine), but our other users don't have that option.

Thanks,
Chris

This message has been edited. Last edited by: BC_Chris,


WebFOCUS 8.1.03
Excel, PDF, HTML, Active Reports
 
Posts: 13 | Registered: February 23, 2014Reply With QuoteReport This Post
Virtuoso
posted Hide Post
The error makes one think you have a report that doesn't point to a database field. The only way you could run into this is if you define a field set to a constant without the WITH to anchor it to a real field (which I don't think is available in IA).

Is there anyway to create the same report without adding all the other previous files? If so, would you get this error when you only have this one request and click File? I haven't seen this error so you might be better off opening a case with tech support so they can trace the error.

This message has been edited. Last edited by: BabakNYC,


WebFOCUS 8206, Unix, Windows
 
Posts: 1707 | Location: New York City | Registered: December 30, 2015Reply With QuoteReport This Post
Guru
posted Hide Post
BC_Chris

Here is a response from the InfoAssist group.

The message does not related to the number of HOLD files. This message would appear when after a HOLD, a user clicks on, say Create Report, in the drop down shown inside the red shape below, and then tries to do a HOLD again before adding any fields in the request.

As far as the limit there really is no limit, it is all based on the backend reporting server.

If the issue is still occurring can you list the step that you take to reproduce the issue and we can review.

Thank you for participating in the Focal Point Forum.

Kindest regards,
Tamra Colangelo
Focal Point Moderator - Information Builders Inc.
* Summit 2016 – June 13-17 in Reno, Nevada  - http://www.informationbuilders.com/events/summit


WebFOCUS 8x - BI Portal, Developer Studio, App Studio, Excel, PDF, Active Formats and HTML5
 
Posts: 487 | Location: Toronto | Registered: June 23, 2009Reply With QuoteReport This Post
Virtuoso
posted Hide Post
So, we are running into the same problem. We've got several holds, and there ARE fields in the request/query we want to create another hold with, but we get that pop-up saying to please put some fields into the request in order to do so. We DO have fields in the request! We need this tool to work like yesterday, and it's riddled with bugs!

Anyone here ever figure out a fix for this as of yet?


8.2.02M (production), 8.2.02M (test), Windows 10, all outputs.
 
Posts: 1110 | Location: USA | Registered: January 27, 2015Reply With QuoteReport This Post
Gold member
posted Hide Post
I have been working with IA for last 2 weeks and have noticed this message aswell. If I am correct this message happend when I clicked "new report" then pressed again "Hold" without adding anything and then changed to other holds etc. I dont have any example right now but if it happens again I will look into it.

If you happend to have still example and there is nothing "secret" there you can pm me the code and I give it a look Smiler


Release: WebFOCUS 8104, AppStudio: 8105
OS: Windows
Output: HTML,Excel,Active Reports
 
Posts: 89 | Registered: November 19, 2013Reply With QuoteReport This Post
Virtuoso
posted Hide Post
SSander,

So, there's at least 3 of us that have ran across this pop-up now. Our analyst's multi-step request is in its 4th request for a final hold before he will then be able to create the 5th and final request that will be output to the end users, but even with an actual field from the original master file describing a MSSQL data source in this final hold request, when pressing the File button to go and hold it (fields present), it states that we need to add at least one field...even though there is a real field trying to be held...

I've already looked over the code and it doesn't show any signs that it could not be held if one desired to hold it. I even replaced the ON TABLE PCHOLD FORMAT HTML line with ON TABLE HOLD AS folder/FINALHOLD FORMAT FOCUS and it worked. However, our analysts won't have the luxury of accessing the code. We need this bug fixed so the tool can be used by them.

I have opened case # 160420038 on this. The IBIer helping me with the case has found an existing bug he added my case to. I haven't gotten any updates on this as of yet.


8.2.02M (production), 8.2.02M (test), Windows 10, all outputs.
 
Posts: 1110 | Location: USA | Registered: January 27, 2015Reply With QuoteReport This Post
Member
posted Hide Post
Hello,

How was this error resolved for you. We are getting the same things. We are running WF8105. I was able to get around it once but what I thought was going to be a viable workaround did not repeat. I've added existing fields from my first HOLD file to the report. I've defined and computed new fields and added them to the report. As soon as I click on FILE I get "Please add at least one field to the report."

Thanks in advance,
Mike@UConn


Currently WebFocus 8.1.05

 
Posts: 12 | Registered: October 03, 2007Reply With QuoteReport This Post
Member
posted Hide Post
We are currently WebFOCUS 8.1.05 - please disregard my old .sig file.

Mike@UConn
 
Posts: 12 | Registered: October 03, 2007Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Is the number of hold files in one fex limited?

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.