Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Image in DEFINE/COMPUTE field
Go
New
Search
Notify
Tools
Reply
  
[SOLVED] Image in DEFINE/COMPUTE field
 Login/Join
 
Platinum Member
posted
Hello

I am trying to display image using DEFINE or COMPUTE field but it is not working. I have to concatenate it with other fields and some text and make 1 single field. So, I cannot just create a placeholder for image and add path in stylesheet. I can place image in app folder or in domain.
TABLE FILE CAR
SUM 
    COMPUTE COLOGO/A100 = '<img src="IBFS:/WFC/Repository/DOMAINname/FOLDERname/images/arrow.png" border=0 />';
    COMPUTE IMAGE/A100  = '<img src="img1.png" border=0 />'; 
BY COUNTRY
ON TABLE SET PAGE NOLEAD
ON TABLE SET HTMLCSS ON
ON TABLE SET STYLE *
GRID=OFF, SIZE=9, $
ENDSTYLE
END  

Please suggest. Thank you.

This message has been edited. Last edited by: WebFOCUS_Dev,


WebFOCUS 8206
All formats
 
Posts: 87 | Registered: September 13, 2017Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Are you getting any kind of error? When I try that with my png file, it works but I do get a warning message.
Here is my compute:
 COMPUTE COLOGO/A100 = '<img src="/approot/enterprise_analytics/wmk_confidential.png" border=0 />';

Here is the warning message I get:
(FOC1517) UNRECOGNIZED COMMAND WMK_CONFIDENTIAL.PNG
However, the image does appear for each row of the output. I wonder if the location for your file is the issue.

--Deb


WebFOCUS 8.2.03 (production), 8.2.06 (testing)
AppStudio, InfoAssist
Windows, All Outputs
 
Posts: 184 | Location: Indiana | Registered: December 05, 2017Reply With QuoteReport This Post
Platinum Member
posted Hide Post
quote:
Originally posted by DWaybright:
Are you getting any kind of error? When I try that with my png file, it works but I do get a warning message.
Here is my compute:
 COMPUTE COLOGO/A100 = '<img src="/approot/enterprise_analytics/wmk_confidential.png" border=0 />';

Here is the warning message I get:
(FOC1517) UNRECOGNIZED COMMAND WMK_CONFIDENTIAL.PNG
However, the image does appear for each row of the output. I wonder if the location for your file is the issue.

--Deb

No error. I am seeing X marks in place of images. For image in domain, I copied "Full Path" from its properties. For image in app folder I gave same as in your example.


WebFOCUS 8206
All formats
 
Posts: 87 | Registered: September 13, 2017Reply With QuoteReport This Post
Expert
posted Hide Post
You can't reference the IBFS path from a web perspective. It needs to be a URL.
I would suggest running the image from WebFOCUS to a new window and copying the URL.

Remove the domain leaving just the '/ibi_apps/.....'

Copy that into the COMPUTE or DEFINE and try again.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6307 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Hallway has posted some examples here: Image in the report column

Also note, where he has
/EDA/EDASERVE/images/D_xlRedArrow.png 
could reference in an images domain:
/WFC/Repository/images/D_xlRedArrow.png  

This message has been edited. Last edited by: dbeagan,


WF 8.2.06
Win10 / IE11
AHTML EXL2K PDF
 
Posts: 185 | Registered: October 19, 2010Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Image in DEFINE/COMPUTE field

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.