Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [Closed] Linking to MRE HTML Launch page from URL
Go
New
Search
Notify
Tools
Reply
  
[Closed] Linking to MRE HTML Launch page from URL
 Login/Join
 
Member
posted
I have created an HTML page to run a .fex in my MRE environment. This runs successfully when run from within the MRE. My users would like this available to them via an existing application as a link. I have reviewed other similar posts and have not been successful at getting this to work. This works when the .fex in named in the link, but when I attempt to link to the html page it does not. The launch page is displayed but when the Run button is clicked, I get a message that I must log in to Managed Reporting. The link that I am using is -
"http://qawebsrv/ibi_apps/WFServlet?IBIMR_domain=untitled/untitled.htm&IBIMR_action=MR_RUN_FEX&IBIMR_sub_action=MR_STD_REPORT&IBIMR_fex=app/safety_audits.htm&IBIF_ex=app/safety_audits.htm&IBIMR_drill=RUNNID&IBIMR_folder=#safetyfm9hy4"
Thanks

This message has been edited. Last edited by: James at WI,


Release 7.7.03,
Windows platform,
Excel, PDF, HTML,Active Reports, Active/Flex,
 
Posts: 25 | Location: Michigan, USA | Registered: May 09, 2008Reply With QuoteReport This Post
Guru
posted Hide Post
off the top of my head, have you tried copying the report to somewhere outside of your MRE environment and referencing that one in the hyperlink?


Developer Studio 7.64
Win XP
Output: mostly HTML, also Excel and PDF

"Never attribute to malice that which can be adequately explained by stupidity." - Heinlein's Razor
 
Posts: 285 | Location: UK | Registered: October 26, 2007Reply With QuoteReport This Post
Member
posted Hide Post
nubi, are you asking me to copy the .fex or the .htm to a location outside of MRE? And which parameter do I change in the link (IBIMR_fex or IBIF_ex ro both)?

Thanks


Release 7.7.03,
Windows platform,
Excel, PDF, HTML,Active Reports, Active/Flex,
 
Posts: 25 | Location: Michigan, USA | Registered: May 09, 2008Reply With QuoteReport This Post
Member
posted Hide Post
Since I plan to use this process to link to public reports only, I am going to put the report and launch pages in the application area (outside of MRE) and link to them there. From what I understand, the issue I am having relates to signing on / security / and the MRE environment.

We can consider this resolved.

thanks


Release 7.7.03,
Windows platform,
Excel, PDF, HTML,Active Reports, Active/Flex,
 
Posts: 25 | Location: Michigan, USA | Registered: May 09, 2008Reply With QuoteReport This Post
<Wayne White>
posted
I am trying to set up a URL Link to an HTML Launch page. I don't really care whether the page is saved in Managed Reporting or on the EDA Server, but, I can't seem to get the path correct. It sounds like you have it figured out. Can you paste the path you used?
 
Reply With QuoteReport This Post
Expert
posted Hide Post
quote:
I don't really care whether the page is saved in Managed Reporting or on the EDA

Actually, you have to care, because it's more complicated to create a link to something within MRE.

A link to an HTML page in an App folder accessible by the web server:
http://server-name/approot/app-name/file-name.html


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
<Wayne White>
posted
Thanks for your quick response. When I said I don't care, I meant I will put the page wherever it is easiest to get to.

I am fairly new to Web Focus & I have tried the path you gave me, but I must be missing something in the translation.

I tried to paste a section of my tree here, but can't. Here is what I see (I know I also have a server address & I do know it).

+ Development Studio Desktop
+ WebFocus Environments
+ Production Environment
+ Data Servers
+USSSERVE
+ Applications
+ LIFEHLTH
+ HTML
PageINeed.htm
 
Reply With QuoteReport This Post
Expert
posted Hide Post
you're using DevStu, yes? and building your launch page from within MRE and leaving it there, yes?

do something different...
point to your fex in devstu, then right click and you'll see an option called 'Publish'.
that creates a launch page, and parks it in /webfocus86/ibi_html/publish directory.

Compare the 2 launch pages...
Your first one will assume you're in MRE
Your second one (Published) will be available from OUTSIDE mre.
You'll have to play with your published page, and format it the way you want, of course.
The act of 'Publishing' from a fex just captures the &vars, and constructs the guts of the page that you'll need for external running.

ok? get busy now.
And be sure to read the 4 basic WebFocus manuals... Developing Applications is probably the one most helpful for this situation.




In Focus since 1979///7706m/5 ;wintel 2008/64;OAM security; Oracle db, ///MRE/BID
 
Posts: 3811 | Location: Manhattan | Registered: October 28, 2003Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [Closed] Linking to MRE HTML Launch page from URL

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.