Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Graphing problem with double across for X-axis (Updated)
Go
New
Search
Notify
Tools
Reply
  
[CLOSED] Graphing problem with double across for X-axis (Updated)
 Login/Join
 
Virtuoso
posted
Hello,

I'm struggling with a GRAPH. Say I want to display the percentage per week of each type of car sold, like so:
APP HOLD IBISAMP
-RUN

DEFINE FILE SALES
	YEAR/I4 = EDIT(EDIT(DATE, '99'));
	MONTH/I2 = EDIT(EDIT(DATE, '$$$99'));
END
TABLE FILE SALES
SUM PCT.CNT.PROD_CODE AS '%'
ACROSS YEAR AS 'Year'
ACROSS MONTH AS 'Month'
BY PROD_CODE AS 'Type'
HEADING
"Sales per code per month"
END


I got this to work for another graph where I didn't have the extra BY-clause, but this cumulative thing is causing me trouble!
What it should look like, except that the X-axis labels should be split into separate month and year labels is this:
GRAPH FILE SALES
SUM PCT.CNT.PROD_CODE AS '%'
ACROSS DATE AS 'Year/Month'
BY PROD_CODE AS 'Type'
HEADING
"Sales per code per month"
ON GRAPH SET LOOKGRAPH VBRSTKPC
ON GRAPH SET GRAPHEDIT SERVER
ON GRAPH SET BARNUMB OFF
ON GRAPH SET 3D OFF
ON GRAPH SET VZERO ON
ON GRAPH SET GRID ON
ON GRAPH SET VAXIS 380
ON GRAPH SET HAXIS 1000
ON GRAPH SET GRMERGE ON
ON GRAPH PCHOLD FORMAT PNG
END


I can't get that to work though, I don't get much further than this:
DEFINE FILE SALES
	YEAR/I4 = EDIT(EDIT(DATE, '99'));
	MONTH/I2 = EDIT(EDIT(DATE, '$$$99'));
END
GRAPH FILE SALES
SUM PCT.CNT.PROD_CODE AS '%'
ACROSS YEAR AS 'Year'
ACROSS MONTH AS 'Month'
BY PROD_CODE AS 'Type'
HEADING
"Sales per code per month"
ON GRAPH PCHOLD FORMAT PNG
ON GRAPH SET GRAPHDEFAULT OFF
ON GRAPH SET VZERO ON
ON GRAPH SET HTMLENCODE ON
ON GRAPH SET HAXIS 1000
ON GRAPH SET VAXIS 380
ON GRAPH SET UNITS PIXELS
ON GRAPH SET LOOKGRAPH VBRSTKPC
ON GRAPH SET BARNUMB OFF
ON GRAPH SET 3D OFF
ON GRAPH SET GRID ON
ON GRAPH SET GRWIDTH 1
ON GRAPH SET GRMERGE ADVANCED
ON GRAPH SET GRMULTIGRAPH 0
ON GRAPH SET GRLEGEND 1
ON GRAPH SET GRXAXIS 2
END


The trouble is, instead of putting year:month on the X-axis (although the label says it did), it's actually putting product-code:year in there and the graph isn't cumulative at all!
The LEGEND looks right though.

I have tried a bunch of things, but I can't seem to get this to work the way I want to. HELP!

[Edit: Used the sample tables now that I know how to query those]

This message has been edited. Last edited by: Kerry,


WebFOCUS 8.1.03, Windows 7-64/2008-64, IBM DB2/400, Oracle 11g & RDB, MS SQL-Server 2005, SAP, PostgreSQL 11, Output: HTML, PDF, Excel 2010
: Member of User Group Benelux :
 
Posts: 1643 | Location: Enschede, Netherlands | Registered: August 12, 2010Reply With QuoteReport This Post
Expert
posted Hide Post
Hi Wep5622,

I consulted with our technicals and was suggested that this issue may be better addressed by a case with Customer Support Services. To open a case, please either call at 1-800-736-6130, or access online at InfoResponse.

Cheers,

Kerry


Kerry Zhan
Focal Point Moderator
Information Builders, Inc.
 
Posts: 1950 | Location: New York | Registered: November 16, 2004Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Thanks for looking into this.
Are you saying this isn't intended behaviour? No wonder I couldn't get it to work then...

Before opening a case on "this", I'm not exactly sure what the issue is exactly - I'm fairly new to creating graphs, there's still quite a bit of trial-and-error involved Wink
Should we be able to tell the graph to ignore the first n sort fields or should the graph select sort fields counting from the tail of the query definition instead of from the head? Is that what is going on here at all?

I probably should try to apply these graphs to the CAR sample tables too...


WebFOCUS 8.1.03, Windows 7-64/2008-64, IBM DB2/400, Oracle 11g & RDB, MS SQL-Server 2005, SAP, PostgreSQL 11, Output: HTML, PDF, Excel 2010
: Member of User Group Benelux :
 
Posts: 1643 | Location: Enschede, Netherlands | Registered: August 12, 2010Reply With QuoteReport This Post
Expert
posted Hide Post
Hi Wep5622,

Do you have any update on trial-and-error testing? A case may be of better help. Wink

Cheers,

Kerry


Kerry Zhan
Focal Point Moderator
Information Builders, Inc.
 
Posts: 1950 | Location: New York | Registered: November 16, 2004Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Graphing problem with double across for X-axis (Updated)

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.