Focal Point
[SOLVED] - Set Variables in 8.2.3

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/7971057331/m/4867071196

March 13, 2019, 02:02 PM
ColdWhiteMilk
[SOLVED] - Set Variables in 8.2.3
This code works in previous versions of WebFOCUS. In 8.2.3, which I'm testing now, when I run the report I get prompted to enter a value for &NOHEAD.

Any idea why this is happening and how to fix?

SET ASNAMES = ON

-SET &NOHEAD = 1; 

-LEAVEHEADON

-SET &HEAD1  ='"'|'My Header Information'|'"';

TABLE FILE TEAMS
PRINT
TEAMS.NUMBER

WHERE TEAMS.NUMBER EQ '1234567'

-IF &NOHEAD =1 GOTO NOFSTHEADING

-NOFSTHEADING

HEADING
&HEAD1.EVAL

ON TABLE PCHOLD FORMAT HTML
END

This message has been edited. Last edited by: FP Mod Chuck,


Production - 7.6.4
Sandbox - 7.6.4
March 13, 2019, 02:15 PM
MartinY
From WF8 much more code validation has been applied
Please try first to have this fix as below (change "=" by "EQ" and add semicolon ";" which should end every -IF command)

-IF &NOHEAD EQ 1 GOTO NOFSTHEADING;


Also add SET &ECHO=ON at the top of your fex to see exactly the executed code.

Finally, for me your code, the way you show us, don't really make sense.
Why having a -IF test condition that will branch to the line right after the -IF ?
That test is doing nothing

You should try to replicate the issue with a legacy file (CAR) and/or post your complete code if not already the case.


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
March 13, 2019, 02:28 PM
ColdWhiteMilk
The code is streamlined from a larger template that I use for reports that go to excel or text output.

The if statement is so that I can turn on/off the report header depending on what the output is going to be.

I don't get an error message. Running the code above prompts me for NOHEAD instead of taking the value from the -SET


Production - 7.6.4
Sandbox - 7.6.4
March 13, 2019, 02:45 PM
ColdWhiteMilk
I figured out the issue.

It wasn't a problem with the
-SET &NOHEAD = 1; 


8.2.3 does not seem to like the additional comment that I have after that:

-SET &NOHEAD = 1; -*Hide Header



Production - 7.6.4
Sandbox - 7.6.4
March 13, 2019, 03:28 PM
MartinY
quote:
Originally posted by ColdWhiteMilk:

8.2.3 does not seem to like the additional comment that I have after that:

-SET &NOHEAD = 1; -*Hide Header


Probably one of the code tightening applied since WF8 where a comment should start at column 1


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
March 13, 2019, 03:44 PM
Waz
These are some of the things we have seen migrating from 8.1 to 8.2

The biggest issue I see is this code.
-IF &NOHEAD =1 GOTO NOFSTHEADING

-NOFSTHEADING


As mentioned, has a equeal sign instead of EQ and has no semicolon to end the IF.

And yes we also found that comments not in column 1 or 2 cause issues.

We also found that a - on a line by its self causes issues.

There are many others.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

March 13, 2019, 03:52 PM
Doug
quote:
We also found that a - on a line by its self causes issues.

That was a tricky one to discover (back in the day)...