Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [Solved]Found an issue with WebFOCUS or Excel, not sure which.
Go
New
Search
Notify
Tools
Reply
  
[Solved]Found an issue with WebFOCUS or Excel, not sure which.
 Login/Join
 
Master
posted
I'm converting some old reports to XLSX format from EXL2K format. I have a field that is an age group field. Two of the values in the field of <2 and >=13. EXL2K handles these just fine. When I run the report with XLSX format, the report dies when Excel 2010 opens the sheet saying there is unreadable data. To be clear, WebFOCUS generates the report just fine, it is just when Excel tries to open the sheet that I get the error. I tracked it down to these values. I'm guessing the Excel 2010 is taking the strings <2 and >=13 as the start of a formula. To get around this I have to put an extra quote mark as follows:
original line

EVERAGE/A4=DECODE ADOPT_AGE(1 '>2' 2 '2-5' 3 '6-12' 4 '>=13' ELSE ' ');

new code

EVERAGE/A5=DECODE ADOPT_AGE(1 '''>2' 2 '2-5' 3 '6-12' 4 '''>=13' ELSE ' ');


Just curious if anyone else has come across this?

This message has been edited. Last edited by: jgelona,


In FOCUS since 1985. Prod WF 8.0.08 (z90/Suse Linux) DB (Oracle 11g), Self Serv, Report Caster, WebServer Intel/Linux.
 
Posts: 958 | Location: Oklahoma City | Registered: October 27, 2006Reply With QuoteReport This Post
Expert
posted Hide Post
I think you are right, and another way to handle this would be to change the < and > to & gt; and lt;


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6278 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Reply With QuoteReport This Post
Gold member
posted Hide Post
this is not a issue. i guess this is a feature in XLSX and not in EXL2k.

XLSX render the contents as XML which needs escape character for some special characters like the one you mentioned.


WebFOCUS 8
Windows, All Outputs
 
Posts: 68 | Registered: January 23, 2018Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Does it still die if you add ON TABLE SET HTMLENCODE ON to the TABLE-request?

Strictly speaking, that setting should probably be named XMLENCODE instead (and implied when using format XLSX), but the effect is the same.


WebFOCUS 8.1.03, Windows 7-64/2008-64, IBM DB2/400, Oracle 11g & RDB, MS SQL-Server 2005, SAP, PostgreSQL 11, Output: HTML, PDF, Excel 2010
: Member of User Group Benelux :
 
Posts: 1664 | Location: Enschede, Netherlands | Registered: August 12, 2010Reply With QuoteReport This Post
Master
posted Hide Post
Adding ON TABLE SET HTMLENCODE ON fixed the problem. Thanks


In FOCUS since 1985. Prod WF 8.0.08 (z90/Suse Linux) DB (Oracle 11g), Self Serv, Report Caster, WebServer Intel/Linux.
 
Posts: 958 | Location: Oklahoma City | Registered: October 27, 2006Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [Solved]Found an issue with WebFOCUS or Excel, not sure which.

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.