Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at myibi@ibi.com and provide your corporate email address, company, and name.


Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED]about ADVIZOR

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[CLOSED]about ADVIZOR
 Login/Join
 
Gold member
posted
i set the activex1 :style="Z-INDEX: 1"
image1 :style="Z-INDEX: 999;"

but the image not topside .

i think this is similar calendar .

i set the calendar image like this:

 

	var images=document.getElementsByTagName("img");

	var numImages = images.length;

	for (i=0;i<numImages;++i)
	{
		if (images[i].src.indexOf("dynCalendar.gif")>0){
		images[i].style.zIndex='1';

		}

	}


 


can anyone know the ADVIZOR image name (in html)?? or set the image1 over the activex1 ?

 

<img id=image1 style="Z-INDEX: 999;" .....>
<OBJECT id=activex1 style="Z-INDEX: 1; LEFT: 130px; WIDTH: 192px; POSITION: absolute; TOP: 340px; HEIGHT: 192px" tabIndex=7 height=192 width=192 classid=clsid:601CD7CF-2222-4444-871D-00A02411D404 name=activex1>
<PARAM NAME="_cx" VALUE="5080">
<PARAM NAME="_cy" VALUE="5080">
<PARAM NAME="Files" VALUE="">
<PARAM NAME="Data" VALUE="">
<PARAM NAME="Animate" VALUE="0">
<PARAM NAME="AnimateCommand" VALUE="0">
.............
...........

<PARAM NAME="PoolWeights" VALUE="-1"></OBJECT>
 



Thanks,
James Yang

This message has been edited. Last edited by: Yangyang,


WebFOCUS 7.6.8
WebFOCUS 7.6.10
BI
FLEX
.NET
 
Posts: 97 | Registered: August 18, 2009Report This Post
Expert
posted Hide Post
This may be related to activeX.

Can you wrap the activeX object in a DIV and set it to display=none, then if you need to show it, use javascript to change the setting display for the DIV.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Gold member
posted Hide Post
thanks Waz,

i didn't want make it display=none , i just want make image over the activeX object,

when i run it , it not work.


thanks,
James


WebFOCUS 7.6.8
WebFOCUS 7.6.10
BI
FLEX
.NET
 
Posts: 97 | Registered: August 18, 2009Report This Post
Expert
posted Hide Post
ActiveX can do weird things when layering objects on a web page.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Gold member
posted Hide Post
Thanks Waz,

yes , i think it's similar with calendar image.

i check the activeX in web page , it have not image in web page .....

when i use developer studio "edit in composer"

i can see the activeX object under the image,

but when i run the html , it over the image...


they are in different div.

div1 : image
div2 : activeX object .



Thanks,
James

This message has been edited. Last edited by: Yangyang,


WebFOCUS 7.6.8
WebFOCUS 7.6.10
BI
FLEX
.NET
 
Posts: 97 | Registered: August 18, 2009Report This Post
Expert
posted Hide Post
James,

I guess that you are using IE of some flavour? If so, it's a known problem which also affects some combo boxes being hidden behind iframes. I spent a long time a few years back trying to get this sort of thing to work OK and then I found a link on MSDN which explained it. Too long ago to know the link that I found though.

T



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.07 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
 
Posts: 5694 | Location: United Kingdom | Registered: April 08, 2004Report This Post
Gold member
posted Hide Post
quote:
MSDN


Thanks TonyA

i think this is no way to fix ...
i think display=none can fix it for the moment.


http://support.microsoft.com/d...cid=kb;EN-US;q177378

the image is Windowless Elements
the active is Windowed Elements

can anyone have idea ?


Thanks,
James

This message has been edited. Last edited by: Yangyang,


WebFOCUS 7.6.8
WebFOCUS 7.6.10
BI
FLEX
.NET
 
Posts: 97 | Registered: August 18, 2009Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED]about ADVIZOR

Copyright © 1996-2020 Information Builders