Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

Join the TIBCO Community
TIBCO Community is a collaborative space for users to share knowledge and support one another in making the best use of TIBCO products and services. There are several TIBCO WebFOCUS resources in the community.

  • From the Home page, select Predict: WebFOCUS to view articles, questions, and trending articles.
  • Select Products from the top navigation bar, scroll, and then select the TIBCO WebFOCUS product page to view product overview, articles, and discussions.
  • Request access to the private WebFOCUS User Group (login required) to network with fellow members.

Former myibi community members should have received an email on 8/3/22 to activate their user accounts to join the community. Check your Spam folder for the email. Please get in touch with us at community@tibco.com for further assistance. Reference the community FAQ to learn more about the community.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] WebFocus8 Image displaying issue

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[SOLVED] WebFocus8 Image displaying issue
 Login/Join
 
Gold member
posted
ALL,
I have a following code in WF 7.7.03, in this version images are displaying without any issues. When this code converted into WF8, the image is not displaying as like version 7. Do I need to update any path in this code?

  

-SET &ECHO = 'ALL';

-SET &XLS_IMG =  '''<img src="/approot/baseapp/excel.png" align="absmiddle" width="16" height="16" alt="Excel" border="0">''';



DEFINE FILE CAR
EXL_IMG/A200 = IF '&WFFMT' NE 'HTML' THEN ' ' ELSE &XLS_IMG;
END


TABLE FILE CAR
PRINT
     CAR.COMP.CAR
     CAR.CARREC.MODEL
     CAR.BODY.BODYTYPE
HEADING
"<EXL_IMG"
ON TABLE SET PAGE-NUM NOLEAD
ON TABLE NOTOTAL
ON TABLE PCHOLD FORMAT HTML
ON TABLE SET HTMLCSS ON
ON TABLE SET STYLE *
     INCLUDE = IBFS:/EDA/CM1LODV8/_EDAHOME/ETC/endeflt.sty,
$
ENDSTYLE
END



Thanks

This message has been edited. Last edited by: <Kathryn Henning>,


WebFocus 8202M
APP Studio
Info assist
Report caster
Portals
Maintain
EXcel,PDF,HTML,Active Reports
 
Posts: 82 | Location: MD | Registered: May 14, 2010Report This Post
<Kathryn Henning>
posted
Hi RaviD,

When including code in a post, you can use the last button on the icon ribbon to accomplish this.

Regards,

Kathryn
 
Report This Post
Gold member
posted Hide Post
OK. Thanks


WebFocus 8202M
APP Studio
Info assist
Report caster
Portals
Maintain
EXcel,PDF,HTML,Active Reports
 
Posts: 82 | Location: MD | Registered: May 14, 2010Report This Post
Expert
posted Hide Post
What gets generated ?
Is the link to the image broken ?
HAve you looked at the reports html output to see what has been generated where the image code should be ?


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Platinum Member
posted Hide Post
Hi,

Is your WebFOCUS server installed on the same server as your web server?

This may be obvious, but just to check:
The web server is going to try to find the image for you. So you need to see which physical directory "approot" points to on your web server. Then, in that directory there needs to be a baseapp directory, which needs to contain excel.png


WebFOCUS 8.2.06 mostly Windows Server
 
Posts: 195 | Location: Johannesburg, South Africa | Registered: September 13, 2008Report This Post
Gold member
posted Hide Post
It seems configuration issue with our web server. I will update here if I find any resolution


WebFocus 8202M
APP Studio
Info assist
Report caster
Portals
Maintain
EXcel,PDF,HTML,Active Reports
 
Posts: 82 | Location: MD | Registered: May 14, 2010Report This Post
Gold member
posted Hide Post
This Issue was resolved by Adding WebApps to Approot.


WebFocus 8202M
APP Studio
Info assist
Report caster
Portals
Maintain
EXcel,PDF,HTML,Active Reports
 
Posts: 82 | Location: MD | Registered: May 14, 2010Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] WebFocus8 Image displaying issue

Copyright © 1996-2020 Information Builders