Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at myibi@ibi.com and provide your corporate email address, company, and name.


Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     needed: subfoot with no text, just a colored bar

Read-Only Read-Only Topic
Go
Search
Notify
Tools
needed: subfoot with no text, just a colored bar
 Login/Join
 
Member
posted
I have successfully created a report with a blank row as a subfooter for a group of common records. The report has 2 distinct groups, and thus has 2 of these blank rows. I need these 2 blank rows to be a color other than white.

Here is what I have tried (only a small portion shown), and it does not work. What is wrong with my code, or is it possible that something else in the code is interfering? TRANSPORT_TYPE is the field used in the "BY" and the "ON ... SUBTOTAL" clauses.

ON TABLE SET STYLE *
TYPE=SUBFOOT, BY=TRANSPORT_TYPE, BACKCOLOR=RGB(100 100 100),$
ENDSTYLE

thanks

Richard Killey
WF Dev Studio 5.3.2

This message has been edited. Last edited by: MTO-Solutions-Engineering,
 
Posts: 23 | Location: Toronto, Ontario, Canada | Registered: January 09, 2007Report This Post
Platinum Member
posted Hide Post
Richard,

Not sure why you are having trouble. Code below works for me. Is this what you tried?

TABLE FILE CAR
PRINT MODEL
BY CAR
ON CAR SUBFOOT
" "
" "
ON TABLE SET STYLE *
TYPE=SUBFOOT, BY=CAR, BACKCOLOR=RGB(100 100 100),$
ENDSTYLE
END


dwf
 
Posts: 135 | Location: Portland, OR | Registered: March 23, 2005Report This Post
Expert
posted Hide Post
Richard,
you know there's a difference between SUBFOOT and SUBTOTAL, yes?
your code says ON ... SUBTOTAL
and your stylesheet says
TYPE=SUBFOOT,...
theu're not the same thing..you know that , right?
You see in Portland's code how he uses SUBFOOT for both?




In Focus since 1979///7706m/5 ;wintel 2008/64;OAM security; Oracle db, ///MRE/BID
 
Posts: 3811 | Location: Manhattan | Registered: October 28, 2003Report This Post
Member
posted Hide Post
Thank you DWF and Susannah. My code definitely has ON field SUBFOOT and then in the style section, TYPE=SUBFOOT.

I will play a bit more with it and if still not working will post a larger chunk of the code.

Richard


MTO
WebFOCUS Dev Studio 5.3.2 (trying to upgrade to 7.x !)
Unix with Win XP front ends
output usually PDF (and some HTML and XLS at times)
 
Posts: 23 | Location: Toronto, Ontario, Canada | Registered: January 09, 2007Report This Post
Member
posted Hide Post
I should have been more specific. I have both a SUBTOTAL and a SUBFOOT. The end user wants a shaded blank line after the group subtotal.

ON TRANSPORT_TYPE SUBTOTAL AS 'Sub Total'
ON TABLE SUBTOTAL AS 'Grand Total'
ON TRANSPORT_TYPE SUBFOOT
" "

This successfully puts the subtotal on one line and that is followed by a blank line, but the shading does not occur.

Richard


MTO
WebFOCUS Dev Studio 5.3.2 (trying to upgrade to 7.x !)
Unix with Win XP front ends
output usually PDF (and some HTML and XLS at times)
 
Posts: 23 | Location: Toronto, Ontario, Canada | Registered: January 09, 2007Report This Post
Member
posted Hide Post
ARRRGGGHHH

The report has a branch in it as it is meant to cover situations that need the extra footer and cases that do not need it. I inadvertently added an additional ENDSTYLE in the one branch. The error message I was getting, of course, sent me down the wrong rabbit hole and I had trouble coming back out.

The report now works fine, and I appreciate the two of you telling me that the code I had should work fine, which got me looking at other possible problems.

Richard


MTO
WebFOCUS Dev Studio 5.3.2 (trying to upgrade to 7.x !)
Unix with Win XP front ends
output usually PDF (and some HTML and XLS at times)
 
Posts: 23 | Location: Toronto, Ontario, Canada | Registered: January 09, 2007Report This Post
Expert
posted Hide Post
Richard,

This is where the new "Logical View" tab in Dev Studio editor becomes very useful Smiler.

T



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.07 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
 
Posts: 5694 | Location: United Kingdom | Registered: April 08, 2004Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     needed: subfoot with no text, just a colored bar

Copyright © 1996-2020 Information Builders