Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Internal exception processing IBFSService.runAdHocFex
Go
New
Search
Notify
Tools
Reply
  
[SOLVED] Internal exception processing IBFSService.runAdHocFex
 Login/Join
 
Platinum Member
posted
Hi All,

I have code similar to below. It runs fine in Development and Test but then gets the dreaded error ---

Internal exception processing IBFSService.runAdHocFex

--- when I moved it to Production

The problem is in the SET command for variable Z0_STR

FYI - I'm running on 8.201M

Here's the code ...

-SET &Z_LNS = 5;
-SET &Z_I01 = 'a';
-SET &Z_I02 = 'bb';
-SET &Z_I03 = 'ccc';
-SET &Z_I04 = 'dddd';
-SET &Z_I05 = 'eeeee';
-TYPE ---------------------------------------------------------
-TYPE Z_LNS --- &Z_LNS
-TYPE Z_I01 --- &Z_I01
-TYPE Z_I02 --- &Z_I02
-TYPE Z_I03 --- &Z_I03
-TYPE Z_I04 --- &Z_I04
-TYPE Z_I05 --- &Z_I05
-TYPE ---------------------------------------------------------
-**
-**** Loop thru all input lines
-**
-REPEAT :Z0_LOOP FOR &Z0_I FROM 1 TO &Z_LNS;
-SET &Z0_LNE = FPRINT(&Z0_I,'I2L','A2');
-SET &Z0_STR = TRUNCATE(&Z_I&Z0_LNE.EVAL);
-TYPE Z0_I --------- &Z0_I
-TYPE Z0_LNE ------- &Z0_LNE
-TYPE Z0_STR ------- &Z0_STR
-TYPE ---------------------------------------------------------
-:Z0_LOOP
-RUN


Does someone know why this &Z_I&Z0_LNE.EVAL works in one environment but not in another? Our environments should be the same, but maybe a setting is different.

Thanks

This message has been edited. Last edited by: FP Mod Chuck,


WebFocus 8.201M, Windows, App Studio
 
Posts: 221 | Location: Lincoln Nebraska | Registered: August 12, 2008Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Try the following. The "." is the way you are supposed to concatenate variables to achieve what you are trying to do. It doesn't make sense that it would work in one and then fail in another, but try it anyway.

quote:
-SET &Z_LNS = 5;
-SET &Z_I01 = 'a';
-SET &Z_I02 = 'bb';
-SET &Z_I03 = 'ccc';
-SET &Z_I04 = 'dddd';
-SET &Z_I05 = 'eeeee';
-TYPE ---------------------------------------------------------
-TYPE Z_LNS --- &Z_LNS
-TYPE Z_I01 --- &Z_I01
-TYPE Z_I02 --- &Z_I02
-TYPE Z_I03 --- &Z_I03
-TYPE Z_I04 --- &Z_I04
-TYPE Z_I05 --- &Z_I05
-TYPE ---------------------------------------------------------
-**
-**** Loop thru all input lines
-**
-REPEAT :Z0_LOOP FOR &Z0_I FROM 1 TO &Z_LNS;
-SET &Z0_LNE = FPRINT(&Z0_I,'I2L','A2');
-SET &Z0_STR = TRUNCATE(&Z_I.&Z0_LNE);
-TYPE Z0_I --------- &Z0_I
-TYPE Z0_LNE ------- &Z0_LNE
-TYPE Z0_STR ------- &Z0_STR
-TYPE ---------------------------------------------------------
-:Z0_LOOP
-RUN


"There is no limit to what you can achieve ... if you don’t care who gets the credit." Roger Abbott
 
Posts: 1100 | Location: Toronto, Ontario | Registered: May 26, 2004Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Thanks ... That did work!!!

But I'm still confused why it worked in one environment and not another.

We have a little difference in Parameter Prompting settings ...

In Dev and Test - Managed Reporting is 'Off'
In Prod - Managed Reporting is 'Always Prompt'

Hmmmm ...


WebFocus 8.201M, Windows, App Studio
 
Posts: 221 | Location: Lincoln Nebraska | Registered: August 12, 2008Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Internal exception processing IBFSService.runAdHocFex

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.