Focal Point
[CLOSED] Excell report output (Protected view)

This topic can be found at:

March 14, 2019, 08:19 AM
[CLOSED] Excell report output (Protected view)
we migrated to webfocus8.2.02 in excel report output getting warning message "Protected view" like below image

[IMG] [/IMG]

in the code i given as

how to avoid "Protected view" in excel when i open the report

Thank You.

This message has been edited. Last edited by: FP Mod Chuck,

WebFOCUS 8202
March 14, 2019, 09:56 AM
This is not related with WF.

It is a Windows, MS-Excel security feature. nothing that IB-WF can manage.
Talk with you network Admin if they agree to change that.

WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
March 15, 2019, 08:52 AM
Here are some suggestions:

In Excel, click on "File", then, near the bottom, click on "Options", "Trust Center", then "Trust Center Settings". Under trusted locations, click on "Allow Trusted Locations on my network", then add the reporting and client server(s). Make sure to click on "Subfolders of this location are also trusted". Close that and return to the Trust Center. Now click on "Protected View". In our environment everything is checked by default. I have unchecked, "Enable Protected View for Outlook Attachments".

All of our workstations are Windows 7. We make extensive use of formatting macros and when the Protected View or Macro warning popped up, clicking the Enable Content button would turn off the warning but the Auto-Open macro would not run. Users would have to know to go in and run the macro. We've been doing some testing in Windows 10 and Office 2016 and this issue seems to be resolved, so the Warnings, while annoying, don't seem to affect functionality.

In FOCUS since 1985. Prod WF 8.0.08 (z90/Suse Linux) DB (Oracle 11g), Self Serv, Report Caster, WebServer Intel/Linux.