Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at myibi@ibi.com and provide your corporate email address, company, and name.


Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] GRID=OFF adding unwanted blank spaces above report

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[SOLVED] GRID=OFF adding unwanted blank spaces above report
 Login/Join
 
Member
posted
How do I stop this happening? Heres my code:

TABLE FILE USAGE
FULL_USERNAME
EVENTS
ON TABLE HOLD AS NODERU04 FORMAT HTMTABLE
ON TABLE SET PAGE-NUM OFF
ON TABLE SET STYLE *
TYPE=REPORT,
GRID=OFF,
$
ENDSTYLE
END
-RUN

Which gives me this html with the unnecessary blank spaces:

<BODY>
<TABLE CELLPADDING=1>
<TR>
<TD NOWRAP COLSPAN=2>
 </TD>
</TR>
<TR>
<TD NOWRAP COLSPAN=2>
 </TD>
</TR>
<TR><TD NOWRAP COLSPAN=2>
<TABLE BORDER=0 CELLSPACING=0 CELLPADDING=0 WIDTH="100%">
<TR>......


Thanks.

This message has been edited. Last edited by: LEnderby,


WebFOCUS 7611
Windows XP Pro
 
Posts: 11 | Location: Nottingham, UK | Registered: February 27, 2009Report This Post
Expert
posted Hide Post
Try
ON TABLE SET PAGE-NUM NOLEAD


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Report This Post
Member
posted Hide Post
Hi Francis thanks but that hasnt worked I still have two empty table cells above my report. These disappear when I remove GRID=OFF but I want to remove the borders and I need the report at the top of the web page.


WebFOCUS 7611
Windows XP Pro
 
Posts: 11 | Location: Nottingham, UK | Registered: February 27, 2009Report This Post
Gold member
posted Hide Post
Hi LEnderby,

Here is my result with SET PAGE-NUM NOLEAD.
(it is pretty close to the top of the page.)

<TABLE CELLPADDING=1>
<TR>
<TD NOWRAP VALIGN=BOTTOM>
<U>COUNTRY</U></TD>
<TD NOWRAP ALIGN=RIGHT VALIGN=BOTTOM>
<U>SALES</U></TD>
</TR>
<TR>
<TD NOWRAP>
ENGLAND</TD>
<TD NOWRAP ALIGN=RIGHT>
12000</TD>
...snip.... (data removed to shorten)
</TABLE>


Here is the code I ran to get that result... 769.

TABLE FILE CAR
SUM SALES BY COUNTRY
ON TABLE HOLD AS NODERU04 FORMAT HTMTABLE
ON TABLE SET PAGE-NUM NOLEAD
ON TABLE SET STYLE * 
TYPE=REPORT,GRID=OFF,$
ENDSTYLE
END
-HTMLFORM BEGIN
!IBI.FIL.NODERU04;
-HTMLFORM END


Another choice is to create a DEFINED field,
that has your exact HTML that you want.
That is the long way to get your result, but you'll get exactly what you're asking for.

This message has been edited. Last edited by: Kerry,


WebFocus 7x, 8x, Win / Linux, any output format
 
Posts: 70 | Location: reading, pa | Registered: April 07, 2007Report This Post
Gold member
posted Hide Post
I see my post got mangled...
In any case... try the focexec code.
because it has different (and I think shorter)
results than yours.


WebFocus 7x, 8x, Win / Linux, any output format
 
Posts: 70 | Location: reading, pa | Registered: April 07, 2007Report This Post
Member
posted Hide Post
Thanks for your help its because I had SET LINES=99999 at the top. Take that out and it works.


WebFOCUS 7611
Windows XP Pro
 
Posts: 11 | Location: Nottingham, UK | Registered: February 27, 2009Report This Post
Platinum Member
posted Hide Post
So........What if you need both:

ON TABLE SET PAGE NOLEAD
ON TABLE SET LINES 999999

Why doesn't this work? Is this a bug? Is there a work-around?

Let me know if someone has been able to get both of these to work in the same report.

Thanks
Jim


WebFocus 8.201M, Windows, App Studio
 
Posts: 227 | Location: Lincoln Nebraska | Registered: August 12, 2008Report This Post
Expert
posted Hide Post
This is an ANNOYING "feature" of WebFOCUS. Anything higher than 998 causes the issue.

SET LINES=999 causing odd behavior

TABLE FILE CAR
SUM SALES BY COUNTRY
ON TABLE HOLD AS H001 FORMAT HTMTABLE
ON TABLE SET PAGE-NUM NOLEAD
ON TABLE SET LINES 998
ON TABLE SET STYLE * 
TYPE=REPORT,GRID=OFF,$
ENDSTYLE
END
-HTMLFORM BEGIN
<html>
<body style="margin: 0px;">
!IBI.FIL.H001;
</style>
</html>
-HTMLFORM END


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Report This Post
Platinum Member
posted Hide Post
Hi Francis,

Thanks for pointing this out.

This is annoying, but the work-around will take care of my issue for now.

Thanks Again,

Jim


WebFocus 8.201M, Windows, App Studio
 
Posts: 227 | Location: Lincoln Nebraska | Registered: August 12, 2008Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] GRID=OFF adding unwanted blank spaces above report

Copyright © 1996-2020 Information Builders