Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Go
New
Search
Notify
Tools
Reply
  
[CLOSED] Drilldown
 Login/Join
 
Gold member
posted
Hi all,
When i add the below code in my procedure and run i am getting the following error - "Unknown error occurred. Agent on reporting server EDASERVE may have crashed. Please investigate reporting server log."

$
TYPE=DATA,
COLUMN=&LAST,
TARGET='_blank',
FOCEXEC=first_drill_report1( \
FIRSTNAME='&FIRST' \
HIREDATE='&HIRE' \
JOBCLASS='&JOB' \
DEPT='&DEPT' \
DIV='&DIV' \
),
$

TYPE=DATA,
COLUMN=&FIRST,
TARGET='_blank',
DRILLMENUITEM='FIRSTNAME',
FOCEXEC=hire_drill_report1( \
HIREDATE='&HIRE' \
JOBCLASS='&JOB' \
DEPT='&DEPT' \
DIV='&DIV' \
),
DRILLMENUITEM='LASTNAME',
FOCEXEC=first_drill_report1( \
FIRSTNAME='&FIRST' \
HIREDATE='&HIRE' \
JOBCLASS='&JOB' \
DEPT='&DEPT' \
DIV='&DIV' \
),

$

TYPE=DATA,
COLUMN=&JOB,
TARGET='_blank',
DRILLMENUITEM='HIREDATE',
FOCEXEC=job_drill_report1( \
JOBCLASS='&JOB' \
DEPT='&DEPT' \
DIV='&DIV' \
),
DRILLMENUITEM='FIRSTNAME',
FOCEXEC=hire_drill_report1( \
HIREDATE='&HIRE' \
JOBCLASS='&JOB' \
DEPT='&DEPT' \
DIV='&DIV' \
),
DRILLMENUITEM='LASTNAME',
FOCEXEC=first_drill_report1( \
FIRSTNAME='&FIRST' \
HIREDATE='&HIRE' \
JOBCLASS='&JOB' \
DEPT='&DEPT' \
DIV='&DIV' \
),

$

TYPE=DATA,
COLUMN=&DEPT,
TARGET='_blank',
DRILLMENUITEM='JOBCLASS',
FOCEXEC=dept_drill_report1( \
DEPT='&DEPT' \
DIV='&DIV' \
),
DRILLMENUITEM='HIREDATE',
FOCEXEC=job_drill_report1( \
JOBCLASS='&JOB' \
DEPT='&DEPT' \
DIV='&DIV' \
),
DRILLMENUITEM='FIRSTNAME',
FOCEXEC=hire_drill_report1( \
HIREDATE='&HIRE' \
JOBCLASS='&JOB' \
DEPT='&DEPT' \
DIV='&DIV' \
),
DRILLMENUITEM='LASTNAME',
FOCEXEC=first_drill_report1( \
FIRSTNAME='&FIRST' \
HIREDATE='&HIRE' \
JOBCLASS='&JOB' \
DEPT='&DEPT' \
DIV='&DIV' \
),

$

TYPE=DATA,
COLUMN=&DIV,
TARGET='_blank',
DRILLMENUITEM='DEPT',
FOCEXEC=div_drill_report1( \
DIV='&DIV' \
),
DRILLMENUITEM='JOBCLASS',
FOCEXEC=dept_drill_report1( \
DEPT='&DEPT' \
DIV='&DIV' \
),
DRILLMENUITEM='HIREDATE',
FOCEXEC=job_drill_report1( \
JOBCLASS='&JOB' \
DEPT='&DEPT' \
DIV='&DIV' \
),
DRILLMENUITEM='FIRSTNAME',
FOCEXEC=hire_drill_report1( \
HIREDATE='&HIRE' \
JOBCLASS='&JOB' \
DEPT='&DEPT' \
DIV='&DIV' \
),
DRILLMENUITEM='LASTNAME',
FOCEXEC=first_drill_report1( \
FIRSTNAME='&FIRST' \
HIREDATE='&HIRE' \
JOBCLASS='&JOB' \
DEPT='&DEPT' \
DIV='&DIV' \
),

$

Please help me to run the report with out a error

Thanks in advance

This message has been edited. Last edited by: Kerry,
 
Posts: 52 | Registered: September 30, 2008Reply With QuoteReport This Post
Virtuoso
posted Hide Post
First you should try taking out all but one section at a time and running it to see if you can narrow it down.
 
Posts: 1903 | Location: San Antonio | Registered: February 28, 2005Reply With QuoteReport This Post
Virtuoso
posted Hide Post
quote:
COLUMN=&LAST,

I think your problem may have to do with these constructions. Are you quite sure that these &variables indeed do point to a physical column at run time? And do not contain the selected value for that column?


GamP

- Using AS 8.2.01 on Windows 7 - IE11.
in Focus since 1988
 
Posts: 1960 | Location: Netherlands | Registered: September 25, 2007Reply With QuoteReport This Post
  Powered by Social Strata  
 


Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.