Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

Join the TIBCO Community
TIBCO Community is a collaborative space for users to share knowledge and support one another in making the best use of TIBCO products and services. There are several TIBCO WebFOCUS resources in the community.

  • From the Home page, select Predict: WebFOCUS to view articles, questions, and trending articles.
  • Select Products from the top navigation bar, scroll, and then select the TIBCO WebFOCUS product page to view product overview, articles, and discussions.
  • Request access to the private WebFOCUS User Group (login required) to network with fellow members.

Former myibi community members should have received an email on 8/3/22 to activate their user accounts to join the community. Check your Spam folder for the email. Please get in touch with us at community@tibco.com for further assistance. Reference the community FAQ to learn more about the community.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED]WebFOCUS HTML Page in IE11

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[CLOSED]WebFOCUS HTML Page in IE11
 Login/Join
 
Gold member
posted
We are having HTML Launch page with various control like dropdownlist box, text box, report frame which is running on webfocus 7.6.11 version.

we are trying to call this launch page from the parent application (not in webfocus) within iframe.

everything is working fine in Chrome, Firefox.

Only in Internet explore its having error even in IE its working fine with IE5 engine.

I am trying to override the frame engine using
<meta http-equiv="X-UA-Compatible" content="IE=5" />

but its not accepting

I cannot change the parent page as it need to run on edge mode.

error i am getting is
Object doesn't support property or method 'evaluate'
in ibirls3.js


Any suggestion will be highly appreciated

This message has been edited. Last edited by: krish,
 
Posts: 64 | Location: North Carolina | Registered: December 04, 2007Report This Post
Expert
posted Hide Post
You will need to find out which object the evaluate method is expected to be on.

My guess is that the object is null.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Gold member
posted Hide Post
Thanks for the response, problem is IE 11 will not support evaluate method. we need some fix particular to IE like below but I am trying to avoid change in ibirls.js as its part of product.
if(window.DOMParser)
            {
                result =
                    root
                        .evaluate(
                            expression,
                            node,
                            null, 
                            XPathResult.ANY_TYPE,
                            null);
            }
            else // Internet Explorer
            {
                result = node.selectNodes(expression);
            }
			

Thanks
Krishnan
 
Posts: 64 | Location: North Carolina | Registered: December 04, 2007Report This Post
Expert
posted Hide Post
I think you need to work out what object the evaluate is being called on, this will give you an idea where the issue is being caused.

The only other suggestion I have would be to contact Tech Support


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Gold member
posted Hide Post
I am already working with tech support, I thought if someone faced the similar issue and resolved the same it would save some time.

code which is having problem is which is from ibirls3.js

if(isIEvar)
	{
	   node = xmlNode.selectSingleNode(nodeName);
	}
	else
	{
	    var owner = xmlNode.nodeType == 9 ? xmlNode : xmlNode.ownerDocument;
        var xpathResult = owner.evaluate(nodeName, xmlNode, null, 0, null);
        node = xpathResult.iterateNext();
   }
 
Posts: 64 | Location: North Carolina | Registered: December 04, 2007Report This Post
Expert
posted Hide Post
Well, hopefully someone else on the forum has experienced this.

Usually when this sort of thing happens, there is something that has broken or no populated as expected and the IBI JS files can't handle it.

Thats why I was suggesting tracking the issue back to the source.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Gold member
posted Hide Post
Thanks Waz, IBI tech is saying as long as we are getting the report in the browser with no errors they are good.

Confused

now I am little bit worried, as I am able to reproduce the issue with IE11 edge mode.
I am checking back with them.

I think it's something to do with forcing the iframe to use different engine(IE 5) or make the report page work in edge mode in IE will the solution.
 
Posts: 64 | Location: North Carolina | Registered: December 04, 2007Report This Post
Expert
posted Hide Post
Edge is a new IE and I don't think that IB have certified WF with it yet.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Platinum Member
posted Hide Post
We are considering rolling out IE11 during our upgrade from 7705 to 8103. IE11 is not playing nicely with 7705 even with enterprise mode enabled. So far we have found that InfoAssist Define and Compute windows will not allow selection of field names by double click or drag and drop. They would have to be typed in and this will be a pain to the non-coders. There were a few other minor things that I don't have in hand right now. So we will probably have to hold IE11 until post-golive.


WebFOCUS 7.7.05 (Someday 8)
Windows 7, All Outputs
In Focus since 1983.
 
Posts: 103 | Registered: April 27, 2011Report This Post
Expert
posted Hide Post
I don't think that IE11 is certified for use with WF7.7.05.

T



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.07 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
 
Posts: 5694 | Location: United Kingdom | Registered: April 08, 2004Report This Post
Platinum Member
posted Hide Post
is this evaluate() method an IBI API or javascript method? The correct javascript method should be eval().


7.66 and 7.704
System: Windows / AIX / Linux
Output: Mostly HTML, with some PDF, Excel and Lotus(!)
 
Posts: 147 | Location: Toronto (GTA) | Registered: May 25, 2005Report This Post
Gold member
posted Hide Post
I think Evaluate() is an java script, which will work in other browser(Chorme, Firefox) except IE
 
Posts: 64 | Location: North Carolina | Registered: December 04, 2007Report This Post
Master
posted Hide Post
We have all kinds of IE issues and it's not because of IE11, it's because IBI forces specific versions with the "X-UA-Compatible" meta tag, that can't be overwritten. Their code doesn't support higher versions of IE which is why it's there. We have a ticket open and have had them fix an IE issue, which came out in 8.1.05, that was forcing IE 10 when using portals, yet, we are still having issues, because their fix is very flaky. There is no override for their meta tag and if you go into IE, hit F12, go into the Emulation tab, then select document mode to a higher version, you will most likely, see it works. Personally, I use Chrome as well does 60% of the world. IE holds 6% so I tend to say, "move to Chrome".



- FOCUS Man, just FOCUS!
-----------------------------
Product: WebFOCUS
Version: 8.1.04
Server: Windows 2008 Server
 
Posts: 578 | Registered: October 01, 2014Report This Post
Virtuoso
posted Hide Post
Since I've began developing portals and content in 8.1.xx, I've been developing everything so that it works well in Chrome first and foremost. Why? Because IE is on its deathbed and nothing developed tends to run smoothly or look decent in IE. Firefox offsets my custom HTML widgets I create so they aren't centered in panels, but other than that things work a lot better than in IE. In Chrome, everything works, and does so quickly. Thus, for now, anything created with IBI products is being developed for Chrome since IBI doesn't want to get with the times and make things browser agnostic. I wish content we create with IBI products worked without issue and workarounds in all 4 major browsers. But that is I guess asking too much of them.


8.2.02M (production), 8.2.02M (test), Windows 10, all outputs.
 
Posts: 1113 | Location: USA | Registered: January 27, 2015Report This Post
Gold member
posted Hide Post
Issue got resolved by enabling the Enterprise mode in IE.

Thanks all for your input.
 
Posts: 64 | Location: North Carolina | Registered: December 04, 2007Report This Post
Expert
posted Hide Post
I have the same problem - I get the JS error "Object doesn't support property or method 'evaluate'" when running a page created in Dev Studio 7.7.03 or 7.7.05 - we are WF 8.0.08 and IE11. I can resolve the issue by opening and saving the page in Dev Studio 8.0.08. We're forbidden to look at code but a bunch of stuff gets updated in the html meta tags and I cannot trace which exact line will resolve the issue.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Report This Post
Master
posted Hide Post
quote:
We're forbidden to look at code


First option:
After you build your HTML page in AS, open in external editor, copy the code, paste it into a FEX and wrap -HTMLFORM BEGIN/END around it. Works exactly the same, but you are able to view and edit the code any time you like.

Second option:
I've also found, I can rename the file through properties to TXT. Then in AS just say OPEN file, it notices that it's really a TXT and lets you edit the text. Even though the tree doesn't refresh, showing it's a TXT. Just remember to rename it back.



- FOCUS Man, just FOCUS!
-----------------------------
Product: WebFOCUS
Version: 8.1.04
Server: Windows 2008 Server
 
Posts: 578 | Registered: October 01, 2014Report This Post
Expert
posted Hide Post
You're lucky to be on 8.1.04, where apparently the first really usable version of App Studio exists. We're on 8.0.08 where Dev Studio is the only reliable tool. App Studio I won't touch.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Report This Post
Master
posted Hide Post
I started using AS just this week. Mainly, because at some point, I'm not going to have a choice. However, it is said by IBI, who was here in our office this week, that DS will be supported until AS has everything DS has. I know that isn't true, but I responded with, so DS will always be supported, since David refuses to put, "Open in Text Editor" for HTML files, which DS does today. A few of the IBI reps looked at each other and said, "good point". Though I have a work around, I'm sure they will work hard on closing up that gap.

Personally, I don't use the HTML Composer for either DS or AS. I end up building my own HTML5 pages and pulling reports or graphs I build using InfoAssist into them. DS and AS both write code specific to browsers and pull in so much crap that isn't needed, it's a nightmare to fix when something goes wrong between WF versions. Which is why I hate the aspect of not being able to edit my own HTML files in AS.

David is so focused on thinking everyone using WF also uses their HTML Composer, without the possibility of a developer actually doing what I'm doing, he hasn't noticed people that do web development are not only Business Analysis. Which personally, I think he is, which is why he doesn't understand our needs.



- FOCUS Man, just FOCUS!
-----------------------------
Product: WebFOCUS
Version: 8.1.04
Server: Windows 2008 Server
 
Posts: 578 | Registered: October 01, 2014Report This Post
Gold member
posted Hide Post
Hi Francis,
Glad that you also got this same issue Smiler . Is any one have feasible solution so that 7.6.11 HTML page will work on IE 11 EDGE mode.

without enabling Enterprise mode.


7.1.1
Windows XP
HTML
 
Posts: 64 | Location: North Carolina | Registered: December 04, 2007Report This Post
Expert
posted Hide Post
If the web page is referenced in a B.I. Portal page, setting the X-UA-Compatible meta header to edge or 9 doesn't make any difference, because BIP sets it to 10.

<!DOCTYPE html>

<html>
	<head>
	    <title>BI Portal</title>
		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
		<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE10" >		
		<meta http-equiv="MsThemeCompatible" content="yes">
		<meta http-equiv="ImageToolBar" content="no">
		<link type="text/css" rel="StyleSheet" href="/ibi_apps/bindows/css/bimain.css">
		<script type="text/javascript" src="/ibi_apps/bindows/js/application.js"></script>
	</head>
	<body>
		<script type="text/javascript">application.start("/ibi_apps/bindows", "/ibi_apps/tools/portal/resources/markup/wfbiportalrun.jsp?&ViewID=VR-IGV5ZELR1XVE1Z32J526&ViewName=ie11_test&ViewTitle=ie11_test&SessionTimeout=7200000")</script>
	</body>
</html>


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Report This Post
Master
posted Hide Post
I found an interesting fact today. You would think IBI would use metatag to force compatibility because of code limitations they might have. Open the same portal up that says it emulates IE10, in Chrome or firefox. It says it emulates IE8.

Some smart developer over in IBI, is setting the IE Compatible mode differently, based on the browser that is accessing it. Guess they didn't realize that that setting is for IE only and everyone else ignores it.




- FOCUS Man, just FOCUS!
-----------------------------
Product: WebFOCUS
Version: 8.1.04
Server: Windows 2008 Server
 
Posts: 578 | Registered: October 01, 2014Report This Post
Expert
posted Hide Post
Ha ha



Welcome
To
Focus

Welcome
To
Focalpoint


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Master
posted Hide Post
haha.. Nice..

I was going to respond with "Wait To ****", if someone asked.. :P


Edit: really, they * out F-A-R-T



- FOCUS Man, just FOCUS!
-----------------------------
Product: WebFOCUS
Version: 8.1.04
Server: Windows 2008 Server
 
Posts: 578 | Registered: October 01, 2014Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED]WebFOCUS HTML Page in IE11

Copyright © 1996-2020 Information Builders