Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at myibi@ibi.com and provide your corporate email address, company, and name.


Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Report caster HTML output error-Task Error: incoming signal rt (sig eot f (OPFSIGNAL)

Read-Only Read-Only Topic
Go
Search
Notify
Tools
Report caster HTML output error-Task Error: incoming signal rt (sig eot f (OPFSIGNAL)
 Login/Join
 
Gold member
posted
All,
I am having reports(tables) which are displayed either in HTML or EXCEL. I am using report caster to run the report. I am passing HTMTABLE or EXL2K as the variable to report from the report caster.When i pass EXL2K as variable report is created properly. Incase of HTMTABLE i am getting
Task Error: incoming signal rt (sig eot f (OPFSIGNAL) CL) not allowed in protocol state 3:-1:0
Dont know what this error all about.
Using following DM commands i am setting the report out type in the report.In this FORMATNAME is the variable set @ report caster.

-IF &FORMATNAME EQ 'HTMTABLE' THEN GOTO 'HTMLREPORT' ELSE
-GOTO 'EXCELREPORT';
-HTMLREPORT
-SET &REPORTTYPE='ON TABLE HOLD AS HMO FORMAT HTMTABLE';
-SET &REPORTTYPE1='ON TABLE HOLD AS PPO FORMAT HTMTABLE';
-SET &REPORTTYPE2='ON TABLE HOLD AS TOTALS FORMAT HTMTABLE';
-GOTO END_FORMAT
-EXCELREPORT
-SET &REPORTTYPE='ON TABLE PCHOLD FORMAT EXL2K OPEN NOBREAK';
-SET &REPORTTYPE1='ON TABLE PCHOLD FORMAT EXL2K NOBREAK';
-SET &REPORTTYPE2='ON TABLE PCHOLD FORMAT EXL2K CLOSE';
-END_FORMAT

In the table level i will be using &REPORTTYPE,&REPORTTYPE1,&REPORTTYPE2 to get the appropriate output type.

At the end i use HTMLFORM to display the output.

Any idea why this different error comes for HTML alone. Is it OS related??

Regards


Dev:
Dev Studio 7.1.6,Report Caster 7.1.1,Servlet
Local:
Dev Studio 7.1.6,Report Caster 7.1.1,Apache 5.0.2,
Win XP


 
Posts: 80 | Registered: March 21, 2007Report This Post
Virtuoso
posted Hide Post
quote:
At the end i use HTMLFORM to display the output.

Any idea why this different error comes for HTML alone. Is it OS related??


From what I know of Report Caster, what you are trying to do is a can't get here from there. Report Caster is its own way of doing things. Of course I may be wrong.


Leah
 
Posts: 1317 | Location: Council Bluffs, IA | Registered: May 24, 2004Report This Post
Virtuoso
posted Hide Post
In Report Caster you have to specify the output type of the report, and that is used regardless of what format type is set in the code of the fex. As Leah says, Caster does things it's own way. Our way around is having two separate jobs in RC - one for HTML and one for EXL2K.


Regards,

Darin



In FOCUS since 1991
WF Server: 7.7.04 on Linux and Z/OS, ReportCaster, Self-Service, MRE, Java, Flex
Data: DB2/UDB, Adabas, SQL Server Output: HTML,PDF,EXL2K/07, PS, AHTML, Flex
WF Client: 77 on Linux w/Tomcat
 
Posts: 2298 | Location: Salt Lake City, Utah | Registered: February 02, 2007Report This Post
Gold member
posted Hide Post
Lee,
I created 2 files in RC. Still i am getting the same error. In the log it show 0 HTML files saved, then it shows the task error as i gave earlier. I am distributing it to Library. I feel the error is with distribution not on the file generation. Any suggestion on this?

Regards


Dev:
Dev Studio 7.1.6,Report Caster 7.1.1,Servlet
Local:
Dev Studio 7.1.6,Report Caster 7.1.1,Apache 5.0.2,
Win XP


 
Posts: 80 | Registered: March 21, 2007Report This Post
Virtuoso
posted Hide Post
Out of curiosity, did you leave in all of the DM commands or take them out prior to setting up two caster jobs?


Leah
 
Posts: 1317 | Location: Council Bluffs, IA | Registered: May 24, 2004Report This Post
Gold member
posted Hide Post
Leah,
I removed the DM statements.Now i also removed the arguments, instead in the report itself i set 'ON TABLE HOLD AS AAA FORMAT HTMTABLE'.I have 6 tables.
Following is the log message for running a RC for HTML.
Starting worker thread
 Starting task: wftest
 Task type: EDA RPC
 Procedure name: data/wf107_
 Connecting to server EDASERVE with execution    id tks123
Executing focexec.
0 HTML FILE SAVED ...
0 HTML FILE SAVED ...
0 HTML FILE SAVED ...
0 HTML FILE SAVED ...
0 HTML FILE SAVED ...
0 HTML FILE SAVED ...
Task error:incoming signal rt(sig eot f(OPFSIGNAL) CL ) not allowed in protocol state 3:-1:0
No report to distribute."


Following is the log message for Excel report in RC.
Starting worker thread
Starting task: wf107
Task type: EDA RPC
Procedure name: data/wfbob107_15052007
Connecting to server EDASERVE with execution id v99co01
Executing focexec.
Task finished.
DISTRIBUTED TO report library


Any idea what can be the error message? any links to know what are the DO NOT DO for RC?

Regards


Dev:
Dev Studio 7.1.6,Report Caster 7.1.1,Servlet
Local:
Dev Studio 7.1.6,Report Caster 7.1.1,Apache 5.0.2,
Win XP


 
Posts: 80 | Registered: March 21, 2007Report This Post
Virtuoso
posted Hide Post
I know the documentation is not very clear on this subject, but I do know that you will not get any output with the ON TABLE HOLD FORMAT HTMTABLE. This saves the report output to disk, sending nothing back to Caster for distribution. I also do not think that you can produce six different tables (reports) and have them distributed via Caster UNLESS they are in some format that supports compound documents such as PDF or Excel. RC will only distribute the last report produced.
As always, someone may come up with a workaround technique, but standard functionality won't get you there for multiple HTML reports. You'll either have to have 6 different jobs (you can probably chain them together) or output them in a compound document.

I know that doesn't address your specific error message, but I think there's a bigger issue before you even get to the error message.


Regards,

Darin



In FOCUS since 1991
WF Server: 7.7.04 on Linux and Z/OS, ReportCaster, Self-Service, MRE, Java, Flex
Data: DB2/UDB, Adabas, SQL Server Output: HTML,PDF,EXL2K/07, PS, AHTML, Flex
WF Client: 77 on Linux w/Tomcat
 
Posts: 2298 | Location: Salt Lake City, Utah | Registered: February 02, 2007Report This Post
Gold member
posted Hide Post
Lee,
The issue is solved. Now i am able to execute the reports through report caster. The problem was in the temporary file names.I feel the total length of temporary files for holding in HTMTABLE format is 6.Also i removed from the .

Regards


Dev:
Dev Studio 7.1.6,Report Caster 7.1.1,Servlet
Local:
Dev Studio 7.1.6,Report Caster 7.1.1,Apache 5.0.2,
Win XP


 
Posts: 80 | Registered: March 21, 2007Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Report caster HTML output error-Task Error: incoming signal rt (sig eot f (OPFSIGNAL)

Copyright © 1996-2020 Information Builders