Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at myibi@ibi.com and provide your corporate email address, company, and name.


Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     (SOLVED) Issues with metadata on 8203

Read-Only Read-Only Topic
Go
Search
Notify
Tools
(SOLVED) Issues with metadata on 8203
 Login/Join
 
Gold member
posted
Has anyone had any issues with the behavior of their metadata when upgrading from 8201 to 8203?
From what I can tell, everything now defaults to a business view, which creates its own hierarchies and somewhat reeks havoc on the layout of the metadata within App Studio.

At first, when I was creating reports off of an active synonym, the only dimensions that would show up were those that had hierarchies built into them, and it wouldn't show any measures. I then went into each active synonym and had to "reset defaults" in the business view of the active synonym to get all measures to show and all dimensions to show.

Now that I have done that, I sometimes get two separate dimensions listed out under the business view and each set of that same dimension has different fields in it.

It's quite bizarre and I have not had any luck with tech support from loading a ticket about a week ago.

I have tried some setting changes in the reporting server console/workspace/focus sets and info/settings for web console preferences, specifically the NTM_SUPPORT_BV_PLUS_FOR_CUBE set to NO, but that didn't help anything.

Does anyone else have any suggestions?

Thank you!!
-Larissa

This message has been edited. Last edited by: LarissaB,


Version: 8.2.03M, OS/Platform: Windows 7 & 10, Output: Excel, pdf, html
 
Posts: 63 | Location: Liberty Lake, WA - USA | Registered: June 23, 2016Report This Post
Virtuoso
posted Hide Post
Larissa

Sadly no one has any help for you.. Did techsupport get this resolved for you? If not what is your case number?


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
 
Posts: 2128 | Location: Customer Support | Registered: April 12, 2005Report This Post
Member
posted Hide Post
LarissaB: I have the exact same issue. I opened a case with IBI and Jessica Chen assisted me. The solution is not pretty. Apparently there is no magic switch to make the metadata .mas ojbects appear in 8.2.3 as they did in 8.1.05m. I see it happened to you in moving from 8.2 to 8.3. So whatever they did it just happened. IMO. ANYWAY.....What I had to do, per Jessica Chen is this. 1. open the .mas, click no Business view, click on reset, click ok, save the .mas I then open a report and the field list is as it was in 8.1.05m.

My case for this is: 180709128

I hope this helps!


8.2.3 PROD/DEV 826 TEST
AIX, DB2 All Outputs
 
Posts: 14 | Registered: July 06, 2016Report This Post
Gold member
posted Hide Post
Bently, this is awesome advice and I don't even mind resetting all our master files as this is the most help I've heard of. The only issue I have is that I do not see a way to select no Business View.

I have tried the option of "Reset Default" on the business view tool, but what you're referencing is exactly what I want. To turn the business view off all together!

If you have any guided direction to get to that setting "no business view" that would be great. I'll also see if I can take a peek at your case you referenced.

Thanks again!


Version: 8.2.03M, OS/Platform: Windows 7 & 10, Output: Excel, pdf, html
 
Posts: 63 | Location: Liberty Lake, WA - USA | Registered: June 23, 2016Report This Post
Member
posted Hide Post
Larissa, I made a typing error
IT should be click ON the business view, click reset

Sorry!

I am reaching out to IBI on this and referring to my ticket asking them to resolve this bizarre behavior. This (in my organization's view) is unacceptable to just change the presentation of the field list in the object inspector, which I assume is where you are seeing this issue. I can not believe only two customers are the only ones who see this issue. We have autonomy over our data so we probably will never use business views/dimensions since our users will most likely never use IA or the other fun tools for end users in WebFOCUS.
The other bizarre thing that I can point out to you is that not all my clusters where this is happening were affected!! Very bizarre.


8.2.3 PROD/DEV 826 TEST
AIX, DB2 All Outputs
 
Posts: 14 | Registered: July 06, 2016Report This Post
Virtuoso
posted Hide Post
If all you want is to get rid of the BV's, on the same set of icons as Reset Default, the right most is Hide All. If you click that, you'll basically get rid of all the BV stuff and end up with a Master file that only has the fields as they appear in the DBMS without any folders, measures or dimensions.


WebFOCUS 8206, Unix, Windows
 
Posts: 1853 | Location: New York City | Registered: December 30, 2015Report This Post
Platinum Member
posted Hide Post
This is an example of what happens if you have a DATE field in a SQL table and you create a new synonym.

The original field:
FIELDNAME=ACCOUNTING_DT, ALIAS=ACCOUNTING_DT, USAGE=YYMD, ACTUAL=DATE, MISSING=ON, $


Turns into:
FIELDNAME=ACCOUNTING_DT, ALIAS=ACCOUNTING_DT, USAGE=YYMD, ACTUAL=DATE, MISSING=ON, $
    DEFINE ACCOUNTING_DT_YEAR/I4 MISSING ON ALL=DTPART(ACCOUNTING_DT, YEAR);
      TITLE='ACCOUNTING_DT,Year', $
    DEFINE ACCOUNTING_DT_QUARTER/I1 MISSING ON ALL=DTPART(ACCOUNTING_DT, QUARTER);
      TITLE='ACCOUNTING_DT,Quarter', $
    DEFINE ACCOUNTING_DT_MONTH/I2 MISSING ON ALL=DTPART(ACCOUNTING_DT, MONTH);
      TITLE='ACCOUNTING_DT,Month', $
    DEFINE ACCOUNTING_DT_DAY/I2 MISSING ON ALL=DTPART(ACCOUNTING_DT, DAY);
      TITLE='ACCOUNTING_DT,Day', $
    DEFINE ACCOUNTING_DT_YEAR_Y/YYMDy MISSING ON ALL=DTRUNC(ACCOUNTING_DT, YEAR);
      TITLE='ACCOUNTING_DT,Y', $
    DEFINE ACCOUNTING_DT_YEAR_Q/YYMDq MISSING ON ALL=DTRUNC(ACCOUNTING_DT, QUARTER);
      TITLE='ACCOUNTING_DT,Y-Q', $
    DEFINE ACCOUNTING_DT_YEAR_M/YYMDm MISSING ON ALL=DTRUNC(ACCOUNTING_DT, MONTH);
      TITLE='ACCOUNTING_DT,Y-M', $
    DEFINE ACCOUNTING_DT_YEAR_D/YYMD MISSING ON ALL=DTRUNC(ACCOUNTING_DT, DAY);
      TITLE='ACCOUNTING_DT,Y-M-D', $


You can imagine the clutter if your table has multiple date fields.

All of these show up on the user's field selection list.


WebFOCUS 8.2.03 - Production
WebFOCUS 8.2.04 - Sand Box
Windows 2012 R2 Server
HTML, PDF, Excel
In FOCUS since 1980
 
Posts: 115 | Location: Seattle, WA | Registered: April 07, 2015Report This Post
Virtuoso
posted Hide Post
If you go to the Reporting Server console under Adapters, there's a CHANGE COMMON ADAPTER SETTINGS button. the first drop down is DECOMPOSE DATE. If you don't wish to see the year quarter month separated in the master file, you can change that to OFF. Take a look at other default settings on that same screen to adjust back to the earlier release settings.


WebFOCUS 8206, Unix, Windows
 
Posts: 1853 | Location: New York City | Registered: December 30, 2015Report This Post
Gold member
posted Hide Post
Thank you to everyone on your help!

Bentley - I added the notes from your case number over to my case number as well and give IBI some more backup documentation. Are environments are very similar and currently the BV+ view is more of a deterrent than a help. Even the reset default button wouldn't work for changing our view though, it still held onto the BV+ grouping.

BabakNYC - I didn't realize that "Hide All" would take those BV's out. I had actually gone into the code of my active synonyms and removed all the lines from the text of the beginning with the first FOLDER= line of code:
FOLDER=MG_CREDIT_CARD_MONTHLY_ACCT, PARENT=.,
DV_ROLE=MEASURE,
DESCRIPTION='Measure Groups', $
This seemed to do the exact same thing as the "Hide All" and gave us back our view as we had in 8201M

Michael and BabakNYC - I had also turned the DECOMPOSE DATE option off in 8201M, so I did know to look for that setting on this 8203 release. That adaptor setting did throw me for a loop on our last upgrade to 8201M though!

Thanks again for all the input you guys, I appreciate it!


Version: 8.2.03M, OS/Platform: Windows 7 & 10, Output: Excel, pdf, html
 
Posts: 63 | Location: Liberty Lake, WA - USA | Registered: June 23, 2016Report This Post
Member
posted Hide Post
We the customer should NOT have to do ANYTHING to our .,as objects when we do a migration. This is a complete FAILURE on IBI's part. I don't care about "settings", EVERYTHING should remain AS IT WAS UNLESS there is a MAJOR modification and then the IBI tech folks should (and may for all I know) make it abundantly clear about the MAJOR change. I am VERY disappointed. I have works with over 20 software vendors in my 35 years of IT and IBI is the worst. I was once a Partner in a software firm, this level of issue would get folks terminated IF NOT COMMUNICATED to the customers.


BabakNYC, THANKS!!

LarissaB, I have done the same as you did with removing the stuff. I actually tried the hide thing but never went any further.

The whole decompose date thing is slick. BUT only if you enable Business views, I think.

to bad we cant have BOTH, the original view followed by the business view. That would make sense.


8.2.3 PROD/DEV 826 TEST
AIX, DB2 All Outputs
 
Posts: 14 | Registered: July 06, 2016Report This Post
Virtuoso
posted Hide Post
Actually, what I do is create a vanilla master file without any of the extras (i.e. column name, usage and actuals) and then I create a new master file and reference the base master above. Then in that new master file I add the BV or DV and decompose the master. You end up with a pair of masters but if you change something in the base master file you don't lose DEFINEs COMPUTEs et cetera by refreshing it.


WebFOCUS 8206, Unix, Windows
 
Posts: 1853 | Location: New York City | Registered: December 30, 2015Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     (SOLVED) Issues with metadata on 8203

Copyright © 1996-2020 Information Builders