Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

Join the TIBCO Community
TIBCO Community is a collaborative space for users to share knowledge and support one another in making the best use of TIBCO products and services. There are several TIBCO WebFOCUS resources in the community.

  • From the Home page, select Predict: WebFOCUS to view articles, questions, and trending articles.
  • Select Products from the top navigation bar, scroll, and then select the TIBCO WebFOCUS product page to view product overview, articles, and discussions.
  • Request access to the private WebFOCUS User Group (login required) to network with fellow members.

Former myibi community members should have received an email on 8/3/22 to activate their user accounts to join the community. Check your Spam folder for the email. Please get in touch with us at community@tibco.com for further assistance. Reference the community FAQ to learn more about the community.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Reporting Server Error - Too many messages

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[SOLVED] Reporting Server Error - Too many messages
 Login/Join
 
Gold member
posted
Hey guys, has anyone ever come across this error message? "Reporting Server Error - Too many messages" We have a few procedures that run by pulling some financial transaction data for a day or two (which is quite a bit) and it will run successfully, but if we expand the date range out past a certain point, we no longer get results and get the Reporting Server Error message.
Has anyone else ever run across this? Is there a setting somewhere that caps the returned results? I couldn't even find exactly what this error message referenced, so I am kind of in the dark as where to start. Any help would be greatly appreciated!
Thanks again,
LB
**We run 8.1.05M and on a windows OS

This message has been edited. Last edited by: FP Mod Chuck,


Version: 8.2.03M, OS/Platform: Windows 7 & 10, Output: Excel, pdf, html
 
Posts: 63 | Location: Liberty Lake, WA - USA | Registered: June 23, 2016Report This Post
Virtuoso
posted Hide Post
Try adding
-SET &ECHO = OFF;

at the beginning of your fex.

It's the first step


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
 
Posts: 2410 | Location: Montreal Area, Qc, CA | Registered: September 25, 2013Report This Post
Expert
posted Hide Post
This can occur when you have -SET &ECHO=ALL; or when a lot of error messages are generated - typically when data format error messages are generated.

Run the procedure for a day or two. If you're not generating an Excel or PDF file, then you should be able to View Source from your web browser. Look for any error messages. If there aren't any, increase the number of days by 1, try again, until you see errors in the "view source" results...


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Report This Post
Gold member
posted Hide Post
Okay, good tips so far!
If I put -SET &ECHO = OFF for my first line in the code, I get the following error message, regardless of the date range I put in;
'0 ERROR AT OR NEAR LINE 5 IN PROCEDURE ADHOCRQ FOCEXEC *
(FOC224) SYNTAX ERROR: PROMPT'

Here is part of the underlying code;
1. -SET &ECHO = OFF
2. -PROMPT &START_DTE.Start Date MMDDYYYY:.;
3. -PROMPT &END_DTE.End Date MMDDYYYY:.;
4. -*-PROMPT &DEP_AMT.Minimum Deposit Amount:.,
5. -*-PROMPT &WITH_AMT.Minimum Withdrawal Amount:.,
6. -*-PROMPT &NUM_DEPOSITS.Number of Deposits:.;
7. -*-PROMPT &NUM_WITHDRAWALS.Number of Withdrawals:.;
8. -*-PROMPT &TTL_DEP_AMT.Total Deposit Amount:.;
9. -*-PROMPT &TTL_WITH_AMT.Total Withdrawal Amount:.;
10. -DEFAULT &START_DTE ='0212017';
11. -DEFAULT &END_DTE ='02282017';
12. -DEFAULT &DEP_AMT = 150;
13. -DEFAULT &WITH_AMT = 150;
14. -DEFAULT &NUM_DEPOSITS = 2;
15. -DEFAULT &NUM_WITHDRAWALS = 2;
16. -DEFAULT &TTL_DEP_AMT = 300;
17. -DEFAULT &TTL_WITH_AMT = 300;
18. -SET &START_TRAN_DTE = EDIT(&START_DTE, '$$$$9999') | EDIT(&START_DTE, '99') | EDIT(&START_DTE, '$$99');
19. -SET &END_TRAN_DTE = EDIT(&END_DTE, '$$$$9999') | EDIT(&END_DTE, '99') | EDIT(&END_DTE, '$$99');
20. TABLE FILE A_TRANS_DLY
21. PRINT

The user who wrote this procedure has an output of xlsx open on the first report and then an xlsx close on the second report, I was unsuccessful at getting a final output in html to get the source code. I'd include the entire segment of code, but it's huge and probably not helpful for anyone else to see!

If I comment out the
-*-SET &ECHO = OFF
Then I get successful results with the above date range, file size about 17KB, if I update the date range to 02112017 - 02282017 (one additional day) that's when I am getting the "too many messages" error.


Version: 8.2.03M, OS/Platform: Windows 7 & 10, Output: Excel, pdf, html
 
Posts: 63 | Location: Liberty Lake, WA - USA | Registered: June 23, 2016Report This Post
Expert
posted Hide Post
Comment out the ON TABLE PCHOLD FORMAT XLSX OPEN and CLOSE so that you can see the source.

I have worked with WF for ages and have never used -PROMPT. I don't know why you're getting that error. Temporarily comment out these PROMPT commands and add -SET to set your start and end dates.

What's huge about the source code?

-SET &ECHO=OFF; will reduce the output to nothing...


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Report This Post
Virtuoso
posted Hide Post
-PROMPT is Mainframe green screen way of populating variables. WebFOCUS uses either HTML launch pages you have to create with App Studio Composer or let it Auto Prompt users to do the same thing. Are you porting this application from Mainframe?


WebFOCUS 8206, Unix, Windows
 
Posts: 1853 | Location: New York City | Registered: December 30, 2015Report This Post
Gold member
posted Hide Post
The -SET always needs to end with a ; to end the line

Hence why it is complaining about the next line since it isn't expecting another - command. So there isn't really an error on the -PROMPT.

Also, as Francis said is good to stop before the PCHOLD if still get the message error to see what messages it is adding.


WF: 8201, OS: Windows, Output: HTML, PDF, Excel
 
Posts: 78 | Registered: November 08, 2010Report This Post
Gold member
posted Hide Post
Thank you all for the support, a lot of these options have been really helpful in further troubleshooting this issue.

Here is the base of what error is generating;
On one of the joins within this procedure, it is set to join on an inner one-to-many. This is creating a lot of duplicates, and I think the reporting server can only handle so many of those 'duplicates in join' error messages. I am having our report writer go back and see if we can correct that join with a one-to-one, but still get valid results returned.
I have multiple lines of errors that return something similar to this (at least 100 rows of varying account #'s);
(FOC1072) DUPLICATES IN JOIN 'FROM' FIELD : EMPACCTS/1000020063

We are now focusing on trying to correct that join piece, so if anyone has further suggestions for that, I'll take whatever I can get!

Thanks again for being so responsive to this string!


Version: 8.2.03M, OS/Platform: Windows 7 & 10, Output: Excel, pdf, html
 
Posts: 63 | Location: Liberty Lake, WA - USA | Registered: June 23, 2016Report This Post
Expert
posted Hide Post
We may be able to help if you post the join...


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Report This Post
Expert
posted Hide Post
Hi LarissaB

My suggestion for using ECHO is to set it to OFF in a PROD environment, but for Development turn on ON, not ALL, unless you have problems tracking down an error.

ON will echo FOCUS commands, not Dialog Manager commands (- commands).

We have a bit of code here that detects which environment and sets the &ECHO appropriately.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Silver Member
posted Hide Post
You can also use
SET MESSAGE = OFF

I've had to use that when I was creating several thousand files in one report run.

Have a great day,
Emily


WF 8.1.05 on Windows machines
Backend: Informix, SQL and Oracle databases
 
Posts: 37 | Location: Houston, Texas | Registered: May 01, 2008Report This Post
Expert
posted Hide Post
quote:
We have a bit of code here that detects which environment and sets the &ECHO appropriately.

You could always use SET DEFECHO = OFF in your Prod environment edasprof.prf.

T
 
Posts: 5694 | Location: United Kingdom | Registered: April 08, 2004Report This Post
Expert
posted Hide Post
quote:
DEFECHO

That's a new one for me! Thanks.

This message has been edited. Last edited by: Francis Mariani,


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Report This Post
Expert
posted Hide Post
Larissa,

There is a setting within the admin console for Maximum Messages - which is normally 20000.

However, I would suggest finding out why you're getting so many messages and eradicate the cause rather than extend the max messages.

Keeping the date range (that fails) in place but limiting the recordset returned (using IF RECORDLIMIT EQ nnn) you may be able to see some of the messages being produced which may help.

T



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.07 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
 
Posts: 5694 | Location: United Kingdom | Registered: April 08, 2004Report This Post
Expert
posted Hide Post
quote:
DEFECHO


Nice, and useful.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Expert
posted Hide Post
I agree with T. [well, I could just put that line on a t-shirt!]
I up my max messages b/c I've got a big caster jcl , but I made sure there were not unneeded statements in that jcl, like ?FF or CHECK FILE or random -TYPE that I only need during development.




In Focus since 1979///7706m/5 ;wintel 2008/64;OAM security; Oracle db, ///MRE/BID
 
Posts: 3811 | Location: Manhattan | Registered: October 28, 2003Report This Post
Expert
posted Hide Post
quote:
I could just put that line on a t-shirt!

Smiler Good One Roll Eyes

I hope NOT to see that at summit this year! (you have to understand the context!)

Yes DHagen, that was this years first hint that I will again be presenting at Summit 2017 in Dallas - the unashamed plug will come later Wink Any chance that you will be there? It would be good to catch up.

T

This message has been edited. Last edited by: Tony A,



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.07 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
 
Posts: 5694 | Location: United Kingdom | Registered: April 08, 2004Report This Post
Expert
posted Hide Post
As for DEFECHO, it's one setting that I suggest to Customers, especially those that have disparate development groups that are geographically separated with different techniques and discipline in removing unnecessary -SET &ECHO = ALL; within their promoted code!

T



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.07 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
 
Posts: 5694 | Location: United Kingdom | Registered: April 08, 2004Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Reporting Server Error - Too many messages

Copyright © 1996-2020 Information Builders