Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at myibi@ibi.com and provide your corporate email address, company, and name.


Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Possible Error on: setMonetarySeparator(",");

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[SOLVED] Possible Error on: setMonetarySeparator(",");
 Login/Join
 
Member
posted
I get this error when I run a procedure with a graph in Developer. I even get it when I try to run some of the demo of Century Corp Executive Summary reports off the Welcome to WebFOCUS Site. Has anyone encountered this issue before? Any information could be helpful. Thanks.

This message has been edited. Last edited by: Kerry,


WebFOCUS DevStudio Client 7.6.11 on XP
 
Posts: 4 | Location: Northern Illinois, USA | Registered: May 14, 2008Report This Post
Expert
posted Hide Post
Larry,

What version are you running? It could be that it's not supported on that release.

There are no references in either of the WF graphics manual or the Perspectives for Java manual from THREED to "setMonetarySeparator".

Have you tried "setTextFormatPattern"?

T



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.07 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
 
Posts: 5694 | Location: United Kingdom | Registered: April 08, 2004Report This Post
Member
posted Hide Post
We are on WebFOCUS DevStudio 7.6.11 on Windows XP.

For the graph that we are trying to design in Developer Studio the setTextFormatPattern is already defaulted to "(getY1Label(),"#.##");" in the Text view.


WebFOCUS DevStudio Client 7.6.11 on XP
 
Posts: 4 | Location: Northern Illinois, USA | Registered: May 14, 2008Report This Post
Member
posted Hide Post
We discovered that our client may be running on newer version than the server and that is most likely the cause of our issue.


WebFOCUS DevStudio Client 7.6.11 on XP
 
Posts: 4 | Location: Northern Illinois, USA | Registered: May 14, 2008Report This Post
Gold member
posted Hide Post
There is a SET Command for Continental Decimal:
SET CDN = ON


WF 7703M, XP/Win7, MRE, RC, BID, PMF, HTML, PDF, Excel 2000/7/10
 
Posts: 73 | Location: NY | Registered: February 06, 2007Report This Post
Platinum Member
posted Hide Post
Larry - We had the same eror when we upgraded from 764 to 76-10 recently.

Fix is to insert this following line inside the style section of the 'graph file' step.

setReportParsingErrors(false);


-------------------------------------------------------------------------------------------------
Blue Cross & Blue Shield of MS
WF.76-10 on (WS2003 + WebSphere) / EDA on z/OS + DB2 + MS-SQL
MRE, BID, Dev. Studio, Self-Service apps & a dash of fun !! Music
 
Posts: 218 | Location: Jackson, MS | Registered: October 31, 2006Report This Post
Member
posted Hide Post
AlexU, we set CDN = ON but still had the same error.

BlueZone, the ‘setReportParsingErrors(false);’ statement did the trick for our DevStudio graph. We have graphs appearing now. Thanks!

Thanks to everyone that offered to help, I really appreciate it.


WebFOCUS DevStudio Client 7.6.11 on XP
 
Posts: 4 | Location: Northern Illinois, USA | Registered: May 14, 2008Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Possible Error on: setMonetarySeparator(",");

Copyright © 1996-2020 Information Builders