Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at myibi@ibi.com and provide your corporate email address, company, and name.


Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Testing WebFOCUS to Run from BATCH JCL

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[CLOSED] Testing WebFOCUS to Run from BATCH JCL
 Login/Join
 
Member
posted
can I call a WebFOCUS fex from a JCL batch job?

This message has been edited. Last edited by: <Kathryn Henning>,


FOCUS/WebFOCUS 7.6n and above
Windows, All Outputs
 
Posts: 9 | Registered: July 03, 2014Report This Post
Member
posted Hide Post
The answer is YES : anything is possible

How depends very much on what you're trying to do and which IBI software you have :
  • is your WebFOCUS a zOS installation (PDS or HFS deployment)
  • is your WebFOCUS a Windows installation

    For example from the zOS scheduling system OMVS it is pretty easy to start a Windows process that then call a Java program that runs a Report Caster schedule.
  •  
    Posts: 16 | Location: Information Builders France | Registered: May 22, 2003Report This Post
    Gold member
    posted Hide Post
    If you have FOCUS on the mainframe, AND you have WebFOCUS on Z/OS, you can simply use FOCUS and point to your WebFOCUS libraries in the JCL.
    If WebFOCUS is not on Z/OS, but you still have FOCUS, you can start FOCUS and from there do a hub-sub setup to get to your WebFOCUS fex.


    Diptesh
    WF 7.1.7 - AIX, MVS
     
    Posts: 79 | Location: Warren, NJ, USA | Registered: October 25, 2006Report This Post
    Member
    posted Hide Post
    I have WebFOCUS zOS installation. I am getting the following error when I try to run WebFOCUS from JCL. Is Batch supported?

    error:-
    F3F4 F6F0F27A 40859999 96994089 954099A3 |u=xxxx, pid=xxxxxx: error in rt|
    8540 89A24095 96A34081 939396A6 85844B40 |ctx: Batch mode is not allowed. |

    This message has been edited. Last edited by: Kalyan,


    FOCUS/WebFOCUS 7.6n and above
    Windows, All Outputs
     
    Posts: 9 | Registered: July 03, 2014Report This Post
      Powered by Social Strata  

    Read-Only Read-Only Topic

    Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Testing WebFOCUS to Run from BATCH JCL

    Copyright © 1996-2020 Information Builders