Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Adding new connection returns the error: (FOC1394) CONNECT FAILURE
Go
New
Search
Notify
Tools
Reply
  
[SOLVED] Adding new connection returns the error: (FOC1394) CONNECT FAILURE
 Login/Join
 
Member
posted
Hi,
I am trying to add new connection to Oracle database in WebFocus Server Console and getting the error when test it:

(FOC1400) SQLCODE IS 12154 (HEX: 00002F7A)
(FOC1394) CONNECT FAILURE
: ORA-12154: TNS:could not resolve the connect identifier specified
(FOC1405) SQL PREPARE ERROR.

The TNS name exists in tnsnames.ora file and I am able to connect to this database through SQL*Plus and TOAD successfully.

Can you please help me to identify the issue?
Thank you.

This message has been edited. Last edited by: Y&Y,


WebFocus 8.008, 7.7.X; Unix/Linux; Oracle 11g, DB2; SQL, PL/SQL, ETL
 
Posts: 22 | Registered: May 17, 2012Reply With QuoteReport This Post
Master
posted Hide Post
From the machine where you installed WebFOCUS, check if the environment variable ORACLE_HOME is valid. Is SQL Plus or TOAD installed in your local or in WF server machine? From where you tested the connectivity? Try connecting to DB from the machine where you have installed WebFOCUS.
If WF and DB are in separate machines. Then ensure some channel to connect those 2 machines.

Hope this helps.

Thanks,
Ram
 
Posts: 542 | Location: Dearborn, MI | Registered: June 03, 2009Reply With QuoteReport This Post
Member
posted Hide Post
Hi Ram,
Thank you for your directions.
I’ve got your point. We are working on it.
SQL Plus and TOAD installed in my local. I tried to use my ORACLE user id for that Database to create new connection from WF server.

Thanks.


WebFocus 8.008, 7.7.X; Unix/Linux; Oracle 11g, DB2; SQL, PL/SQL, ETL
 
Posts: 22 | Registered: May 17, 2012Reply With QuoteReport This Post
Member
posted Hide Post
Hi Ram,
The connection is established. Thank you for your help.
Regards.


WebFocus 8.008, 7.7.X; Unix/Linux; Oracle 11g, DB2; SQL, PL/SQL, ETL
 
Posts: 22 | Registered: May 17, 2012Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Adding new connection returns the error: (FOC1394) CONNECT FAILURE

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.