Focal Point
[CLOSED] How to POST

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/7971057331/m/5957091196

March 22, 2019, 01:58 PM
Shingles
[CLOSED] How to POST
Hello All,

I am having a problem where a user is selecting many values for a single parameter via a drop down list. None of the dashboard panels show up with anything, just a blank html page.

If I run the same report, but only use a subset of those selections, then no error shows up and it behaves like normal. So I suspect I hit some kind of character/byte limit with the parameters. And this page seems to support that. According to that page I have to use a POST, but I don't know how or where to do that.

Can someone point me in the right direction here?

Thank you folks!

This message has been edited. Last edited by: FP Mod Chuck,


WebFOCUS 8201, SP 0.1, Windows 7, HTML
March 24, 2019, 03:51 PM
Waz
We have the same problem, I've asked for an NFR to have the option to submit the reports via POST instead of GET, I think they are working on it.

We ended up either writing our own submit or adding some JS to check for the length and pop up an alert.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

March 25, 2019, 08:21 AM
Shingles
uuuh... NFR? What's that?

Nevermind... Non-Functional Requirement. So I'm guessing this means right now there is no way to use POST?

This message has been edited. Last edited by: Shingles,


WebFOCUS 8201, SP 0.1, Windows 7, HTML
March 25, 2019, 03:45 PM
Waz
New
Feature
Request


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!