Focal Point
***CLOSED Quick FML - Blank Line

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/7971057331/m/6067024276

August 29, 2014, 08:42 AM
RobertF
***CLOSED Quick FML - Blank Line
I could not find an answer to this on my search...

I want blank lines on my FML report. The problem is I always get a zero on the row wherever I have an amount column. This is what I am doing:

' ' LABEL BLNK10 OVER

or this:

' ' AS ' ' LABEL BLNK 20


My coworker was actually getting a dot (.) at one point and got rid of it with a SET NODATA commannd. Thats not working for me.

Can someone help me with the syntax or tell whats causing the zero to appear?

This message has been edited. Last edited by: RobertF,


WebFOCUS 8.
Windows, All Outputs
August 29, 2014, 09:16 AM
Alan B
The official way is:
" " LABEL blank01 OVER

or I use:
RECAP  LINE01/A20 = ' ';     AS ''

where the LABEL for formatting will be LINE01.


Alan.
WF 7.705/8.007
August 29, 2014, 10:04 AM
RobertF
quote:
" " LABEL blank01 OVER

I tried this..it indeed adds a row, but it places a zero in the amount column

I'll try to illustrate this using report output for car brands and quantites:

I started with this:

fords.....50
toyotas...100
nisans....35



I want this:

CARS
.
fords.....50
toyotas...100
nisans....35


With: " " LABEL blank01 OVER I get this:

CARS......0

fords.....50
toyotas...100
nisans....35


WebFOCUS 8.
Windows, All Outputs
August 29, 2014, 10:15 AM
HarryLo
Hi Robert, please try the following:
"CAR" LABEL R1 OVER
" " LABEL R2 OVER
'DATSUN' AS 'DATSUN' LABEL R3 OVER
'PEUGEOT' AS 'PEUGEOT' LABEL R4 OVER
'JAGUAR' AS 'JAGUAR' LABEL R5


WebFOCUS 7.6
Windows, All Outputs
August 29, 2014, 10:29 AM
RobertF
Ahhh...I was using single quotes!


WebFOCUS 8.
Windows, All Outputs