Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

New TIBCO Community Coming Soon
In early summer, TIBCO plans to launch a new community—with a new user experience, enhanced search, and expanded capabilities for member engagement with answers and discussions! In advance of that, the current myibi community will be retired on April 30. We will continue to provide updates here on both the retirement of myibi and the new community launch.

What You Need to Know about Our New Community
We value the wealth of knowledge and engagement shared by community members and hope the new community will continue cultivating networking, knowledge sharing, and discussion.

During the transition period, from April 20th until the new community is launched this summer, myibi users should access the TIBCO WebFOCUS page to engage.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Moving MR Realm DB from Internal to SQL Server

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[SOLVED] Moving MR Realm DB from Internal to SQL Server
 Login/Join
 
Guru
posted
I trying to move our MR users into SQL Server.
I've successfully created the SQL database and tables. I imported the users and groups using .csv files into the tables. The issue I am having is that the Mangaged Reporting Administration application is not displaying the users. It sees them but not showing them.
The groups and domains show up just fine.
In the screenshot it sees the 256 users but only shows 1 of them in the list. I refreshed the WF Admin Console cache and recycled Tomcat.
Still does not fix the issue. If I create a new user using the MR Administartion tool they show up in the list. It's just that the users I inserted into the tables manually do not show up. I don't want to recreate all of the users. Any ideas?
Users missing from MR Administration

This message has been edited. Last edited by: Mighty Max,


WebFOCUS 8.1.05M Unix Self-Service/MRE/Report Caster - Outputs Excel, PDF, HTML, Flat Files
 
Posts: 320 | Location: Memphis, TN | Registered: February 12, 2008Report This Post
Platinum Member
posted Hide Post
Turn on MR Realm traces and log into the MR Administration console where things display.

Within the traces look for the word "null". Most likely you haven't populated something that you need to populate.

To figure out what you're missing, compare a user that displays properly in the list from a user that doesn't display properly in the list.


WF 71.x, 76.x, 7701, 8.0 Beta OS: Linux, Win2k3, Win2k, Win2k8, WinXP


 
Posts: 203 | Registered: November 19, 2007Report This Post
Guru
posted Hide Post
No luck. The trace says that it successfully retrieves all the users.

  
0:0:=================================================================
1:0:   trace opened Thu May 26 11:48:15 EDT 2011
2:0:=================================================================
3:0:ibi.htmlua.web.WFA_Controller.doPost(WFA_Controller.java:733):session auth: MC45MDUyMDA5MjY0NjYxNDk4, req auth: MC45MDUyMDA5MjY0NjYxNDk4
4:0:ibi.htmlua.web.WFA_Controller.logRequest(WFA_Controller.java:2050):********************************************
5:0:ibi.htmlua.web.WFA_Controller.logRequest(WFA_Controller.java:2051):       New WFA Request
6:0:ibi.htmlua.web.WFA_Controller.logRequest(WFA_Controller.java:2052):--------------------------------------------
7:0:ibi.htmlua.web.WFA_Controller.logRequest(WFA_Controller.java:2054):Request Parameters: 
8:0:ibi.htmlua.web.WFA_Controller.logRequest(WFA_Controller.java:2060):WFA_SES_AUTH_ID=MC45MDUyMDA5MjY0NjYxNDk4
9:0:ibi.htmlua.web.WFA_Controller.logRequest(WFA_Controller.java:2060):WFA_RequestType=getExistingUsers
10:0:ibi.htmlua.web.WFA_Controller.logRequest(WFA_Controller.java:2062):--------------------------------------------
11:0:ibi.htmlua.web.WFA_Controller.logRequest(WFA_Controller.java:2065):Session Id = 5053B596BA74728061AE2169E9055427
12:0:ibi.htmlua.service.WFA_AdministrationServiceMRAPIImpl.getNumberOfUsers(WFA_AdministrationServiceMRAPIImpl.java:363):Retrieving number of users
13:15:ibi.htmlua.service.WFA_AdministrationServiceMRAPIImpl.getNumberOfUsers(WFA_AdministrationServiceMRAPIImpl.java:371):User count is <254> for pattern <*>
14:15:ibi.htmlua.service.WFA_AdministrationServiceMRAPIImpl.searchUsers(WFA_AdministrationServiceMRAPIImpl.java:331):Peforming user search for pattern <*>
15:15:ibi.htmlua.service.WFA_AdministrationServiceMRAPIImpl.getMRRoleMap(WFA_AdministrationServiceMRAPIImpl.java:1078):Successfully retrieved all roles
16:47:ibi.htmlua.service.WFA_AdministrationServiceMRAPIImpl.searchUsers(WFA_AdministrationServiceMRAPIImpl.java:357):Successfully searched users
17:47:=================================================================
18:47:   trace closed Thu May 26 11:48:15 EDT 2011
19:47:=================================================================


0:0:=================================================================
1:0:   trace opened Thu May 26 11:49:43 EDT 2011
2:0:=================================================================
3:0:ibi.htmlua.web.WFA_Controller.doPost(WFA_Controller.java:733):session auth: MC45MDUyMDA5MjY0NjYxNDk4, req auth: MC45MDUyMDA5MjY0NjYxNDk4
4:0:ibi.htmlua.web.WFA_Controller.logRequest(WFA_Controller.java:2050):********************************************
5:0:ibi.htmlua.web.WFA_Controller.logRequest(WFA_Controller.java:2051):       New WFA Request
6:0:ibi.htmlua.web.WFA_Controller.logRequest(WFA_Controller.java:2052):--------------------------------------------
7:16:ibi.htmlua.web.WFA_Controller.logRequest(WFA_Controller.java:2054):Request Parameters: 
8:16:ibi.htmlua.web.WFA_Controller.logRequest(WFA_Controller.java:2060):WFA_SES_AUTH_ID=MC45MDUyMDA5MjY0NjYxNDk4
9:16:ibi.htmlua.web.WFA_Controller.logRequest(WFA_Controller.java:2060):WFA_RequestType=searchUsers
10:16:ibi.htmlua.web.WFA_Controller.logRequest(WFA_Controller.java:2060):WFA_Pattern=*
11:16:ibi.htmlua.web.WFA_Controller.logRequest(WFA_Controller.java:2060):WFA_PatternType=description
12:16:ibi.htmlua.web.WFA_Controller.logRequest(WFA_Controller.java:2060):WFA_PageNumber=2
13:16:ibi.htmlua.web.WFA_Controller.logRequest(WFA_Controller.java:2062):--------------------------------------------
14:16:ibi.htmlua.web.WFA_Controller.logRequest(WFA_Controller.java:2065):Session Id = 5053B596BA74728061AE2169E9055427
15:16:ibi.htmlua.service.WFA_AdministrationServiceMRAPIImpl.getNumberOfUsers(WFA_AdministrationServiceMRAPIImpl.java:363):Retrieving number of users
16:16:ibi.htmlua.service.WFA_AdministrationServiceMRAPIImpl.getNumberOfUsers(WFA_AdministrationServiceMRAPIImpl.java:371):User count is <254> for pattern <*>
17:16:ibi.htmlua.service.WFA_AdministrationServiceMRAPIImpl.searchUsers(WFA_AdministrationServiceMRAPIImpl.java:331):Peforming user search for pattern <*>
18:16:ibi.htmlua.service.WFA_AdministrationServiceMRAPIImpl.getMRRoleMap(WFA_AdministrationServiceMRAPIImpl.java:1078):Successfully retrieved all roles
19:47:ibi.htmlua.service.WFA_AdministrationServiceMRAPIImpl.searchUsers(WFA_AdministrationServiceMRAPIImpl.java:357):Successfully searched users
20:47:=================================================================
21:47:   trace closed Thu May 26 11:49:43 EDT 2011
22:47:=================================================================


WebFOCUS 8.1.05M Unix Self-Service/MRE/Report Caster - Outputs Excel, PDF, HTML, Flat Files
 
Posts: 320 | Location: Memphis, TN | Registered: February 12, 2008Report This Post
Platinum Member
posted Hide Post
That's a MR Admin trace.

You want the MR Realm trace. The MR Realm trace should iterate through all the users within the trace and show what parameters were pulled.


WF 71.x, 76.x, 7701, 8.0 Beta OS: Linux, Win2k3, Win2k, Win2k8, WinXP


 
Posts: 203 | Registered: November 19, 2007Report This Post
Guru
posted Hide Post
I found the problem thanks to your help.
The problems appears to have been with the column ROLE_ID in WF_MRUSERS.
When I imported the users I add too many spaces in the ROLE_ID. ie. 'User ' instead of 'User'.

I stumbled upon this by comparing the users in the MR Realm trace.
[2011-05-26 01:09:04 EDT] {DEBUG} [WFMRX_DBSecurityManager] >createUserProfileList: Debra xxxxx|98961|#User                                            |parmrpt,robot,library,email=xxxxx@gmail.com                                            
[2011-05-26 01:09:04 EDT] {DEBUG} [WFMRX_DBSecurityManager] >createUserProfileList: Default Administrator|admin|#MRAdministrator|library,parmrpt,robot,rcadmin,shared,email=admin@company.com  

See the extra whitespace is the RoleID of User Debra compared to the Default Admin.

Thanks Again! I would have never figured this out.


WebFOCUS 8.1.05M Unix Self-Service/MRE/Report Caster - Outputs Excel, PDF, HTML, Flat Files
 
Posts: 320 | Location: Memphis, TN | Registered: February 12, 2008Report This Post
Platinum Member
posted Hide Post
Excellent! I'm glad to hear it worked out.

Troubleshooting problems from manual inserts can be really annoying.


WF 71.x, 76.x, 7701, 8.0 Beta OS: Linux, Win2k3, Win2k, Win2k8, WinXP


 
Posts: 203 | Registered: November 19, 2007Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Moving MR Realm DB from Internal to SQL Server

Copyright © 1996-2020 Information Builders