Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     compound pdf and report caster
Go
New
Search
Notify
Tools
Reply
  
compound pdf and report caster
 Login/Join
 
Virtuoso
posted
We have created a few compound reports.
One is a combination of 3 small tables, a graph, again two small tables and then a two pages list.
It works very well from the dashboard.
Now we want to send these reports via reportcaster and run into problems.
If I remove the two small tables (after the graph) it works, but with these two it does not.

An other report only has two small tables (all from the same dataset) and it does not work.

I have put command &ECHO=ALL on top of both reports and I get the whole logging in my "error" report, but there is no error!
The report is send to my email but when I want to open the attached pdf (which is very small) I get an adobe message that says something like "unable to open, not a proper pdf file"

Any suggestions or thoughts?




Frank

prod: WF 7.6.10 platform Windows,
databases: msSQL2000, msSQL2005, RMS, Oracle, Sybase,IE7
test: WF 7.6.10 on the same platform and databases,IE7

 
Posts: 2387 | Location: Amsterdam, the Netherlands | Registered: December 03, 2006Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Frank I have had that problem before with PDF and reportcaster and strange characters like ~ . Strange thing was it didn't happen all the time...so I could never narrow it down. I don't think I've seen it in 7.6, did you try it there?

oh and also carrige returns.


In Focus since 1993. WebFOCUS 7.7.03 Win 2003
 
Posts: 1903 | Location: San Antonio | Registered: February 28, 2005Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Prarie

I was not able to test it, our test platform is not jet up to date, and we mis some functionality there (like mail)




Frank

prod: WF 7.6.10 platform Windows,
databases: msSQL2000, msSQL2005, RMS, Oracle, Sybase,IE7
test: WF 7.6.10 on the same platform and databases,IE7

 
Posts: 2387 | Location: Amsterdam, the Netherlands | Registered: December 03, 2006Reply With QuoteReport This Post
Master
posted Hide Post
When you created your graphs, did you save them as a .gif and incorporate them into a PDF?


Pat
WF 7.6.8, AIX, AS400, NT
AS400 FOCUS, AIX FOCUS,
Oracle, DB2, JDE, Lotus Notes
 
Posts: 755 | Location: TX | Registered: September 25, 2007Reply With QuoteReport This Post
Virtuoso
posted Hide Post
No

The graphs are separate reports and save as png.
But they work as expected.




Frank

prod: WF 7.6.10 platform Windows,
databases: msSQL2000, msSQL2005, RMS, Oracle, Sybase,IE7
test: WF 7.6.10 on the same platform and databases,IE7

 
Posts: 2387 | Location: Amsterdam, the Netherlands | Registered: December 03, 2006Reply With QuoteReport This Post
Master
posted Hide Post
Keep in mind that when you run the reports thru Report Caster it is not WebFocus trying to open the file it is Adobe PDF. For your Report Caster program table a file (any file) and put your image in a heading, then save that report PDF. The graph for this was held as GIF1 in a previous step.
TABLE FILE RGNTNDR
BY RGN NOPRINT
HEADING
" "
FOOTING BOTTOM
"Percentage of Tenders by Region for &HD1.EVAL thru &HD2.EVAL"
ON TABLE SET PAGE-NUM OFF
ON TABLE PCHOLD FORMAT PDF   
ON TABLE SET STYLE *

UNITS=IN,
PAGESIZE='Letter',
LEFTMARGIN=0.00000,
RIGHTMARGIN=0.500000,
TOPMARGIN=1.000000,
BOTTOMMARGIN=0.500000,
SQUEEZE=ON,
ORIENTATION=LANDSCAPE,$
$
TYPE=HEADING,
IMAGE=GIF1,
JUSTIFY=RIGHT,
$
TYPE=FOOTING,
JUSTIFY=CENTER,
STYLE=BOLD,
FONT=ARIAL,
SIZE=14,
$
ENDSTYLE 
END



Pat
WF 7.6.8, AIX, AS400, NT
AS400 FOCUS, AIX FOCUS,
Oracle, DB2, JDE, Lotus Notes
 
Posts: 755 | Location: TX | Registered: September 25, 2007Reply With QuoteReport This Post
Virtuoso
posted Hide Post
PB

my report is a bit more complex and as said, the graph works, but some smaller tables after the graph gives me the trouble.

-* File 070629FA_compoundpdf1.fex
-* Default Mode: ResourceLayout
-* wordt aangeroepen vanuit: 07026fa 0707006f 070706fa teamlist.fex
-*orientatie ampervariabel, LANDSCAPE of PORTRAIT
SET PANEL=400
SET WIDTH=400
-SET &ORIENT='PORTRAIT';
-DEFAULT &CRMTEAM='$*';
-DEFAULT &CRMTEAM='USA';
-INCLUDE app/070628fa
-RUN
-SET &TEXTJE = IF '&CRMTEAM.EVAL' EQ '$*' THEN 'Overview all teams' ELSE 'Team overview '|&CRMTEAM;
-*SET &TEAMNAME = IF '&CRMTEAM.EVAL' EQ '$*' THEN 'all teams' ELSE '&CRMTEAM.EVAL';
-INCLUDE app/070626fc
-RUN
COMPOUND LAYOUT
UNITS=CM, $
SECTION=section1, LAYOUT=ON, MERGE=OFF, ORIENTATION=PORTRAIT, PAGESIZE=A4, $
pagelayout=1, name='Layout page 1', $
object=string, name='text1', text=&TEXTJE.EVAL, position=(0.8 1.3), WRAP=OFF, dimension=(3.653 0.742), font='ARIAL', color=RGB(70 96 149), style=bold, size=14, $
object=image, name='image1', image=Goudzon.gif, position=(18.522 0.450), dimension=(1.798 1.798), $
object=box, name='line1', position=(0.8 1.50), dimension=(17.463 0.09), backcolor=RGB(70 96 149), border-color=RGB(70 96 149), $
object=string, name='text12', text='&DATEtrMDYY', position=(17 28.814), WRAP=ON, dimension=(3.942 0.478),  font='ARIAL', color=RGB(70 96 149),  SIZE=10,  $
component='report1', type=report, position=(0.8 1.2), dimension=(17.461 3), $
-*component='report2', type=report, position=(9 3.5), dimension=(9 7.5), $
component='report3', type=report, position=(0.8 3.5), dimension=(8 7.0), $
component='graph1', type=report, position=(0.8 9.3), dimension=(18.522 8.113), $
component='report4', type=report, position=(0.8 15.5), dimension=(18.522 5.5), $
component='report5', type=report, position=(0.8 19.5), dimension=(18.522 5.5), $
component='report6', type=report, position=(0.8 23.5), dimension=(18.522 5.5), $
pagelayout=2, name='Layout page 2', $
object=box, name='line2', position=(0.8 1.5), dimension=(17.463 0.09), backcolor=RGB(70 96 149), border-color=RGB(70 96 149), $
object=string, name='text2', text='&DATEtrMDYY', position=(17 28.814), WRAP=OFF, dimension=(3.942 0.478),  font='ARIAL', color=RGB(70 96 149),  SIZE=10,  $
object=string, name='text3', text=&TEXTJE.EVAL, position=(0.8 1.3), WRAP=OFF, dimension=(3.653 0.742), font='ARIAL', color=RGB(70 96 149), style=bold, size=14, $
object=image, name='image2', image=Goudzon.gif, position=(18.522 0.450), dimension=(1.798 1.798), $
component='report7', type=report, position=(0.8 1), dimension=(18.522 29),overflow-position=(0.8 1),overflow-dimension=(18.522 29), $
END
SET COMPONENT='report1'
-*component_type report
-INCLUDE app/070628fc
SET COMPONENT='report3'
-*component_type report detail per klasse
-INCLUDE app/070626fd
SET COMPONENT='graph1'
-*component_type graph
-INCLUDE app/070626fc
TABLE FILE HOLDBAS2
" "
BY MAAND NOPRINT
ON TABLE SET PAGE-NUM NOLEAD
IF RECORDLIMIT EQ 1
ON TABLE PCHOLD FORMAT PDF
ON TABLE SET STYLE *
type=HEADING, IMAGE=TEAMGRAP.svg, position=(0 0), $
END
SET COMPONENT='DefaultComponent'
-*RETENTION
SET COMPONENT='report4'
-*component_type report
-INCLUDE app/070628fd
-*MIGRATION
SET COMPONENT='report5'
-*component_type report
-INCLUDE app/070628fe
-* percentages inspanningen
-SET &BASEJAAR=&&LPD_JAAR;
-SET &VORIGJAAR=&&VRG_JAAR;
SET COMPONENT='report6'
-*component_type report
-INCLUDE app/070911ta
SET COMPONENT='report7'
-*component_type report lijst met clienten en provisie totalen
-INCLUDE app/070625fb
COMPOUND END



But I understand that without the included files this is dificult to solv.

My idee now is that some of the included programs are build as an accross report and that might cause the problem.

Any help would be welcome.




Frank

prod: WF 7.6.10 platform Windows,
databases: msSQL2000, msSQL2005, RMS, Oracle, Sybase,IE7
test: WF 7.6.10 on the same platform and databases,IE7

 
Posts: 2387 | Location: Amsterdam, the Netherlands | Registered: December 03, 2006Reply With QuoteReport This Post
Guru
posted Hide Post
Frank, I've got a wild guess, if you open the report trough the dashboard, you use your local Adobe.
If you use reportcaster, WebFOCUS uses the server Adobe or an interal PDF writer, I'm not sure which one. This can explain why you have these problems.

You could try to upgrade the Adobe on the server, but this won't help you if there's an internal PDF writer.


Test: WF 8.2
Prod: WF 8.2
DB: Progress, REST, IBM UniVerse/UniData, SQLServer, MySQL, PostgreSQL, Oracle, Greenplum, Athena.
 
Posts: 454 | Location: Europe | Registered: February 05, 2007Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Frans

If this was the reason, the compound report would not work at all, but I have several good working reports.

thx for the suggestion




Frank

prod: WF 7.6.10 platform Windows,
databases: msSQL2000, msSQL2005, RMS, Oracle, Sybase,IE7
test: WF 7.6.10 on the same platform and databases,IE7

 
Posts: 2387 | Location: Amsterdam, the Netherlands | Registered: December 03, 2006Reply With QuoteReport This Post
Master
posted Hide Post
Frank,

I realize I sent a very simple example, it is one step out of a compound report that prints 5 graphs.

I think Frans has it backward, if you are opening from Dashboard you are on the WebFocus internal PDF writer and if you are opening from your email you are on your local Adobe.

Since I'm on 5.3 here I can't even test this for you, all I can do is make suggestions. If you run the program through the dashboard can you save it and then open it again? When you save it, is it the same size as the file that is emailed? (You said it was small, are you sure it's not empty?) What if you save it and then email it to yourself? (Okay, I know I'm grasping with that one, but let's eliminate your email server). If you remove the two smaller reports at the end and the list, so that you have just the 3 small tables and the graph can you open it after it has been emailed? If you can, try running the small tables individually. If you can't, try running the other components individually. By checking the individual components you will find if you have one that isn't working through report caster. One final question, do you have any compound reports that have been created through the layout painter that you can email and open in PDF?


Pat
WF 7.6.8, AIX, AS400, NT
AS400 FOCUS, AIX FOCUS,
Oracle, DB2, JDE, Lotus Notes
 
Posts: 755 | Location: TX | Registered: September 25, 2007Reply With QuoteReport This Post
Member
posted Hide Post
Frank,

Just an idea before I go to bed...

Using Reportcaster:
1. First run the webfocus request to produce the PDF on the server.
2. Then run a second RC request to email it.

zzzzzzzz


Paul Burridge
Senior Consultant
34 years with Information Builders
WebFOCUS 8.2.5 Win10
 
Posts: 17 | Location: The Netherlands | Registered: February 21, 2005Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Paul

Nice idea and I thought of that too, but since I want the reports be sent with bursting it was a bit to complex.

Meanwhile we have found what caused the problem.

In one of the included subreports I used "MORE" in a single report that works if you put the collected data after the MORE command first into a new holdfile, and use the holdfile as a new source, and if these holdfiles do not have the same names. The compound report gets a bit confused when using the same names.

After changing all the internal holdfiles to unique names we got it working.

Thanks for all the helpfull hints and suggestions.




Frank

prod: WF 7.6.10 platform Windows,
databases: msSQL2000, msSQL2005, RMS, Oracle, Sybase,IE7
test: WF 7.6.10 on the same platform and databases,IE7

 
Posts: 2387 | Location: Amsterdam, the Netherlands | Registered: December 03, 2006Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     compound pdf and report caster

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.