Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] REST Webservices throws 403 error
Go
New
Search
Notify
Tools
Reply
  
[CLOSED] REST Webservices throws 403 error
 Login/Join
 
Platinum Member
posted
Hi,

We are started getting these issues after changing the Saml SSO setting from AD to Azure AD.

(FOC44540) Web Services Request got error. Response Status : 403 ; Reason: Forbidden

Tested this link and it is working.
http://hostname:8080/ibi_apps/rs?IBIRS_action=TEST

We are using POST request and confirmed that CSRF token is generating and the configuration on Admin Console shows CSRF is enforced. Recently we switched the SAML SSO from AD to Azure AD. After that, this is stopped working. Do I need to look anything else on the configuration?

Thanks for your help

This message has been edited. Last edited by: FP Mod Chuck,


8.2.06
Windows, All Formats
 
Posts: 183 | Registered: December 27, 2013Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Anyone faced this issue. Any ideas or suggestions or comments on this topic.


8.2.06
Windows, All Formats
 
Posts: 183 | Registered: December 27, 2013Reply With QuoteReport This Post
Guru
posted Hide Post
Did you check if there is anything in the logs? event.log, websecurity, audit.log?

Are you using the Rest adapter or the WebFOCUS Client rest adapter?


Test: WF 8.2
Prod: WF 8.2
DB: Progress, REST, IBM UniVerse/UniData, SQLServer, MySQL, PostgreSQL, Oracle, Greenplum, Athena.
 
Posts: 454 | Location: Europe | Registered: February 05, 2007Reply With QuoteReport This Post
Platinum Member
posted Hide Post
We are using REST adapter.

Yes, I did check the logs and it shows nothing.


8.2.06
Windows, All Formats
 
Posts: 183 | Registered: December 27, 2013Reply With QuoteReport This Post
Guru
posted Hide Post
When you see nothing in logs (also check the Tomcat access logs) then it's likely that a firewall is preventing traffic.


Test: WF 8.2
Prod: WF 8.2
DB: Progress, REST, IBM UniVerse/UniData, SQLServer, MySQL, PostgreSQL, Oracle, Greenplum, Athena.
 
Posts: 454 | Location: Europe | Registered: February 05, 2007Reply With QuoteReport This Post
Gold member
posted Hide Post
Hi Guys,

We faced the same issue and after a meeting with the CLOUD team we figured out there were some network rules issues.
Please look at the firewall rules enforced in your NETWORK as if there is an issue from the WebFOCUS side you should have got something in event.log.

Thanks


Webfocus 8.x
Windows
PDF,HTML,XLSX
 
Posts: 56 | Location: India | Registered: June 01, 2018Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] REST Webservices throws 403 error

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.