Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CASE OPENED] HTML Output Type No Longer Working in 82
Go
New
Search
Notify
Tools
Reply
  
[CASE OPENED] HTML Output Type No Longer Working in 82
 Login/Join
 
Platinum Member
posted
Everyone,

On Friday, I developed some tables with a user-selected output type of HTML and Excel as choices in the dropdown listing.

Everything worked inside AppStudio on Friday.
On Monday, the HTML type no longer worked although the Excel type worked without incident.

There were no changes to the code. The code seems to break with the EVAL function.

Does anyone have thoughts?

This message has been edited. Last edited by: FP Mod Chuck,


WebFocus 8.2.04
WebFocus 8.2.04

 
Posts: 154 | Registered: September 18, 2015Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Do you get an error? What doesn't work?


WebFOCUS 8206, Unix, Windows
 
Posts: 1720 | Location: New York City | Registered: December 30, 2015Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Does the code still ran under the same version 8105 ?
I know that some stuff that was running okay under 8105 does not anymore under 8204 such as some specific cases where .EVAL is used

Please share your code and sql traces if possible


WF versions : Prod 8.2.0.1M gen 240, Dev 8.2.04 gen 48, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
 
Posts: 2234 | Location: Montreal Area, Qc, CA | Registered: September 25, 2013Reply With QuoteReport This Post
Master
posted Hide Post
Does this work in your environment?

-SET &WFFMT = &WFFMT.(<'Web Page',HTML>,<Excel,XLSX>).Select Report Output.;

TABLE FILE car
SUM SALES
BY COUNTRY
BY CAR 
ON TABLE PCHOLD FORMAT &WFFMT.EVAL
END  


Hallway
WF(Prod):8202M
WF(Test):8202M
OS/Platform:Win 10
Outputs:All
 
Posts: 495 | Location: Salt Lake City, UT, USA | Registered: November 18, 2015Reply With QuoteReport This Post
Expert
posted Hide Post
I think we need more information.

Can you post your code ?

Is this related to HTMLFORMTYPE ?


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.06OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Know The Code

 
Posts: 6136 | Location: 33.8688° S, 151.2093° E | Registered: October 31, 2006Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Everyone,

I appreciate the replies. I no longer think this is a coding issue as it occurs with some older fexes that do not use the .EVAL function. It seem as if no matter what table I go to, I experience the same behavior. I have started a case with IBI to see if we can narrow down the issue.


WebFocus 8.2.04
WebFocus 8.2.04

 
Posts: 154 | Registered: September 18, 2015Reply With QuoteReport This Post
Platinum Member
posted Hide Post
While I work with IBI on the case (and I know many IBI employees are traveling home from Summit 2019), I thought I'd post additional information.

I have tables inside AppStudio, some of which are newly created and some of which have existed for quite some time. One set utilizes .EVAL; one set does not utilize .EVAL. In fact, the second set of tables is quite simple.

The tables all ran inside AppStudio on Friday, May 31. The tables were linked to HTML documents.

On Monday, June 3, I ran the same tables inside AppStudio. None of the tables will render in HTML format; however, they will render and download in Excel format without incident.

What's peculiar is that all tables render inside the portal admin and online for us. Additionally, our graphs and charts render inside HTML documents inside AppStudio without incident.


There were three updates made to our environment on Friday. They all seem to be Windows Server updates.


I'm curious if anyone has experienced any odd behavior with Windows updates and AppStudio. In the meantime, I'm going to post some additional information to my case.

Thanks!


WebFocus 8.2.04
WebFocus 8.2.04

 
Posts: 154 | Registered: September 18, 2015Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CASE OPENED] HTML Output Type No Longer Working in 82

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.