Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

New TIBCO Community Coming Soon
In early summer, TIBCO plans to launch a new community—with a new user experience, enhanced search, and expanded capabilities for member engagement with answers and discussions! In advance of that, the current myibi community will be retired on April 30. We will continue to provide updates here on both the retirement of myibi and the new community launch.

What You Need to Know about Our New Community
We value the wealth of knowledge and engagement shared by community members and hope the new community will continue cultivating networking, knowledge sharing, and discussion.

During the transition period, from April 20th until the new community is launched this summer, myibi users should access the TIBCO WebFOCUS page to engage.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] PDF Compound Layout Report Issue

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[SOLVED] PDF Compound Layout Report Issue
 Login/Join
 
Platinum Member
posted
I get the following error when including a 4th report in my Compound Layout section for a PDF report:

(FOC3281) COMPOUND REPORT: MISSING CLOSE OR ERROR IN FINAL REPORT

The first 3 reports run successfully in the Compound Layout When I add the 4th report I get the error. The first 3 are reports and the 4th is a bar chart. They all run fine individually. Here's the code for the PDF Layout:

  
SET PAGE-NUM=OFF
SET SQUEEZE=ON
COMPOUND LAYOUT PCHOLD FORMAT PDF
SECTION=S1, LAYOUT=ON, MERGE=OFF, ORIENTATION=LANDSCAPE, $
PAGELAYOUT=1, TOC-LEVEL=1, BOTTOMMARGIN=0.0, TOPMARGIN=0.0, ORIENTATION=LANDSCAPE, METADATA='BOTTOMMARGIN=0,TOPMARGIN=0,LEFTMARGIN=0,RIGHTMARGIN=0,ORIENTATION=LANDSCAPE,', $
COMPONENT=R1, TYPE=REPORT, POSITION=(1 1), DIMENSION=(4 4), $
COMPONENT=R2, TYPE=REPORT, POSITION=(5 1), DIMENSION=(4 4), $
COMPONENT=R3, TYPE=REPORT, POSITION=(7 1), DIMENSION=(4 4), $
COMPONENT=R4, TYPE=REPORT, POSITION=(1 4), DIMENSION=(* *), $
END
SET COMPONENT=R1
EX  IBFS:/WFC/Repository/PMR/ValueBasedPayment/PMR_vbp_est_pymt.fex
SET COMPONENT=R2
EX  IBFS:/WFC/Repository/PMR/ValueBasedPayment/PMR_vbp_per_pot_pymnt.fex
SET COMPONENT=R3
EX  IBFS:/WFC/Repository/PMR/ValueBasedPayment/PMR_vbp_prov_select.fex
SET COMPONENT=R4
EX  IBFS:/WFC/Repository/PMR/ValueBasedPayment/PMR_vbp_estvspot_chart.fex
COMPOUND END

This message has been edited. Last edited by: FP Mod Chuck,


WebFOCUS 8.2.06
SQL Server
HTML, PDF, Excel, etc
 
Posts: 168 | Registered: August 22, 2019Report This Post
Platinum Member
posted Hide Post
Does anyone know if there's anything that needs to be done differently for charts/graphs when including them in a PDF Compound Layout? Anyone has any ideas?


WebFOCUS 8.2.06
SQL Server
HTML, PDF, Excel, etc
 
Posts: 168 | Registered: August 22, 2019Report This Post
Virtuoso
posted Hide Post
Based on displayed error, it seems that your fourth one is the problem.

This is not a TYPE=REPORT, you have a graph. Instead of adding a graph component you have added a report
COMPONENT=R4, COMPONENT-TYPE=GRAPH, POSITION=(1 4), DIMENSION=(* *), $


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
 
Posts: 2410 | Location: Montreal Area, Qc, CA | Registered: September 25, 2013Report This Post
Platinum Member
posted Hide Post
MartinY - Thanks...I overlooked using GRAPH as the TYPE.

Have to add another report after the graph. I'll look to do that.


WebFOCUS 8.2.06
SQL Server
HTML, PDF, Excel, etc
 
Posts: 168 | Registered: August 22, 2019Report This Post
Platinum Member
posted Hide Post
It appears that the font at the individual fex level is overridden in the PDF Compound Layout. That is what it appears to be doing I believe.

Does anyone know exactly where to set the font in the code for the Compound Layout?


WebFOCUS 8.2.06
SQL Server
HTML, PDF, Excel, etc
 
Posts: 168 | Registered: August 22, 2019Report This Post
Virtuoso
posted Hide Post
quote:
Originally posted by AMC2:
It appears that the font at the individual fex level is overridden in the PDF Compound Layout. That is what it appears to be doing I believe.

I doubt that this is the case. AFAIK there is nothing to in Compound to change the font. Each report can have its own font/format/styling.
If you create a new HTML/Document then select Document (PDF, Excel...) from the File Type you will end up in a Compound Layout designer and you have no choice to globally assign a font.

Maybe you different reports are overlapping each other but I doubt that PDF Compound override the individual font


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
 
Posts: 2410 | Location: Montreal Area, Qc, CA | Registered: September 25, 2013Report This Post
Platinum Member
posted Hide Post
MartinY - You are correct...it's not that the Compound Layout is overriding the font I found out. I am using open sans font in my individual reports and it was not being invoked when generating the PDF Compound Layout. It would default to another font and I thought it was the Compound Layout affecting it.

However, I found out from one of our admins that I needed to use the open sans font this way...."OPEN SANS" for PDF within the reports. It needs to be specified with a space between "Open" and "Sans" for it to take effect for PDFs.


WebFOCUS 8.2.06
SQL Server
HTML, PDF, Excel, etc
 
Posts: 168 | Registered: August 22, 2019Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] PDF Compound Layout Report Issue

Copyright © 1996-2020 Information Builders